aboutsummaryrefslogtreecommitdiffstats
path: root/finance/gnucash
diff options
context:
space:
mode:
authormadpilot <madpilot@FreeBSD.org>2014-10-05 21:32:37 +0800
committermadpilot <madpilot@FreeBSD.org>2014-10-05 21:32:37 +0800
commit737c49f3250e375a1cec537707ea574778afd4f3 (patch)
tree0450a40fdc2cc4346761115846dfdd3e0d50dccb /finance/gnucash
parent0878978fec60f769483735f18cf24a76e071623a (diff)
downloadfreebsd-ports-gnome-737c49f3250e375a1cec537707ea574778afd4f3.tar.gz
freebsd-ports-gnome-737c49f3250e375a1cec537707ea574778afd4f3.tar.zst
freebsd-ports-gnome-737c49f3250e375a1cec537707ea574778afd4f3.zip
- Fix gnucash configure script to accept guile 1.8
- Add options to gnucash port to choose which guile version to use - Remove superceded UPDATING entry Approved by: kwm (gnome, implicit)
Diffstat (limited to 'finance/gnucash')
-rw-r--r--finance/gnucash/Makefile16
-rw-r--r--finance/gnucash/files/patch-configure10
2 files changed, 23 insertions, 3 deletions
diff --git a/finance/gnucash/Makefile b/finance/gnucash/Makefile
index 50c51a8824a8..e51f45374af3 100644
--- a/finance/gnucash/Makefile
+++ b/finance/gnucash/Makefile
@@ -3,6 +3,7 @@
PORTNAME= gnucash
PORTVERSION= 2.6.4
+PORTREVISION= 1
CATEGORIES= finance gnome
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}%20%28stable%29/${PORTVERSION}
@@ -12,22 +13,25 @@ COMMENT= Quicken-like money and finance manager
LICENSE= GPLv2 GPLv3
LICENSE_COMB= dual
-BUILD_DEPENDS= guile:${PORTSDIR}/lang/guile2
LIB_DEPENDS= libgnome-keyring.so:${PORTSDIR}/security/libgnome-keyring \
libwebkitgtk-1.0.so:${PORTSDIR}/www/webkit-gtk2 \
libgoffice-0.8.so:${PORTSDIR}/devel/goffice
-RUN_DEPENDS= guile:${PORTSDIR}/lang/guile2 \
- p5-libwww>=0:${PORTSDIR}/www/p5-libwww \
+RUN_DEPENDS= p5-libwww>=0:${PORTSDIR}/www/p5-libwww \
p5-Date-Manip>=0:${PORTSDIR}/devel/p5-Date-Manip \
p5-Finance-Quote>=0:${PORTSDIR}/finance/p5-Finance-Quote
OPTIONS_DEFINE= AQBANKING OFX DATABASE LOCALE_TAX PYTHON GTKMM DOCS
+OPTIONS_SINGLE= GV
+OPTIONS_SINGLE_GV= GUILE1 GUILE2
+OPTIONS_DEFAULT= GUILE1
AQBANKING_DESC= AqBanking support (HBCI/OpenHBCI)
OFX_DESC= OFX support
DATABASE_DESC= Enable SQL database backends
LOCALE_TAX_DESC= Enable localized tax categories
GTKMM_DESC= Enable GTKMM based UI
+GUILE1_DESC= Use lang/guile
+GUILE2_DESC= Use lang/guile2
OPTIONS_SUB= yes
AQBANKING_CONFIGURE_ENABLE=aqbanking
@@ -47,6 +51,12 @@ PYTHON_USE= PYTHON=yes
GTKMM_USE= GNOME=gtkmm24
GTKMM_CONFIGURE_ON= --enable-gtkmm
GTKMM_CONFIGURE_OFF= --disable-gtkmm
+GUILE1_LIB_DEPENDS= libguile.so:${PORTSDIR}/lang/guile
+GUILE1_BUILD_DEPENDS= ${LOCALBASE}/share/guile/1.8/slibcat:${PORTSDIR}/lang/slib-guile
+GUILE1_RUN_DEPENDS= ${LOCALBASE}/share/guile/1.8/slibcat:${PORTSDIR}/lang/slib-guile
+GUILE2_LIB_DEPENDS= libguile-2.0.so:${PORTSDIR}/lang/guile2
+GUILE2_BUILD_DEPENDS= ${LOCALBASE}/share/guile/2.0/slibcat:${PORTSDIR}/lang/slib-guile2
+GUILE2_RUN_DEPENDS= ${LOCALBASE}/share/guile/2.0/slibcat:${PORTSDIR}/lang/slib-guile2
USE_XORG= x11
USES= desktop-file-utils gettext gmake libtool perl5 pkgconfig shebangfix tar:bzip2
diff --git a/finance/gnucash/files/patch-configure b/finance/gnucash/files/patch-configure
new file mode 100644
index 000000000000..2d0b08e6f5b0
--- /dev/null
+++ b/finance/gnucash/files/patch-configure
@@ -0,0 +1,10 @@
+--- configure.orig 2014-09-28 02:56:29.000000000 +0200
++++ configure 2014-10-05 01:43:56.028480737 +0200
+@@ -20513,6 +20513,7 @@
+ { $as_echo "$as_me:${as_lineno-$LINENO}: result: yes" >&5
+ $as_echo "yes" >&6; }
+ succeeded=yes
++ GUILE_EFFECTIVE_VERSION=1.8
+
+ { $as_echo "$as_me:${as_lineno-$LINENO}: checking GUILE_CFLAGS" >&5
+ $as_echo_n "checking GUILE_CFLAGS... " >&6; }