aboutsummaryrefslogtreecommitdiffstats
path: root/finance/grisbi/Makefile
diff options
context:
space:
mode:
authorthierry <thierry@FreeBSD.org>2010-06-09 04:31:53 +0800
committerthierry <thierry@FreeBSD.org>2010-06-09 04:31:53 +0800
commit3f7f4157f2ceab8fbcacffe75108bf91db03fd97 (patch)
tree5dd998d5c2c065b69ce40f71eb702b4da4fe40de /finance/grisbi/Makefile
parent11dfccd77ea466ecc25a86ce3f364d4bcb48ee37 (diff)
downloadfreebsd-ports-gnome-3f7f4157f2ceab8fbcacffe75108bf91db03fd97.tar.gz
freebsd-ports-gnome-3f7f4157f2ceab8fbcacffe75108bf91db03fd97.tar.zst
freebsd-ports-gnome-3f7f4157f2ceab8fbcacffe75108bf91db03fd97.zip
Upgrade to 0.6.
Changelog at <http://www.grisbi.org/changelog.en.html>.
Diffstat (limited to 'finance/grisbi/Makefile')
-rw-r--r--finance/grisbi/Makefile19
1 files changed, 8 insertions, 11 deletions
diff --git a/finance/grisbi/Makefile b/finance/grisbi/Makefile
index 135653785306..03eb18ac6b82 100644
--- a/finance/grisbi/Makefile
+++ b/finance/grisbi/Makefile
@@ -6,27 +6,22 @@
#
PORTNAME= grisbi
-PORTVERSION= 0.5.9
-PORTREVISION= 7
+PORTVERSION= 0.6.0
CATEGORIES= finance
-MASTER_SITES= SF
+MASTER_SITES= SF/${PORTNAME}/${PORTNAME}%20${PORTVERSION}/${PORTVERSION}/
MAINTAINER= thierry@FreeBSD.org
COMMENT= A personnal accounting application
-LIB_DEPENDS= ofx.4:${PORTSDIR}/finance/libofx
-.if !defined(WITHOUT_LATEX)
-RUN_DEPENDS= ${UCS_CLASSDIR}/ucs.sty:${PORTSDIR}/print/latex-ucs
-.endif
+LIB_DEPENDS= ofx.4:${PORTSDIR}/finance/libofx \
+ ssl.7:${PORTSDIR}/security/openssl
USE_BZIP2= yes
USE_ICONV= yes
USE_GMAKE= yes
GNU_CONFIGURE= yes
USE_GNOME= gtk20 glib20 libxml2
-
-TEXMFDIR?= share/texmf
-UCS_CLASSDIR= ${LOCALBASE}/${TEXMFDIR}/tex/latex/ucs
+INSTALLS_ICONS= yes
MAN1= grisbi.1
@@ -42,8 +37,10 @@ PLIST_SUB+= NLS=""
.endif
pre-configure:
+ ${REINPLACE_CMD} -e "s|-lpthread|${PTHREAD_LIBS}|g" \
+ ${WRKSRC}/${CONFIGURE_SCRIPT}
.if defined(NOPORTDOCS)
- @${REINPLACE_CMD} -e "s|pixmaps help|pixmaps|" ${WRKSRC}/Makefile.in
+ ${REINPLACE_CMD} -e "s|pixmaps help|pixmaps|" ${WRKSRC}/Makefile.in
.endif
.include <bsd.port.mk>