aboutsummaryrefslogtreecommitdiffstats
path: root/finance/grisbi/Makefile
diff options
context:
space:
mode:
authorthierry <thierry@FreeBSD.org>2004-05-25 00:52:43 +0800
committerthierry <thierry@FreeBSD.org>2004-05-25 00:52:43 +0800
commitfa35f4498112d02fee47a798e38eee88aa8251c6 (patch)
treed89dc997213147997b6edc49649f62e3b5f505d3 /finance/grisbi/Makefile
parent3618514740491c73391ed9a40e9a2b4bbd39e52a (diff)
downloadfreebsd-ports-gnome-fa35f4498112d02fee47a798e38eee88aa8251c6.tar.gz
freebsd-ports-gnome-fa35f4498112d02fee47a798e38eee88aa8251c6.tar.zst
freebsd-ports-gnome-fa35f4498112d02fee47a798e38eee88aa8251c6.zip
Upgrade to 0.5.0 and de-gnomify.
Diffstat (limited to 'finance/grisbi/Makefile')
-rw-r--r--finance/grisbi/Makefile29
1 files changed, 14 insertions, 15 deletions
diff --git a/finance/grisbi/Makefile b/finance/grisbi/Makefile
index ac43146eee52..2883eb8dc5d9 100644
--- a/finance/grisbi/Makefile
+++ b/finance/grisbi/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= grisbi
-PORTVERSION= 0.4.5
-PORTREVISION= 1
+PORTVERSION= 0.5.0
CATEGORIES= finance
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -15,25 +14,25 @@ MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= thierry@FreeBSD.org
COMMENT= A personnal accounting application
+LIB_DEPENDS= ofx.0:${PORTSDIR}/finance/libofx
+.if !defined(WITHOUT_LATEX)
+RUN_DEPENDS= ${UCS_CLASSDIR}/ucs.sty:${PORTSDIR}/print/latex-ucs
+.endif
+
+USE_BZIP2= yes
USE_GETTEXT= yes
USE_ICONV= yes
-USE_X_PREFIX= yes
USE_GMAKE= yes
-USE_GNOMENG= yes
-USE_GNOME= gtk12 libcapplet libxml gnomepanel orbit gdkpixbuf gnomelibs gnomeprint
-USE_BISON= yes
-USE_BZIP2= yes
-USE_AUTOCONF_VER= 213
+USE_GCC= 3.3
+GNU_CONFIGURE= yes
+USE_GNOME= gtk20 glib20 libxml2
+
+TEXMF?= share/texmf
+UCS_CLASSDIR= ${LOCALBASE}/${TEXMF}/tex/latex/ucs
MAN1= grisbi.1
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include ${PTHREAD_CFLAGS}" \
- LDFLAGS="-L${LOCALBASE}/lib ${PTHREAD_LIBS}" \
- AUTOHEADER="${AUTOHEADER}" AUTOCONF="${AUTOCONF}"
-
-post-install:
- @${ECHO_MSG}
- @${CAT} ${PKGMESSAGE} | ${SED} -e "s:%%PREFIX%%:${PREFIX}:"
- @${ECHO_MSG}
+ LDFLAGS="-L${LOCALBASE}/lib ${PTHREAD_LIBS}"
.include <bsd.port.mk>