aboutsummaryrefslogtreecommitdiffstats
path: root/finance/homebank/Makefile
diff options
context:
space:
mode:
authormezz <mezz@FreeBSD.org>2007-05-25 12:35:20 +0800
committermezz <mezz@FreeBSD.org>2007-05-25 12:35:20 +0800
commitad51f9c410f931d0ba988641e05712eafbff476c (patch)
treede946f0b74b288b84268544450556f51f35649a3 /finance/homebank/Makefile
parent917dbb0bac622a14e96b6650e9f49ec8c2fe295f (diff)
downloadfreebsd-ports-gnome-ad51f9c410f931d0ba988641e05712eafbff476c.tar.gz
freebsd-ports-gnome-ad51f9c410f931d0ba988641e05712eafbff476c.tar.zst
freebsd-ports-gnome-ad51f9c410f931d0ba988641e05712eafbff476c.zip
Update to 3.3.
Diffstat (limited to 'finance/homebank/Makefile')
-rw-r--r--finance/homebank/Makefile26
1 files changed, 19 insertions, 7 deletions
diff --git a/finance/homebank/Makefile b/finance/homebank/Makefile
index c3522b9e1527..5ef189480ffa 100644
--- a/finance/homebank/Makefile
+++ b/finance/homebank/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= homebank
-PORTVERSION= 3.2.1
-PORTREVISION= 1
+PORTVERSION= 3.3
CATEGORIES= finance
MASTER_SITES= http://homebank.free.fr/public/
@@ -17,27 +16,40 @@ COMMENT= Manage your personal accounts at home
USE_XLIB= yes
USE_GMAKE= yes
USE_GNOME= gtk20
+WANT_GNOME= yes
USE_GETTEXT= yes
+INSTALLS_ICONS= yes
GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib ${PTHREAD_LIBS}"
-EXTRACT_AFTER_ARGS= | ${TAR} -xf - --exclude autom4te.cache
-
DOCS= AUTHORS COPYING ChangeLog NEWS README
.include <bsd.port.pre.mk>
-.if ${OSVERSION} < 500000
-BROKEN= Does not build on FreeBSD 4.x
+.if ${HAVE_GNOME:Mgnomehier}!=""
+USE_GNOME= gnomehier
+PLIST_SUB+= GNOME:=""
+GNOME_ENABLED= yes
+.else
+PLIST_SUB+= GNOME:="@comment "
+.endif
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|[(]datadir[)]/application-registry|(prefix)/share/gnome/application-registry|g' \
+ ${WRKSRC}/mime/Makefile.in
+.ifndef (GNOME_ENABLED)
+ @${REINPLACE_CMD} -e 's|install-appDATA install|install|g' \
+ ${WRKSRC}/mime/Makefile.in
.endif
-.ifndef (NOPORTDOCS)
post-install:
+.ifndef (NOPORTDOCS)
@${MKDIR} ${DOCSDIR}
.for i in ${DOCS}
@${INSTALL_DATA} ${WRKSRC}/${i} ${DOCSDIR}
.endfor
.endif
+ @-update-desktop-database
.include <bsd.port.post.mk>