aboutsummaryrefslogtreecommitdiffstats
path: root/finance/kmymoney-kde4/Makefile
diff options
context:
space:
mode:
authorsylvio <sylvio@FreeBSD.org>2010-03-02 08:07:06 +0800
committersylvio <sylvio@FreeBSD.org>2010-03-02 08:07:06 +0800
commit02b872d93b97513b0918565b9951f6db77e9263c (patch)
treee917ec997c8c23e865c6f42e2e3cc9e74001703f /finance/kmymoney-kde4/Makefile
parentc04f872b71a1d46e5d2fc469d57445ed3cfcaefa (diff)
downloadfreebsd-ports-gnome-02b872d93b97513b0918565b9951f6db77e9263c.tar.gz
freebsd-ports-gnome-02b872d93b97513b0918565b9951f6db77e9263c.tar.zst
freebsd-ports-gnome-02b872d93b97513b0918565b9951f6db77e9263c.zip
- Update to 1.0.3
- Add new dependencies - Changed NOPORTS to stay of accord with the default. PR: ports/139347 Submitted by: Oleg Sidorkin <OSidorkin@gmail.com> Approved by: maintainer (timeout > 60 days), itetcu (mentor) Feature safe: yes
Diffstat (limited to 'finance/kmymoney-kde4/Makefile')
-rw-r--r--finance/kmymoney-kde4/Makefile20
1 files changed, 11 insertions, 9 deletions
diff --git a/finance/kmymoney-kde4/Makefile b/finance/kmymoney-kde4/Makefile
index 4935bd0156b1..a1e263d83695 100644
--- a/finance/kmymoney-kde4/Makefile
+++ b/finance/kmymoney-kde4/Makefile
@@ -6,16 +6,16 @@
#
PORTNAME= kmymoney2
-PORTVERSION= 0.8.9
-PORTREVISION= 4
+PORTVERSION= 1.0.3
CATEGORIES= finance
MASTER_SITES= SF/${PORTNAME}/KMyMoney/${PORTVERSION}
MAINTAINER= alecn2002@yandex.ru
COMMENT= KDE-based personal finance assistant
+BUILD_DEPENDS= bash:${PORTSDIR}/shells/bash \
+
LIB_DEPENDS= osp.5:${PORTSDIR}/textproc/opensp
-BUILD_DEPENDS= bash:${PORTSDIR}/shells/bash
LIB_DEPENDS+= ofx.4:${PORTSDIR}/finance/libofx
@@ -39,18 +39,20 @@ DOCSDIR= ${PREFIX}/share/doc/HTML/en/${PORTNAME}
.include <bsd.port.pre.mk>
-.if defined(NOPORTDOCS)
-CONFIGURE_ARGS= --enable-ofxplugin --enable-ofxbanking
-EXTRA_PATCHES= ${FILESDIR}/extra-patch-Makefile.in \
- ${FILESDIR}/extra-patch-doc__en__Makefile.in
-.else
+.if !defined(NOPORTDOCS)
CONFIGURE_ARGS= --enable-ofxplugin --enable-ofxbanking --enable-pdf-docs
# Add more build-time dependencies to generate the PDF docs
BUILD_DEPENDS+= jade:${PORTSDIR}/textproc/jade \
pdfjadetex:${PORTSDIR}/print/jadetex \
html2ps:${PORTSDIR}/print/html2ps-letter \
- dsssl-docbook-modular>=0:${PORTSDIR}/textproc/dsssl-docbook-modular
+ dsssl-docbook-modular>=0:${PORTSDIR}/textproc/dsssl-docbook-modular \
+ cppunit-config:${PORTSDIR}/devel/cppunit \
+ recode:${PORTSDIR}/converters/recode
+.else
+CONFIGURE_ARGS= --enable-ofxplugin --enable-ofxbanking
+EXTRA_PATCHES= ${FILESDIR}/extra-patch-Makefile.in \
+ ${FILESDIR}/extra-patch-doc__en__Makefile.in
.endif
post-patch: