aboutsummaryrefslogtreecommitdiffstats
path: root/finance/libofx/Makefile
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2005-09-01 06:16:42 +0800
committerpav <pav@FreeBSD.org>2005-09-01 06:16:42 +0800
commit8e2afb1a77b87089e16890deaee5f318772cd2ef (patch)
treeddc03b1006457a460f76aaa5323aefc11879a018 /finance/libofx/Makefile
parentd3d9b5c486e3dfb478e9f6118394f05884f21280 (diff)
downloadfreebsd-ports-gnome-8e2afb1a77b87089e16890deaee5f318772cd2ef.tar.gz
freebsd-ports-gnome-8e2afb1a77b87089e16890deaee5f318772cd2ef.tar.zst
freebsd-ports-gnome-8e2afb1a77b87089e16890deaee5f318772cd2ef.zip
- Update to 0.8.0
PR: ports/85532 Submitted by: KATO Tsuguru <tkato432@yahoo.com>
Diffstat (limited to 'finance/libofx/Makefile')
-rw-r--r--finance/libofx/Makefile15
1 files changed, 9 insertions, 6 deletions
diff --git a/finance/libofx/Makefile b/finance/libofx/Makefile
index e8ed11cb50bd..54824f827c22 100644
--- a/finance/libofx/Makefile
+++ b/finance/libofx/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= libofx
-PORTVERSION= 0.7.0
+PORTVERSION= 0.8.0
CATEGORIES= finance
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -14,18 +14,21 @@ MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= ports@FreeBSD.org
COMMENT= OpenSource implementation of the OFX (Open Financial eXchange)
-LIB_DEPENDS= osp.3:${PORTSDIR}/textproc/opensp
+LIB_DEPENDS= curl.3:${PORTSDIR}/ftp/curl \
+ osp.3:${PORTSDIR}/textproc/opensp
USE_GMAKE= yes
USE_GNOME= gnometarget
-USE_LIBTOOL_VER= 15
USE_GETOPT_LONG= yes
-CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
- LDFLAGS="-L${LOCALBASE}/lib"
-CONFIGURE_ARGS= --disable-doxygen --disable-dot \
+USE_LIBTOOL_VER= 15
+CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
+CONFIGURE_ARGS= --disable-doxygen --disable-dot --disable-gengetopt \
--with-opensp-includes=${LOCALBASE}/include/OpenSP
INSTALLS_SHLIB= yes
+CPPFLAGS= -I${LOCALBASE}/include
+LDFLAGS= -L${LOCALBASE}/lib
+
post-install:
.if !defined(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}