aboutsummaryrefslogtreecommitdiffstats
path: root/finance/openhbci
diff options
context:
space:
mode:
authorarved <arved@FreeBSD.org>2005-01-10 01:24:23 +0800
committerarved <arved@FreeBSD.org>2005-01-10 01:24:23 +0800
commit1d96bdea2365fcbc0aadc608637c65f5b190ed99 (patch)
tree34c14bd9f3c5004e9bc386c202c52277e9387a88 /finance/openhbci
parent453a1e8c30edb71e3a55aefeda66902bc564d398 (diff)
downloadfreebsd-ports-gnome-1d96bdea2365fcbc0aadc608637c65f5b190ed99.tar.gz
freebsd-ports-gnome-1d96bdea2365fcbc0aadc608637c65f5b190ed99.tar.zst
freebsd-ports-gnome-1d96bdea2365fcbc0aadc608637c65f5b190ed99.zip
Fix build on 5.x
PR: 75769 Submitted by: Frerich Raabe <frerich@athame.co.uk>
Diffstat (limited to 'finance/openhbci')
-rw-r--r--finance/openhbci/Makefile8
-rw-r--r--finance/openhbci/files/patch-tree.h23
2 files changed, 24 insertions, 7 deletions
diff --git a/finance/openhbci/Makefile b/finance/openhbci/Makefile
index 3c1309675fd3..a70d26e9a444 100644
--- a/finance/openhbci/Makefile
+++ b/finance/openhbci/Makefile
@@ -18,10 +18,4 @@ GNU_CONFIGURE= yes
CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
INSTALLS_SHLIB= yes
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} >= 502126
-BROKEN= "Does not compile on FreeBSD >= 5.x"
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/finance/openhbci/files/patch-tree.h b/finance/openhbci/files/patch-tree.h
new file mode 100644
index 000000000000..aaba14ce9d77
--- /dev/null
+++ b/finance/openhbci/files/patch-tree.h
@@ -0,0 +1,23 @@
+--- src/openhbci/tree.h.orig Mon Jan 3 23:31:35 2005
++++ src/openhbci/tree.h Mon Jan 3 23:28:50 2005
+@@ -695,16 +695,16 @@
+ * Returns an iterator that points to the root of the tree.
+ * @author Martin Preuss<martin@aquamaniac.de>
+ */
+- Tree<T>::iterator root() {
+- return Tree<T>::iterator(&_root);
++ iterator root() {
++ return iterator(&_root);
+ };
+
+ /**
+ * Returns an const_iterator that points to the root of the tree.
+ * @author Martin Preuss<martin@aquamaniac.de>
+ */
+- Tree<T>::const_iterator const_root() const {
+- return Tree<T>::const_iterator(&_root);
++ const_iterator const_root() const {
++ return const_iterator(&_root);
+ };
+
+ /**