aboutsummaryrefslogtreecommitdiffstats
path: root/finance/opentaxsolver/Makefile
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2006-08-29 05:05:20 +0800
committerpav <pav@FreeBSD.org>2006-08-29 05:05:20 +0800
commit247f3fb1d955e3061ff497e02b58f846c49c5fa6 (patch)
tree332b7b58fae76831bb99c7f51152b7e78550f686 /finance/opentaxsolver/Makefile
parentb26648ef620b8f7f2feb4324fd29e0faeebd2bbb (diff)
downloadfreebsd-ports-gnome-247f3fb1d955e3061ff497e02b58f846c49c5fa6.tar.gz
freebsd-ports-gnome-247f3fb1d955e3061ff497e02b58f846c49c5fa6.tar.zst
freebsd-ports-gnome-247f3fb1d955e3061ff497e02b58f846c49c5fa6.zip
OpenTaxSolver (OTS) is a free program for calculating Tax Form
entries and tax-owed or refund-due, such as US Federal or State personal income taxes. An optional graphical front-end, OTS_GUI, has been added. Preliminary versions for Canada and the United Kingdom were posted in previous years and may be updated with help from volunteers. Motivations include: * To make tax preparation software available for all platforms. * To provide insight into how our taxes are calculated in clear unambiguous equations/code. * To avoid invasive, bloated commercial software packages. * To avoid rewriting our own individual programs each year by combining efforts. * To provide a simple reliable tax-package requiring only rudimentary knowledge to maintain. WWW: http://opentaxsolver.sourceforge.net/ PR: ports/95529 Submitted by: John Hein <jhein@timing.com>
Diffstat (limited to 'finance/opentaxsolver/Makefile')
-rw-r--r--finance/opentaxsolver/Makefile53
1 files changed, 53 insertions, 0 deletions
diff --git a/finance/opentaxsolver/Makefile b/finance/opentaxsolver/Makefile
new file mode 100644
index 000000000000..357fa4bc38a6
--- /dev/null
+++ b/finance/opentaxsolver/Makefile
@@ -0,0 +1,53 @@
+# Ports collection makefile for: opentaxsolver
+# Date created: Sat Apr 08, 2006
+# Whom: John Hein (jhein@timing.com)
+#
+# $FreeBSD$
+#
+
+PORTNAME= ${UPPORTNAME:L}
+PORTVERSION= 3.07
+CATEGORIES= finance
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= opentaxsolver
+DISTNAME= ${UPPORTNAME}2005_3.07
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= jhein@timing.com
+COMMENT= US tax prep software
+
+USE_XLIB= yes
+UPPORTNAME= OpenTaxSolver
+
+post-patch:
+ @${REINPLACE_CMD} -e 's/%%PREFIX%%/${PREFIX:C,/,\/,g}/' \
+ ${WRKSRC}/src/GUI/ots_gui.c
+
+do-build:
+ @(cd ${BUILD_WRKSRC}; ${SETENV} ${MAKE_ENV} \
+ ./Build_taxsolve_packages_LINUX.sh)
+
+BUILDPROGLISTCMD= ${FIND} bin -type f
+BUILDEXAMPLELISTCMD= ${FIND} examples_and_templates -type f
+NEWPLIST= ${WRKDIR}/plist.new
+
+do-install:
+ @(cd ${WRKSRC} && \
+ for prog in $$(${BUILDPROGLISTCMD}); do \
+ ${INSTALL_PROGRAM} $${prog} ${PREFIX}/bin/. ; \
+ done && \
+ ${MKDIR} ${PREFIX}/share/ots && \
+ ${INSTALL_DATA} src/GUI/otslogo.ppm ${PREFIX}/share/ots/. && \
+ for example in $$(${BUILDEXAMPLELISTCMD}); do \
+ ${MKDIR} ${PREFIX}/share/ots/$$(dirname $${example}) && \
+ ${INSTALL_DATA} $${example} \
+ ${PREFIX}/share/ots/$$(dirname $${example})/. ; \
+ done)
+
+new-plist:
+ @(cd ${WRKSRC} && \
+ ${BUILDPROGLISTCMD} > ${NEWPLIST} && \
+ ${ECHO_CMD} share/ots/otslogo.ppm >> ${NEWPLIST} && \
+ ${BUILDEXAMPLELISTCMD} | ${SED} 's,^,share/ots/,' >> ${NEWPLIST})
+
+.include <bsd.port.mk>