aboutsummaryrefslogtreecommitdiffstats
path: root/finance/p5-PayflowPro
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2007-10-28 19:47:36 +0800
committermiwi <miwi@FreeBSD.org>2007-10-28 19:47:36 +0800
commite8cc01109ca6862db75c1a24aa486886a4eeadee (patch)
tree761da434ed964d4f35d3757a71931e2f9b185b4d /finance/p5-PayflowPro
parent2f464976c98ef09b4434dbdf536a069e1e2a6d1c (diff)
downloadfreebsd-ports-gnome-e8cc01109ca6862db75c1a24aa486886a4eeadee.tar.gz
freebsd-ports-gnome-e8cc01109ca6862db75c1a24aa486886a4eeadee.tar.zst
freebsd-ports-gnome-e8cc01109ca6862db75c1a24aa486886a4eeadee.zip
Interface to HTTP gateway for PayPal's Payflow Pro service, as described on
the PayPal developer forums at http://www.pdncommunity.com/pdn/board?board.id=payflow This module is intended to be a drop-in replacement for PFProAPI (a couple of minor changes to your code are necessary to use this module instead of PFProAPI). The major difference is that it is pure Perl, and not architecture dependent (ie, you can use this on your 64-bit FreeBSD platform.) WWW: http://labs.mailermailer.com/downloads/ PR: ports/117460 Submitted by: Vivek Khera <vivek at khera.org>
Diffstat (limited to 'finance/p5-PayflowPro')
-rw-r--r--finance/p5-PayflowPro/Makefile33
-rw-r--r--finance/p5-PayflowPro/distinfo3
-rw-r--r--finance/p5-PayflowPro/pkg-descr10
3 files changed, 46 insertions, 0 deletions
diff --git a/finance/p5-PayflowPro/Makefile b/finance/p5-PayflowPro/Makefile
new file mode 100644
index 000000000000..41824ff77e66
--- /dev/null
+++ b/finance/p5-PayflowPro/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: p5-PayflowPro
+# Date created: Wed Oct 24 10:09:12 EDT 2007
+# Whom: Vivek Khera <vivek@khera.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= PayflowPro
+PORTVERSION= 1150
+CATEGORIES= finance perl5
+MASTER_SITES= CPAN
+MASTER_SITE_SUBDIR= ../by-authors/id/V/VK/VKHERA
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= vivek@khera.org
+COMMENT= Pure Perl PayflowPro payment gateway interface
+
+RUN_DEPENDS+= p5-libwww>0.0:${PORTSDIR}/www/p5-libwww
+BUILD_DEPENDS+= p5-libwww>0.0:${PORTSDIR}/www/p5-libwww
+
+PERL_CONFIGURE= yes
+USE_BZIP2= yes
+
+post-install:
+ ${INSTALL_DATA} ${WRKSRC}/ca-bundle.crt ${LOCALBASE}/etc
+
+MAN3= PayflowPro.3
+PLIST_FILES= etc/ca-bundle.crt \
+ %%SITE_PERL%%/PayflowPro.pm \
+ %%SITE_PERL%%/%%PERL_ARCH%%/auto/PayflowPro/.packlist
+PLIST_DIRS= %%SITE_PERL%%/%%PERL_ARCH%%/auto/PayflowPro
+
+.include <bsd.port.mk>
diff --git a/finance/p5-PayflowPro/distinfo b/finance/p5-PayflowPro/distinfo
new file mode 100644
index 000000000000..62680a0e6360
--- /dev/null
+++ b/finance/p5-PayflowPro/distinfo
@@ -0,0 +1,3 @@
+MD5 (PayflowPro-1150.tar.bz2) = 934f7e6c0a08bf6a1e5394ac071dc1c3
+SHA256 (PayflowPro-1150.tar.bz2) = d104d2e775719a64b7d20998e23b7193f2a34e5e1a0beb52f88ba4442add4295
+SIZE (PayflowPro-1150.tar.bz2) = 162816
diff --git a/finance/p5-PayflowPro/pkg-descr b/finance/p5-PayflowPro/pkg-descr
new file mode 100644
index 000000000000..a3a7a687d4a5
--- /dev/null
+++ b/finance/p5-PayflowPro/pkg-descr
@@ -0,0 +1,10 @@
+Interface to HTTP gateway for PayPal's Payflow Pro service, as described on
+the PayPal developer forums at
+http://www.pdncommunity.com/pdn/board?board.id=payflow
+
+This module is intended to be a drop-in replacement for PFProAPI (a couple of
+minor changes to your code are necessary to use this module instead of
+PFProAPI). The major difference is that it is pure Perl, and not architecture
+dependent (ie, you can use this on your 64-bit FreeBSD platform.)
+
+WWW: http://labs.mailermailer.com/downloads/