aboutsummaryrefslogtreecommitdiffstats
path: root/finance/qhacc
diff options
context:
space:
mode:
authorade <ade@FreeBSD.org>2000-09-17 01:56:00 +0800
committerade <ade@FreeBSD.org>2000-09-17 01:56:00 +0800
commitf8abdbd331337efcd9c2f8c42f09c455927561c7 (patch)
treed0410bba11606dac58c2a88fad70b349adfdbef5 /finance/qhacc
parent59e23a4052125c624ea170823f7fe77bf3052f88 (diff)
downloadfreebsd-ports-gnome-f8abdbd331337efcd9c2f8c42f09c455927561c7.tar.gz
freebsd-ports-gnome-f8abdbd331337efcd9c2f8c42f09c455927561c7.tar.zst
freebsd-ports-gnome-f8abdbd331337efcd9c2f8c42f09c455927561c7.zip
Update to 0.6
PR: 21283 Submitted by: Ports Fury
Diffstat (limited to 'finance/qhacc')
-rw-r--r--finance/qhacc/Makefile17
-rw-r--r--finance/qhacc/distinfo2
-rw-r--r--finance/qhacc/files/patch-aa11
-rw-r--r--finance/qhacc/files/patch-ab11
-rw-r--r--finance/qhacc/pkg-message10
-rw-r--r--finance/qhacc/pkg-plist7
6 files changed, 44 insertions, 14 deletions
diff --git a/finance/qhacc/Makefile b/finance/qhacc/Makefile
index cf84a1f3ab5b..db6a9d084136 100644
--- a/finance/qhacc/Makefile
+++ b/finance/qhacc/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= qhacc
-PORTVERSION= 0.5
+PORTVERSION= 0.6
CATEGORIES= misc
MASTER_SITES= ftp://ftp.ostrich-emulators.cx/qhacc/
@@ -15,18 +15,19 @@ MAINTAINER= ports@FreeBSD.org
USE_QT2= yes
USE_X_PREFIX= yes
GNU_CONFIGURE= yes
-CONFIGURE_ARGS+=--with-qt="${X11BASE}"
-MAKE_ENV+= QTDIR=${PREFIX} CXX="${CXX}" CC="${CC}"
+CONFIGURE_ARGS= --with-qt="${X11BASE}"
pre-build:
@${RM} -f ${WRKSRC}/src/moc_*.cpp
do-install:
- @${INSTALL_PROGRAM} ${WRKSRC}/src/qhacc ${PREFIX}/bin/qhacc.exec
- @${SED} -e "s:%%PREFIX%%:${PREFIX}:g" ${FILESDIR}/qhacc.sh \
- > ${PREFIX}/bin/qhacc
- @${CHMOD} 755 ${PREFIX}/bin/qhacc
+ ${INSTALL_PROGRAM} ${WRKSRC}/src/qhacc ${PREFIX}/bin
@${MKDIR} ${PREFIX}/share/qhacc
- @${INSTALL_DATA} ${FILESDIR}/config ${PREFIX}/share/qhacc/config.sample
+ ${INSTALL_DATA} ${FILESDIR}/config ${PREFIX}/share/qhacc/config.sample
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${PREFIX}/share/doc/qhacc
+ ${INSTALL_DATA} ${WRKSRC}/docs/*.html ${PREFIX}/share/doc/qhacc
+.endif
+ @${SED} -e "s:/usr/X11R6:${PREFIX}:g" ${PKGMESSAGE}
.include <bsd.port.mk>
diff --git a/finance/qhacc/distinfo b/finance/qhacc/distinfo
index 00d2c13d525c..775acb37b407 100644
--- a/finance/qhacc/distinfo
+++ b/finance/qhacc/distinfo
@@ -1 +1 @@
-MD5 (qhacc-0.5.tar.gz) = d8ece4da9d86a6cdd8444aaeed8987f4
+MD5 (qhacc-0.6.tar.gz) = 60596f6b31629b3be802cecd044393ac
diff --git a/finance/qhacc/files/patch-aa b/finance/qhacc/files/patch-aa
index bb6f62b9719e..6003ae37fcf8 100644
--- a/finance/qhacc/files/patch-aa
+++ b/finance/qhacc/files/patch-aa
@@ -1,6 +1,6 @@
---- src/Makefile.in Wed Apr 12 15:42:26 2000
-+++ src/Makefile.in.new Sat Apr 22 00:41:55 2000
-@@ -94,10 +94,10 @@
+--- src/Makefile.in.orig Sun Aug 27 10:24:42 2000
++++ src/Makefile.in Wed Sep 13 20:44:43 2000
+@@ -94,12 +94,12 @@
qhaccgrapher.h
@@ -12,5 +12,8 @@
+qhacc_LDADD = -lqt2
+MOC = $(QTDIR)/bin/moc2
- CXXFLAGS = -O2 -Wall $(MYFLAGS)
+-CXXFLAGS = -O2 -Wall $(MYFLAGS)
++CXXFLAGS = @CXXFLAGS@ $(MYFLAGS)
mkinstalldirs = $(SHELL) $(top_srcdir)/mkinstalldirs
+ CONFIG_HEADER = ../config.h
+ CONFIG_CLEAN_FILES =
diff --git a/finance/qhacc/files/patch-ab b/finance/qhacc/files/patch-ab
new file mode 100644
index 000000000000..c6fc49934823
--- /dev/null
+++ b/finance/qhacc/files/patch-ab
@@ -0,0 +1,11 @@
+--- configure.orig Mon Aug 21 05:14:11 2000
++++ configure Wed Sep 13 20:51:38 2000
+@@ -1255,7 +1255,7 @@
+
+ for dir in $with_qt
+ do
+- if test -f $dir/lib/libqt.so.2
++ if test -f $dir/lib/libqt2.so
+ then
+ qthome=$dir
+ echo "found in $dir"
diff --git a/finance/qhacc/pkg-message b/finance/qhacc/pkg-message
new file mode 100644
index 000000000000..8c0ab62f5892
--- /dev/null
+++ b/finance/qhacc/pkg-message
@@ -0,0 +1,10 @@
+************************************************************
+ Before running QHacc, users should prepare as follows:
+
+ $ mkdir ~/.qhacc
+ $ cp /usr/X11R6/share/qhacc/config.sample ~/.qhacc/config
+ $ chmod u+rw ~/.qhacc/config
+ $ export QHACC_HOME=~/.qhacc (sh or bash)
+ $ setenv QHACC_HOME ~/.qhacc (csh or tcsh)
+
+************************************************************
diff --git a/finance/qhacc/pkg-plist b/finance/qhacc/pkg-plist
index 4c4e15ad2ce6..bdb550a758a0 100644
--- a/finance/qhacc/pkg-plist
+++ b/finance/qhacc/pkg-plist
@@ -1,4 +1,9 @@
bin/qhacc
-bin/qhacc.exec
+share/doc/qhacc/index.html
+share/doc/qhacc/intro.html
+share/doc/qhacc/formats.html
+share/doc/qhacc/using.html
+share/doc/qhacc/primer.html
share/qhacc/config.sample
@dirrm share/qhacc
+@dirrm share/doc/qhacc
lass='insertions'>+2 * - Add CPE infoamdmi32015-06-041-1/+2 * - Strip binaryamdmi32015-06-041-0/+4 * - Update to 2.2.0jadawin2015-06-032-10/+4 * Security update to 1.6delphij2015-06-012-3/+3 * Update to GNU sharutils 4.15.2 (bugfix release)johans2015-05-312-3/+3 * Cleanup USE_GITHUB usage.mat2015-05-314-6/+6 * - Strip librariesamdmi32015-05-301-1/+7 * - Drop run dependency on sysutils/coreutils, checksums are nowpawel2015-05-272-26/+5 * Fix decompression in a pipeline: import fix from dev branch inriggs2015-05-254-0/+94 * Update to version 1.18.0pawel2015-05-234-74/+25 * Remove $FreeBSD$ from patches files in categories a-j.mat2015-05-223-8/+0 * - Update to 0.22sunpoet2015-05-222-3/+3 * Update to r129. Changes at https://github.com/Cyan4973/lz4/releases/tag/r129.adamw2015-05-202-7/+5 * - Add CPE infoamdmi32015-05-171-1/+2 * - Add CPE infoamdmi32015-05-161-1/+1 * - Add CPE infoamdmi32015-05-161-1/+2 * Reset 14 ocaml ports maintained by Jaap Boender per his requestmarino2015-05-161-1/+1 * MASTER_SITES cleanup.mat2015-05-1423-44/+26 * - Update to 0.21sunpoet2015-05-142-4/+5 * - Update to 0.24sunpoet2015-05-142-4/+3 * Cleanup DIST* variables.mat2015-05-123-5/+4 * - Update to 1.1.7sunpoet2015-05-113-4/+4 * - Strip libraryamdmi32015-05-091-1/+2 * Remove archivers/lz4, which has been marked DEPRECATED for 1 month.adamw2015-05-095-45/+0 * - Update to version 1.7.25pawel2015-05-084-7/+17 * archivers/kzip: update to 20150319 and allow on amd64jbeich2015-05-072-4/+5 * Update ports in the a* categories to not use GH_COMMIT.mat2015-05-064-11/+9 * archivers/lzrip: Fix build on DragonFly with USES=aliasmarino2015-05-011-1/+1 * Horde package update:mm2015-05-012-3/+3 * archivers/libcabinet: link with libzmarino2015-05-011-2/+2 * 1: Upgrade to 1.6.3.vanilla2015-04-292-4/+4 * USE_GITHUB: For the new support, fix DISTNAME to be more consistent.bdrewery2015-04-291-2/+2 * USES=xfce: Stop overriding MASTER_SITE_SUBDIR.bdrewery2015-04-292-4/+2 * - Add CPE infoamdmi32015-04-251-1/+2 * archivers/zip-ada: Upgrade version 48 => 49marino2015-04-223-14/+19 * Update to r128.adamw2015-04-204-7/+9 * - Add CPE infoamdmi32015-04-181-1/+2 * - Add CPE infoamdmi32015-04-181-1/+2 * Remove expired ports:rene2015-04-189-114/+0 * - Add CPE infoamdmi32015-04-171-0/+2 * archivers/bzip2: add CPE inforobak2015-04-161-0/+2 * - Add CPE infoamdmi32015-04-161-1/+2 * archivers/unzoo: add CPE inforobak2015-04-151-0/+1 * converters/libiconv:tijl2015-04-152-6/+5 * - Unbreak: it fetches fine now from Ken Silverman's page, there wasdanfe2015-04-122-11/+6 * n FreeBSD 8 the name of the mtime member of struct stat was st_mtimespec.truckman2015-04-122-4/+14 * Convert bsd.gnustep.mk to USES=gnustepbapt2015-04-092-8/+4 * archivers/lz4: Is it 2015 already?marino2015-04-091-1/+1 * Mark archivers/lz4 as deprecated and mark it for removal in 1 month.adamw2015-04-091-0/+3 * archivers/undms: Update MASTER_SITESbapt2015-04-071-4/+2 * Mark a few ports BROKEN in astro and archivers category (unfetchable)antoine2015-04-054-0/+8 * Mark as broken: no public distfilesbapt2015-04-051-0/+1 * Horde package update:mm2015-04-042-3/+3 * Update to 1.3.delphij2015-04-012-4/+4 * Add missed file in previous commit.delphij2015-04-011-0/+11 * Update to 0.621.delphij2015-04-013-5/+7 * CVE-2014-9112: Heap-based buffer overflow in the process_copy_innaddy2015-03-3110-12/+266 * Remove CENKES mirror (it is dead)bapt2015-03-311-1/+1 * Update to 1.0.7bapt2015-03-312-6/+8 * Add CPE information to Makefilegarga2015-03-311-1/+2 * archivers/libzip:makc2015-03-292-2/+18 * Update to 1.6.delphij2015-03-282-4/+4 * New port: archivers/py-python-snappyantoine2015-03-274-0/+27 * Update to 1.46.adamw2015-03-252-3/+3 * Re-add back ALL_TARGET=default. For reasons that I still don't understand,adamw2015-03-251-0/+1 * Update to r127. Fix tons of hardcoded paths in the Makefile to enableadamw2015-03-253-25/+19 * - Use -lpthread instead of -pthreadsunpoet2015-03-251-1/+1 * 8 ports categories: Remove $PTHREAD_LIBSmarino2015-03-242-2/+1 * Ubreak (see the new patch-math-remainder), resolve most of the warnings,mi2015-03-234-8/+397 * Add security fix for CVE-2014-8118johans2015-03-232-1/+16 * Add patches for the following CVEsflo2015-03-221-0/+12 * Update USE_GITHUB so it does not require GH_COMMIT.bdrewery2015-03-201-1/+1 * Use gmake instead of using rules that may or may not work depending of theantoine2015-03-181-2/+1 * Update gcab to 0.6.kwm2015-03-173-3/+4 * adding CPE information to Makefilejohans2015-03-171-2/+3 * - Cleanup Mk/bsd.ruby.mk and remove no-op knobs in ruby portssunpoet2015-03-141-1/+0 * Some OCD cleanups on some of the perl@ ports.adamw2015-03-137-13/+12 * Update KDE SC to 4.14.3alonso2015-03-122-2/+73 * - Add LICENSEamdmi32015-03-101-1/+5 * Update gcab to 0.5.kwm2015-03-104-52/+20 * Update to 9.38.1.rakuco2015-03-084-8/+18 * Gcab is a utility and library mainly made to create Cabinet files, usingkwm2015-03-076-0/+114 * The FreeBSD Xfce team proudly presents Xfce 4.12.olivierd2015-03-063-33/+8 * Add a patch to fix buffer overrun (CVE-2015-2063)rodrigo2015-03-052-2/+90 * Add CPE information.naddy2015-03-041-2/+3 * Add CPE information.naddy2015-03-041-2/+7 * Drop maintainership. The base system xz(1) have gained threadingdelphij2015-03-031-1/+1 * Remove Authors from pkg-descrbapt2015-03-037-13/+1 * Horde package update:mm2015-03-022-3/+3 * - Unsilence installamdmi32015-03-022-4/+2 * - Unbreak modules buildamdmi32015-03-013-8/+41 * - Update to 0.19sunpoet2015-03-014-16/+7 * Deprecate ports that do not work with Ruby 2.xantoine2015-03-011-0/+2 * - Strip binariesamdmi32015-02-261-1/+4 * switch to USES=tar:tgz.vanilla2015-02-241-1/+1 * switch to USES:tar:tgz.vanilla2015-02-241-1/+1 * 1: add LICENSE.vanilla2015-02-241-1/+3 * Update to version 1.17.24pawel2015-02-242-4/+3 * Remove the historic option INSTALL_AS_INFOUNZIP which would install the unzipehaupt2015-02-211-18/+6 * - Update to 5.2.1sunpoet2015-02-202-3/+7 * - Update to 5.21 (5.2.4)sunpoet2015-02-203-7/+8 * Fix patch, pass my pointy hats please.delphij2015-02-191-2/+2 * Fix build. The merge should have been tested against an ICONV build.delphij2015-02-181-3/+3 * Apply fix for CVE-2015-1315 from Marc Deslauriersdelphij2015-02-182-4/+16 * Fix DEPENDSantoine2015-02-151-1/+1 * - Update to 0.04culot2015-02-132-7/+7 * - Update to 1.45culot2015-02-132-3/+3 * - Update to 0.7.1nivit2015-02-112-4/+4 * Update to 4.15garga2015-02-102-3/+3 * Upgrade to new release 2.09mandree2015-02-074-25/+9 * Apply Debian patch for CVE-2014-9636 which fixes out ofdelphij2015-02-042-7/+18 * Unbreak with gcc from baseantoine2015-01-311-0/+3 * Update to 0.5.fjoe2015-01-282-4/+4 * Update to 2.3.3.delphij2015-01-262-3/+4 * Use /var/log for logdirpawel2015-01-251-1/+2 * Remove explicit dependency on javavmwrapper for ports that USE_JAVAantoine2015-01-241-2/+0 * archivers/par: Mark jobs unsafemarino2015-01-221-0/+2 * - Use INSTALL_TARGET=install-strip instead of STRIP_CMDsunpoet2015-01-201-3/+1 * - Update to 5.21 (5.2.4)sunpoet2015-01-182-4/+4 * Update to 20141018 and take maintainership.delphij2015-01-172-6/+6 * Don't hard-code php lib path.ale2015-01-161-2/+2 * Add patch to fix multiple vulnerabilities.ehaupt2015-01-162-1/+67 * - Update to 1.43culot2015-01-162-4/+4 * - Sort PLISTsunpoet2015-01-131-4/+4 * Update to 1.42.tobez2015-01-132-3/+3 * Horde package update:mm2015-01-122-4/+3 * Update to 1.41.tobez2015-01-102-4/+3 * Update horde_lz4 to 1.0.7mm2015-01-092-3/+3 * Move MASTER_SITES from CRITICAL to LOCAL/ehauptehaupt2015-01-062-2/+2 * Move MASTER_SITES from CRITICAL to LOCAL/ehauptehaupt2015-01-061-1/+1 * Move MASTER_SITES from CRITICAL to LOCAL/ehauptehaupt2015-01-068-8/+8 * - Update to 2.04jadawin2015-01-052-4/+3 * Assign maintainership of FPC ports to new FPC ports teammarino2015-01-053-3/+3 * Bump PORTREVISION after update of x11-fm/thunarolivierd2015-01-051-1/+1 * Update to version 1.17.23pawel2014-12-303-3/+9 * Convert to USES=autoreconfbapt2014-12-291-5/+1 * - Update to 2.068sunpoet2014-12-242-4/+4 * - Update to 2.068sunpoet2014-12-242-5/+5 * - Update to 2.068sunpoet2014-12-242-4/+4 * - Update to 2.068sunpoet2014-12-242-5/+5 * - Update to 2.068sunpoet2014-12-242-3/+3 * - Update to 2.068sunpoet2014-12-242-3/+3 * - Update to 2.068sunpoet2014-12-242-3/+3 * Change my non-FreeBSD MAINTAINER mail to bofh@bofh2014-12-241-1/+1 * Convert to USES=autoreconfbapt2014-12-181-3/+2 * - Update to 2.067sunpoet2014-12-132-5/+4 * - Update to 2.067sunpoet2014-12-132-6/+5 * - Update to 2.067sunpoet2014-12-132-5/+4 * - Update to 2.067sunpoet2014-12-132-6/+5 * - Update to 2.067sunpoet2014-12-132-4/+3 * - Update to 2.067sunpoet2014-12-132-9/+7 * - Update to 2.067sunpoet2014-12-132-4/+3 * Mark BROKEN on freebsd 8, fail to buildantoine2014-12-101-0/+4 * Replace USES=libtool:oldver with USES=libtool or USES=libtool:keepla intijl2014-12-092-2/+2 * I was never able to replicate this, but a number of people have reported thatadamw2014-12-071-1/+1 * Upgrade to version 1.17.22pawel2014-12-063-3/+5 * update zpaq to 6.57bf2014-12-062-15/+20 * archivers/nwreckdum: point to a new home on GitHubdanfe2014-12-051-0/+2 * - Update to 0.74jadawin2014-12-032-4/+3 * Update GNOME to 3.14.2.kwm2014-12-032-4/+4 * Fix build when linking with libperl.so.mat2014-12-011-5/+0 * Cleanup plist of ocaml portsantoine2014-11-301-1/+0 * Split devel/gettext in devel/gettext-runtime and devel/gettext-tools. Thetijl2014-11-301-1/+2 * Update to version 1.17.21pawel2014-11-293-7/+7 * archivers/ucl: Strip files, Add CONFLICTS (libucl)koobs2014-11-282-2/+7 * Change the way Perl modules are installed, update the default Perl to 5.18.mat2014-11-26