aboutsummaryrefslogtreecommitdiffstats
path: root/finance/trytond
diff options
context:
space:
mode:
authorwen <wen@FreeBSD.org>2012-09-18 20:52:25 +0800
committerwen <wen@FreeBSD.org>2012-09-18 20:52:25 +0800
commit847d8c4ed81ee29765e6633a483cfb0ed57ea6aa (patch)
tree01a28261fdb60b7fb67c004c24f51920ee72ca6a /finance/trytond
parent2e8d447aa7d98bcbae2232e1b1950520014fe960 (diff)
downloadfreebsd-ports-gnome-847d8c4ed81ee29765e6633a483cfb0ed57ea6aa.tar.gz
freebsd-ports-gnome-847d8c4ed81ee29765e6633a483cfb0ed57ea6aa.tar.zst
freebsd-ports-gnome-847d8c4ed81ee29765e6633a483cfb0ed57ea6aa.zip
- Improve rc scripts
Submitted by: bsam@ (via email)
Diffstat (limited to 'finance/trytond')
-rw-r--r--finance/trytond/Makefile9
-rw-r--r--finance/trytond/files/patch-etc_trytond.conf13
2 files changed, 21 insertions, 1 deletions
diff --git a/finance/trytond/Makefile b/finance/trytond/Makefile
index 3ecef626a5fc..085903d07649 100644
--- a/finance/trytond/Makefile
+++ b/finance/trytond/Makefile
@@ -7,7 +7,7 @@
PORTNAME= trytond
PORTVERSION= 2.4.1
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= finance python
MASTER_SITES= http://downloads2.tryton.org/${PORTVERSION:R}/
@@ -39,9 +39,16 @@ SUB_LIST= PYTHON_SITELIBDIR=${PYTHON_SITELIBDIR} \
PYEASYINSTALL_EGG=${PYEASYINSTALL_EGG} \
PYTHON=${PYTHON_CMD}
+PIDDIR?= /var/run
+LOGDIR?= /var/log
+
USE_PYTHON= yes
USE_PYDISTUTILS=easy_install
+post-patch:
+ @${REINPLACE_CMD} -e 's|%%PIDDIR%%|${PIDDIR}|g' -e 's|%%LOGDIR%%|${LOGDIR}|g' \
+ ${WRKSRC}/etc/${PORTNAME}.conf
+
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MWEBDAV}
diff --git a/finance/trytond/files/patch-etc_trytond.conf b/finance/trytond/files/patch-etc_trytond.conf
new file mode 100644
index 000000000000..5acc40371228
--- /dev/null
+++ b/finance/trytond/files/patch-etc_trytond.conf
@@ -0,0 +1,13 @@
+--- etc/trytond.conf.orig 2012-09-18 12:54:38.000000000 +0400
++++ etc/trytond.conf 2012-09-18 12:56:50.000000000 +0400
+@@ -45,8 +45,8 @@ jsonrpc = localhost:8000
+ #admin_passwd = admin
+
+ # Configure the path of the files for the pid and the logs
+-#pidfile = False
+-#logfile = False
++pidfile = %%PIDDIR%%/trytond/trytond.pid
++logfile = %%LOGDIR%%/trytond/trytond.log
+
+ #privatekey = server.pem
+ #certificate = server.pem