aboutsummaryrefslogtreecommitdiffstats
path: root/finance/vanitygen
diff options
context:
space:
mode:
authorzi <zi@FreeBSD.org>2013-11-01 09:12:43 +0800
committerzi <zi@FreeBSD.org>2013-11-01 09:12:43 +0800
commitcf4ebfbfa91b244004b5a112911b18a33ff0efee (patch)
tree0fd42a36f6b286cdf3ffab9954d1839c9a3e104e /finance/vanitygen
parent249f3a5404de6babd4e68a35fdcad3d035eb5146 (diff)
downloadfreebsd-ports-gnome-cf4ebfbfa91b244004b5a112911b18a33ff0efee.tar.gz
freebsd-ports-gnome-cf4ebfbfa91b244004b5a112911b18a33ff0efee.tar.zst
freebsd-ports-gnome-cf4ebfbfa91b244004b5a112911b18a33ff0efee.zip
New port: finance/vanitygen:
Vanitygen can generate regular bitcoin addresses, namecoin addresses, and testnet addresses. WWW: https://github.com/samr7/vanitygen/
Diffstat (limited to 'finance/vanitygen')
-rw-r--r--finance/vanitygen/Makefile36
-rw-r--r--finance/vanitygen/distinfo2
-rw-r--r--finance/vanitygen/pkg-descr4
3 files changed, 42 insertions, 0 deletions
diff --git a/finance/vanitygen/Makefile b/finance/vanitygen/Makefile
new file mode 100644
index 000000000000..950699f8297f
--- /dev/null
+++ b/finance/vanitygen/Makefile
@@ -0,0 +1,36 @@
+# Created by: Ryan Steinmetz <zi@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= vanitygen
+PORTVERSION= 0.21
+CATEGORIES= finance
+MASTER_SITES= https://github.com/${GH_ACCOUNT}/${PORTNAME}/archive/
+DISTNAME= ${PORTVERSION}
+
+MAINTAINER= ports@FreeBSD.org
+COMMENT= A standalone vanity address generator for bitcoin
+
+LIB_DEPENDS= pcre:${PORTSDIR}/devel/pcre
+
+USES= gmake
+USE_GITHUB= yes
+GH_ACCOUNT= samr7
+GH_PROJECT= ${PORTNAME}
+GH_TAGNAME= 20130402
+LDFLAGS+= -L${LOCALBASE}/lib
+PLIST_FILES= bin/keyconv bin/vanitygen
+NO_STAGE= yes
+
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
+
+post-patch:
+ @${REINPLACE_CMD} \
+ -e 's|CFLAGS=|CFLAGS=-I${LOCALBASE}/include -L${LOCALBASE}/lib |g' \
+ -e 's| oclvanitygen oclvanityminer||g' \
+ ${WRKSRC}/Makefile
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/keyconv ${PREFIX}/bin/
+ ${INSTALL_PROGRAM} ${WRKSRC}/vanitygen ${PREFIX}/bin/
+
+.include <bsd.port.mk>
diff --git a/finance/vanitygen/distinfo b/finance/vanitygen/distinfo
new file mode 100644
index 000000000000..ca7cb914fc3f
--- /dev/null
+++ b/finance/vanitygen/distinfo
@@ -0,0 +1,2 @@
+SHA256 (0.21.tar.gz) = 58c56e1ec51c654077ace5599d4f9dc512110e2150fe40a05380f948b305be7f
+SIZE (0.21.tar.gz) = 77441
diff --git a/finance/vanitygen/pkg-descr b/finance/vanitygen/pkg-descr
new file mode 100644
index 000000000000..ddc84137ddcf
--- /dev/null
+++ b/finance/vanitygen/pkg-descr
@@ -0,0 +1,4 @@
+Vanitygen can generate regular bitcoin addresses, namecoin addresses,
+and testnet addresses.
+
+WWW: https://github.com/samr7/vanitygen/