aboutsummaryrefslogtreecommitdiffstats
path: root/finance
diff options
context:
space:
mode:
authoraz <az@FreeBSD.org>2012-06-30 22:53:22 +0800
committeraz <az@FreeBSD.org>2012-06-30 22:53:22 +0800
commit0e6a86ac785369dcd2f6b93f52268d5336dcd283 (patch)
treefe4d654de9040e3451da08f6eb2865c73df28369 /finance
parentc4488f29abd1339c42a704fb50b07d1210e0f3bc (diff)
downloadfreebsd-ports-gnome-0e6a86ac785369dcd2f6b93f52268d5336dcd283.tar.gz
freebsd-ports-gnome-0e6a86ac785369dcd2f6b93f52268d5336dcd283.tar.zst
freebsd-ports-gnome-0e6a86ac785369dcd2f6b93f52268d5336dcd283.zip
- Remove SITE_PERL from *_DEPENDS
Approved by: portmgr@ (bapt@)
Diffstat (limited to 'finance')
-rw-r--r--finance/kmymoney-kde4/Makefile10
-rw-r--r--finance/ledgersmb/Makefile2
-rw-r--r--finance/ledgersmb12/Makefile6
-rw-r--r--finance/p5-Business-OnlinePayment-PayflowPro/Makefile4
-rw-r--r--finance/sql-ledger/Makefile2
5 files changed, 12 insertions, 12 deletions
diff --git a/finance/kmymoney-kde4/Makefile b/finance/kmymoney-kde4/Makefile
index e561a2ebf2b0..941630349f67 100644
--- a/finance/kmymoney-kde4/Makefile
+++ b/finance/kmymoney-kde4/Makefile
@@ -68,11 +68,11 @@ PLIST_SUB+= WITH_OFX="@comment "
.if defined(WITH_QUOTES)
USE_PERL5_RUN= yes
-RUN_DEPENDS+= ${SITE_PERL}/Date/Manip.pm:${PORTSDIR}/devel/p5-Date-Manip \
- ${SITE_PERL}/Finance/Quote.pm:${PORTSDIR}/finance/p5-Finance-Quote \
- ${SITE_PERL}/${PERL_ARCH}/XML/Parser.pm:${PORTSDIR}/textproc/p5-XML-Parser \
- ${SITE_PERL}/XML/Writer.pm:${PORTSDIR}/textproc/p5-XML-Writer \
- ${SITE_PERL}/LWP.pm:${PORTSDIR}/www/p5-libwww
+RUN_DEPENDS+= p5-Date-Manip>=0:${PORTSDIR}/devel/p5-Date-Manip \
+ p5-Finance-Quote>=0:${PORTSDIR}/finance/p5-Finance-Quote \
+ p5-XML-Parser>=0:${PORTSDIR}/textproc/p5-XML-Parser \
+ p5-XML-Writer>=0:${PORTSDIR}/textproc/p5-XML-Writer \
+ p5-libwww>=0:${PORTSDIR}/www/p5-libwww
.endif
.if !defined(PACKAGE_BUILDING) && defined(WITH_KBANKING) && !exists(${LOCALBASE}/lib/libgwengui-qt4.so)
diff --git a/finance/ledgersmb/Makefile b/finance/ledgersmb/Makefile
index 7f2ad6441e56..5100fd052bfa 100644
--- a/finance/ledgersmb/Makefile
+++ b/finance/ledgersmb/Makefile
@@ -14,7 +14,7 @@ MASTER_SITES= SF/${PORTNAME}/ledgersmb/${PORTVERSION}
MAINTAINER= anarcat@anarcat.ath.cx
COMMENT= A double entry accounting system
-BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/DBD/Pg.pm:${PORTSDIR}/databases/p5-DBD-Pg
+BUILD_DEPENDS= p5-DBD-Pg>=0:${PORTSDIR}/databases/p5-DBD-Pg
RUN_DEPENDS:= ${BUILD_DEPENDS}
NO_BUILD= yes
diff --git a/finance/ledgersmb12/Makefile b/finance/ledgersmb12/Makefile
index aacb47e3533d..6ed4fa79a4af 100644
--- a/finance/ledgersmb12/Makefile
+++ b/finance/ledgersmb12/Makefile
@@ -13,9 +13,9 @@ MASTER_SITES= SF/ledger-smb/${PORTNAME}/${PORTVERSION}
MAINTAINER= anarcat@anarcat.ath.cx
COMMENT= A double entry accounting system
-BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/DBD/Pg.pm:${PORTSDIR}/databases/p5-DBD-Pg \
- ${SITE_PERL}/MIME/Lite.pm:${PORTSDIR}/mail/p5-MIME-Lite \
- ${SITE_PERL}/Config/Std.pm:${PORTSDIR}/devel/p5-Config-Std
+BUILD_DEPENDS= p5-DBD-Pg>=0:${PORTSDIR}/databases/p5-DBD-Pg \
+ p5-MIME-Lite>=0:${PORTSDIR}/mail/p5-MIME-Lite \
+ p5-Config-Std>=0:${PORTSDIR}/devel/p5-Config-Std
RUN_DEPENDS:= ${BUILD_DEPENDS}
LATEST_LINK= ledgersmb12
diff --git a/finance/p5-Business-OnlinePayment-PayflowPro/Makefile b/finance/p5-Business-OnlinePayment-PayflowPro/Makefile
index 7ecabac0b24d..c3482c22ae36 100644
--- a/finance/p5-Business-OnlinePayment-PayflowPro/Makefile
+++ b/finance/p5-Business-OnlinePayment-PayflowPro/Makefile
@@ -14,8 +14,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= never@nevermind.kiev.ua
COMMENT= A Business::OnlinePayment backend module for PayflowPro
-BUILD_DEPENDS= ${SITE_PERL}/Business/OnlinePayment.pm:${PORTSDIR}/finance/p5-Business-OnlinePayment \
- ${SITE_PERL}/mach/PFProAPI.pm:${PORTSDIR}/finance/p5-PFProAPI
+BUILD_DEPENDS= p5-Business-OnlinePayment>=0:${PORTSDIR}/finance/p5-Business-OnlinePayment \
+ p5-PFProAPI>=0:${PORTSDIR}/finance/p5-PFProAPI
RUN_DEPENDS:= ${BUILD_DEPENDS}
PERL_CONFIGURE= yes
diff --git a/finance/sql-ledger/Makefile b/finance/sql-ledger/Makefile
index 7cce27460526..92ce781a5abc 100644
--- a/finance/sql-ledger/Makefile
+++ b/finance/sql-ledger/Makefile
@@ -15,7 +15,7 @@ MASTER_SITES= http://www.sql-ledger.com/source/ \
MAINTAINER= 5u623l20@gmail.com
COMMENT= A double entry accounting system
-BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/DBD/Pg.pm:${PORTSDIR}/databases/p5-DBD-Pg
+BUILD_DEPENDS= p5-DBD-Pg>=0:${PORTSDIR}/databases/p5-DBD-Pg
RUN_DEPENDS:= ${BUILD_DEPENDS}
NO_BUILD= yes