aboutsummaryrefslogtreecommitdiffstats
path: root/finance
diff options
context:
space:
mode:
authorkwm <kwm@FreeBSD.org>2015-08-03 04:23:55 +0800
committerkwm <kwm@FreeBSD.org>2015-08-03 04:23:55 +0800
commit8e06482685b64ce8d458dbb06943d4e18ee837cd (patch)
tree36ed89e03b0f2ac4525ba4f4e39af16da597b209 /finance
parent44a9844e6b8ab862275ea28c01d4bfbc41256986 (diff)
downloadfreebsd-ports-gnome-8e06482685b64ce8d458dbb06943d4e18ee837cd.tar.gz
freebsd-ports-gnome-8e06482685b64ce8d458dbb06943d4e18ee837cd.tar.zst
freebsd-ports-gnome-8e06482685b64ce8d458dbb06943d4e18ee837cd.zip
Part 1 of adding USE_GNOME=intltool to ports that require it.
The reason for this is that in the GNOME 3.16 update, USE_GNOME gtk20 and gtk30 don't pull intltool in anymore. PR: 201980 Exp-run by: antoine@
Diffstat (limited to 'finance')
-rw-r--r--finance/gnucash/Makefile2
-rw-r--r--finance/grisbi/Makefile2
-rw-r--r--finance/homebank/Makefile2
3 files changed, 3 insertions, 3 deletions
diff --git a/finance/gnucash/Makefile b/finance/gnucash/Makefile
index 462889150a82..bf98627dd2a3 100644
--- a/finance/gnucash/Makefile
+++ b/finance/gnucash/Makefile
@@ -61,7 +61,7 @@ USE_XORG= x11
USES= compiler:c++11-lib desktop-file-utils gettext gmake libtool perl5 \
pkgconfig shebangfix tar:bzip2
INSTALLS_ICONS= yes
-USE_GNOME+= gtk20 libgnomecanvas libxml2 libxslt:build
+USE_GNOME+= gtk20 intltool libgnomecanvas libxml2 libxslt:build
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
CPPFLAGS+= -I${LOCALBASE}/include
diff --git a/finance/grisbi/Makefile b/finance/grisbi/Makefile
index 5f9f4c9894f1..43ca23511d4f 100644
--- a/finance/grisbi/Makefile
+++ b/finance/grisbi/Makefile
@@ -16,7 +16,7 @@ LIB_DEPENDS= libofx.so:${PORTSDIR}/finance/libofx
USES= tar:bzip2 desktop-file-utils gmake iconv pkgconfig shared-mime-info
GNU_CONFIGURE= yes
-USE_GNOME= gtk20 glib20 libxml2
+USE_GNOME= gtk20 glib20 intltool libxml2
USE_OPENSSL= yes
INSTALLS_ICONS= yes
CONFIGURE_ENV+= OPENSSL_CFLAGS="-I${OPENSSLINC}" OPENSSL_LIBS="-L${OPENSSLLIB} -lcrypto"
diff --git a/finance/homebank/Makefile b/finance/homebank/Makefile
index 24429430d90d..9aabcc0f5003 100644
--- a/finance/homebank/Makefile
+++ b/finance/homebank/Makefile
@@ -14,7 +14,7 @@ LIB_DEPENDS= libosp.so:${PORTSDIR}/textproc/opensp
GNU_CONFIGURE= yes
USES= desktop-file-utils gettext gmake pkgconfig shared-mime-info
-USE_GNOME= gtk30
+USE_GNOME= gtk30 intltool
INSTALLS_ICONS= yes
CPPFLAGS+= -I${LOCALBASE}/include