aboutsummaryrefslogtreecommitdiffstats
path: root/finance
diff options
context:
space:
mode:
authortcberner <tcberner@FreeBSD.org>2016-08-24 16:20:31 +0800
committertcberner <tcberner@FreeBSD.org>2016-08-24 16:20:31 +0800
commita5fddeafcdb2cab1016827038e317a262dad4857 (patch)
treeb9dc00f333e96550a5732b38b9c9444035e4339c /finance
parent3832b190ef3ea2bbefdd61450bff8af422a2e9ae (diff)
downloadfreebsd-ports-gnome-a5fddeafcdb2cab1016827038e317a262dad4857.tar.gz
freebsd-ports-gnome-a5fddeafcdb2cab1016827038e317a262dad4857.tar.zst
freebsd-ports-gnome-a5fddeafcdb2cab1016827038e317a262dad4857.zip
Replace Mk/bsd.kde4.mk by Mk/Uses/kde.mk in preparation for KDE Frameworks and
Plasma5 ports At the moment KDE ports use bsd.kde4.mk to handle their dependencies. When working on the ports for KDE Frameworks and Plasma5 it seemed to be more reasonable to create a new kde.mk instead of adding an bsd.kde5.mk. The kde.mk in this review is a stripped down version of the one we are using in the KDE Test repositories plasma5 branch [1] to only contain the parts relevant to the current KDE4 ports in the portstree [2]. Changes to the KDE Ports needed by this: Replace USE_KDE4 by USE_KDE [3] Add USES=kde:4 [4] [1] http://src.mouf.net/area51/view/branches/plasma5/KDE/Mk/Uses/kde.mk [2] The version in the plasma5 branch also handles frameworks/plasma5 and handles MASTER_SITES via a KDE_DIST variable similar to bsd.qt.mk for Qt Ports -- I chose to leave this out for now, as the diff is already large enough. [3] I chose USE_KDE instead of USE_KDE4, USE_KDE5, USE_KDEX as the version we want is already specified as argument to kde:<arg> [4] For KDE Frameworks and Plasma5 ports this would be kde:5 PR: 210667 Approved by: portmgr, mat (mentor), rakuco (mentor) Reviewed by: mat, rakuco Differential Revision: https://reviews.freebsd.org/D6961
Diffstat (limited to 'finance')
-rw-r--r--finance/kmymoney-kde4/Makefile4
-rw-r--r--finance/libalkimia/Makefile4
-rw-r--r--finance/skrooge/Makefile5
3 files changed, 7 insertions, 6 deletions
diff --git a/finance/kmymoney-kde4/Makefile b/finance/kmymoney-kde4/Makefile
index ae6db8ebcac1..5c41d68bb368 100644
--- a/finance/kmymoney-kde4/Makefile
+++ b/finance/kmymoney-kde4/Makefile
@@ -15,10 +15,10 @@ LICENSE_FILE= ${WRKSRC}/COPYING
LIB_DEPENDS= libboost_graph.so:devel/boost-libs \
libalkimia.so:finance/libalkimia
-USES= cmake pkgconfig shared-mime-info shebangfix tar:xz
+USES= cmake kde:4 pkgconfig shared-mime-info shebangfix tar:xz
USE_QT4= gui dbus network phonon sql svg xml \
qmake_build moc_build rcc_build uic_build
-USE_KDE4= automoc4 kdelibs pimlibs
+USE_KDE= automoc4 kdelibs pimlibs
USE_LDCONFIG= yes
SHEBANG_FILES= kmymoney/misc/financequote.pl
diff --git a/finance/libalkimia/Makefile b/finance/libalkimia/Makefile
index 3c653fca719e..4d32735a5b04 100644
--- a/finance/libalkimia/Makefile
+++ b/finance/libalkimia/Makefile
@@ -13,8 +13,8 @@ LICENSE= LGPL21
LIB_DEPENDS= libgmp.so:math/gmp
-USES= cmake:outsource pathfix tar:xz
-USE_KDE4= automoc4 kdelibs
+USES= cmake:outsource kde:4 pathfix tar:xz
+USE_KDE= automoc4 kdelibs
USE_QT4= qmake_build moc_build rcc_build uic_build
USE_LDCONFIG= yes
diff --git a/finance/skrooge/Makefile b/finance/skrooge/Makefile
index 5ee94a727bca..dcd736466105 100644
--- a/finance/skrooge/Makefile
+++ b/finance/skrooge/Makefile
@@ -13,10 +13,11 @@ LIB_DEPENDS= libofx.so:finance/libofx \
libqca.so:devel/qca \
libkactivities.so:x11/kactivities
-USES= cmake:outsource gettext grantlee:4 shared-mime-info sqlite:3 tar:xz
+USES= cmake:outsource gettext grantlee:4 kde:4 shared-mime-info \
+ sqlite:3 tar:xz
USE_QT4= qmake_build moc_build uic_build rcc_build designer_build \
corelib dbus gui script sql webkit xml sql-sqlite3_run
-USE_KDE4= automoc4 kdelibs pimlibs
+USE_KDE= automoc4 kdelibs pimlibs
USE_LDCONFIG= yes
PLIST_SUB= VERSION=${PORTVERSION}