aboutsummaryrefslogtreecommitdiffstats
path: root/finance
diff options
context:
space:
mode:
authorkoobs <koobs@FreeBSD.org>2016-03-03 18:11:31 +0800
committerkoobs <koobs@FreeBSD.org>2016-03-03 18:11:31 +0800
commiteda94908b828778ed30fb7fdf11dfc2c86e73dd8 (patch)
tree6b0fc97e6146382e6756e041d66e6b79fb3994ea /finance
parent5608a15294eb296f2e9beb26c3f555282792c8e2 (diff)
downloadfreebsd-ports-gnome-eda94908b828778ed30fb7fdf11dfc2c86e73dd8.tar.gz
freebsd-ports-gnome-eda94908b828778ed30fb7fdf11dfc2c86e73dd8.tar.zst
freebsd-ports-gnome-eda94908b828778ed30fb7fdf11dfc2c86e73dd8.zip
finance/py-stripe: Update to 1.30.0
- Update PORTVERSION and distinfo checksum (1.30.0) - Update mock in TEST_DEPENDS (now any version) - Update setup.py patch to add tests_require for future upstreaming Changes: https://github.com/stripe/stripe-python/blob/v1.30.0/CHANGELOG
Diffstat (limited to 'finance')
-rw-r--r--finance/py-stripe/Makefile4
-rw-r--r--finance/py-stripe/distinfo4
-rw-r--r--finance/py-stripe/files/patch-setup.py25
3 files changed, 21 insertions, 12 deletions
diff --git a/finance/py-stripe/Makefile b/finance/py-stripe/Makefile
index abfb60203a45..c3436a908a28 100644
--- a/finance/py-stripe/Makefile
+++ b/finance/py-stripe/Makefile
@@ -3,7 +3,7 @@
#
PORTNAME= stripe
-PORTVERSION= 1.29.1
+DISTVERSION= 1.30.0
CATEGORIES= finance python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -16,7 +16,7 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}requests>=0.8.8:${PORTSDIR}/www/py-requests
TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pycurl>=7.19:${PORTSDIR}/ftp/py-pycurl \
- ${PYTHON_PKGNAMEPREFIX}mock>=1.0.1:${PORTSDIR}/devel/py-mock \
+ ${PYTHON_PKGNAMEPREFIX}mock>0:${PORTSDIR}/devel/py-mock \
${PYTHON_PKGNAMEPREFIX}unittest2>0:${PORTSDIR}/devel/py-unittest2
USES= python
diff --git a/finance/py-stripe/distinfo b/finance/py-stripe/distinfo
index 8e2a7044e9dd..12f79619a75d 100644
--- a/finance/py-stripe/distinfo
+++ b/finance/py-stripe/distinfo
@@ -1,2 +1,2 @@
-SHA256 (stripe-1.29.1.tar.gz) = 61b98cec0f10888a3a5ea1096cb0fcc040541d627df0089fc0400ec2c81d7471
-SIZE (stripe-1.29.1.tar.gz) = 176656
+SHA256 (stripe-1.30.0.tar.gz) = 90d8c6f6acc9485bae5d106b62c6b09b62eea9d7fb1c8476fb4c85b04777fa3a
+SIZE (stripe-1.30.0.tar.gz) = 176841
diff --git a/finance/py-stripe/files/patch-setup.py b/finance/py-stripe/files/patch-setup.py
index 9413f062c7a6..a29fc18eda10 100644
--- a/finance/py-stripe/files/patch-setup.py
+++ b/finance/py-stripe/files/patch-setup.py
@@ -1,15 +1,24 @@
-# Use latest mock for tests
-# Fix two test failures with latest mock #205
-# https://github.com/stripe/stripe-python/issues/205
-
---- setup.py.orig 2016-02-22 10:32:35 UTC
+--- setup.py.orig 2016-03-03 09:42:16 UTC
+++ setup.py
-@@ -57,7 +57,7 @@ setup(
+@@ -28,6 +28,11 @@ if sys.version_info < (2, 6):
+ else:
+ install_requires.append('requests >= 0.8.8')
+
++tests_require = [
++ 'unittest2',
++ 'pycurl>=7.19',
++ 'mock',
++]
+
+ with open('LONG_DESCRIPTION.rst') as f:
+ long_description = f.read()
+@@ -56,8 +61,8 @@ setup(
+ packages=['stripe', 'stripe.test', 'stripe.test.resources'],
package_data={'stripe': ['data/ca-certificates.crt']},
install_requires=install_requires,
++ tests_require=tests_require,
test_suite='stripe.test.all',
-- tests_require=['unittest2', 'mock == 1.0.1'],
-+ tests_require=['unittest2', 'mock>=1.0.1'],
+- tests_require=['unittest2', 'mock'],
use_2to3=True,
classifiers=[
"Development Status :: 5 - Production/Stable",