aboutsummaryrefslogtreecommitdiffstats
path: root/finance
diff options
context:
space:
mode:
authorwxs <wxs@FreeBSD.org>2009-07-16 00:47:45 +0800
committerwxs <wxs@FreeBSD.org>2009-07-16 00:47:45 +0800
commit5df5244832441b2891d52b6e4692f7826550fbf9 (patch)
treee5cc110a0c6b72dd9bb7f133efd52b77ab031c63 /finance
parent194d70d50158859e626cd148123bb52dec698a06 (diff)
downloadfreebsd-ports-gnome-5df5244832441b2891d52b6e4692f7826550fbf9.tar.gz
freebsd-ports-gnome-5df5244832441b2891d52b6e4692f7826550fbf9.tar.zst
freebsd-ports-gnome-5df5244832441b2891d52b6e4692f7826550fbf9.zip
- Chase security/gpgme update.
Most changes are just PORTREVISION and LIB_DEPENDS fixes. However, the following ports require a patch to use the new gpgme correctly: deskutils/kdepim3 deskutils/kdepim3 deskutils/kdepim3 deskutils/kdepim3 deskutils/kdepim4 deskutils/kdepim4 deskutils/kdepimlibs4 deskutils/kdepimlibs4 deskutils/kdepimlibs4 finance/qhacc mail/mutt-devel net-im/ayttm net-im/centericq net-im/centerim net-im/centerim-devel security/openvas-libnasl These patches were submitted by various people and documented in ports/135911. PR: ports/135911
Diffstat (limited to 'finance')
-rw-r--r--finance/qhacc/Makefile4
-rw-r--r--finance/qhacc/files/patch-plugins::gpg::gpgplugin.cpp10
2 files changed, 12 insertions, 2 deletions
diff --git a/finance/qhacc/Makefile b/finance/qhacc/Makefile
index c3d83a5d74b7..caeb09e3a70d 100644
--- a/finance/qhacc/Makefile
+++ b/finance/qhacc/Makefile
@@ -7,7 +7,7 @@
PORTNAME= qhacc
PORTVERSION= 3.5
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= finance
MASTER_SITES= SF
@@ -56,7 +56,7 @@ PLIST_SUB+= SQLITE="@comment "
.endif
.if defined(WITH_GPGME)
-LIB_DEPENDS+= gpgme.17:${PORTSDIR}/security/gpgme
+LIB_DEPENDS+= gpgme.18:${PORTSDIR}/security/gpgme
CONFIGURE_ARGS+= --enable-gpg
PLIST_SUB+= GPGME=""
.else
diff --git a/finance/qhacc/files/patch-plugins::gpg::gpgplugin.cpp b/finance/qhacc/files/patch-plugins::gpg::gpgplugin.cpp
new file mode 100644
index 000000000000..ce4133454c49
--- /dev/null
+++ b/finance/qhacc/files/patch-plugins::gpg::gpgplugin.cpp
@@ -0,0 +1,10 @@
+--- ./plugins/gpg/gpgplugin.cpp.orig 2009-06-30 00:55:33.000000000 -0400
++++ ./plugins/gpg/gpgplugin.cpp 2009-06-30 00:59:33.000000000 -0400
+@@ -56,6 +56,7 @@
+ const PluginInfo& GPGDBPlugin::info() const { return pinfo; }
+
+ bool GPGDBPlugin::iconnect( QHacc *, const QString&, QString& error ){
++ gpgme_check_version( NULL );
+ madectx=( GPG_ERR_NO_ERROR==gpgme_new( &gpgctx ) );
+ if( madectx ){
+ gpgme_set_passphrase_cb( gpgctx, GPGDBPlugin::passphrase_cb,