aboutsummaryrefslogtreecommitdiffstats
path: root/finance
diff options
context:
space:
mode:
authoraz <az@FreeBSD.org>2013-07-31 14:54:09 +0800
committeraz <az@FreeBSD.org>2013-07-31 14:54:09 +0800
commit448a5e5ed056eca21f6e4c419f976b3ec6d14fd0 (patch)
treece66d6984b8e2580d19a3e478f618b13623e3080 /finance
parentbe5a215285755fb61a101782219027ad5e305270 (diff)
downloadfreebsd-ports-gnome-448a5e5ed056eca21f6e4c419f976b3ec6d14fd0.tar.gz
freebsd-ports-gnome-448a5e5ed056eca21f6e4c419f976b3ec6d14fd0.tar.zst
freebsd-ports-gnome-448a5e5ed056eca21f6e4c419f976b3ec6d14fd0.zip
- Convert to new Uses/perl5.mk framework
- Resolve issues with implicit lang/perl in extract and patch dependencies - Trim Makefile header Reviewed by: bapt@ (exp-run) Approved by: bapt@ (portmrg@)
Diffstat (limited to 'finance')
-rw-r--r--finance/ledgersmb12/Makefile3
-rw-r--r--finance/p5-Business-OnlinePayment-2CheckOut/Makefile3
-rw-r--r--finance/p5-Business-OnlinePayment-SurePay/Makefile3
-rw-r--r--finance/p5-Business-WorldPay-Junior/Makefile9
4 files changed, 9 insertions, 9 deletions
diff --git a/finance/ledgersmb12/Makefile b/finance/ledgersmb12/Makefile
index f26a599b377c..8141e6cc1fb5 100644
--- a/finance/ledgersmb12/Makefile
+++ b/finance/ledgersmb12/Makefile
@@ -18,7 +18,8 @@ LATEST_LINK= ledgersmb12
WRKSRC= ${WRKDIR}/${PORTNAME}
NO_BUILD= yes
-USE_PERL5= yes
+USES= perl5
+USE_PERL5= run build patch
SUB_FILES= pkg-message
diff --git a/finance/p5-Business-OnlinePayment-2CheckOut/Makefile b/finance/p5-Business-OnlinePayment-2CheckOut/Makefile
index 27beef13da6d..6e2fce2d2f8d 100644
--- a/finance/p5-Business-OnlinePayment-2CheckOut/Makefile
+++ b/finance/p5-Business-OnlinePayment-2CheckOut/Makefile
@@ -16,7 +16,8 @@ BUILD_DEPENDS= p5-Business-CreditCard>=0:${PORTSDIR}/finance/p5-Business-CreditC
p5-Text-CSV_XS>=0:${PORTSDIR}/textproc/p5-Text-CSV_XS
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure patch
MAN3= Business::OnlinePayment::2CheckOut.3
diff --git a/finance/p5-Business-OnlinePayment-SurePay/Makefile b/finance/p5-Business-OnlinePayment-SurePay/Makefile
index 1f355ccec713..6553e23585dc 100644
--- a/finance/p5-Business-OnlinePayment-SurePay/Makefile
+++ b/finance/p5-Business-OnlinePayment-SurePay/Makefile
@@ -14,7 +14,8 @@ BUILD_DEPENDS= p5-Business-CreditCard>=0:${PORTSDIR}/finance/p5-Business-CreditC
p5-Business-OnlinePayment>=0:${PORTSDIR}/finance/p5-Business-OnlinePayment
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure patch
MAN3= Business::OnlinePayment::SurePay.3
diff --git a/finance/p5-Business-WorldPay-Junior/Makefile b/finance/p5-Business-WorldPay-Junior/Makefile
index f6eff9ab952e..89b3157d5fc2 100644
--- a/finance/p5-Business-WorldPay-Junior/Makefile
+++ b/finance/p5-Business-WorldPay-Junior/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: Business::OnlinePayment::WorldPay::Junior
-# Date created: 24 October 2002
-# Whom: Maxim Sobolev <sobomax@FreeBSD.org>
-#
+# Created by: Maxim Sobolev <sobomax@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= Business-WorldPay-Junior
PORTVERSION= 1.07
@@ -19,7 +15,8 @@ BUILD_DEPENDS= p5-Business-CreditCard>=0:${PORTSDIR}/finance/p5-Business-CreditC
p5-DBI>=0:${PORTSDIR}/databases/p5-DBI
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure patch
MAN3= Business::WorldPay::Junior.3