aboutsummaryrefslogtreecommitdiffstats
path: root/finance
diff options
context:
space:
mode:
authorclsung <clsung@FreeBSD.org>2006-08-15 07:06:39 +0800
committerclsung <clsung@FreeBSD.org>2006-08-15 07:06:39 +0800
commit50795f01a3c57015e598ca1fc2157ee9960e872b (patch)
tree40f8c09ac63b030feb0791010ae8056bea6d5eff /finance
parent7ef47488cb05bd8fb665e2190fa43d7b2255c15c (diff)
downloadfreebsd-ports-gnome-50795f01a3c57015e598ca1fc2157ee9960e872b.tar.gz
freebsd-ports-gnome-50795f01a3c57015e598ca1fc2157ee9960e872b.tar.zst
freebsd-ports-gnome-50795f01a3c57015e598ca1fc2157ee9960e872b.zip
- s,INSTALLS_SHLIB,USE_LDCONFIG,g
- these include dns/ editors/ emulators/ finance/ games/ graphics/ maintained by ports@ PR: ports/101916 Submitted by: Gea-Suan Lin <gslin_AT_gslin dot org>
Diffstat (limited to 'finance')
-rw-r--r--finance/gnucash-devel/Makefile2
-rw-r--r--finance/gnucash/Makefile2
-rw-r--r--finance/ktoblzcheck/Makefile2
-rw-r--r--finance/libofx/Makefile2
-rw-r--r--finance/openhbci/Makefile2
-rw-r--r--finance/qhacc/Makefile2
-rw-r--r--finance/quantlib/Makefile2
7 files changed, 7 insertions, 7 deletions
diff --git a/finance/gnucash-devel/Makefile b/finance/gnucash-devel/Makefile
index 2d3471790d4c..6d0df73694ec 100644
--- a/finance/gnucash-devel/Makefile
+++ b/finance/gnucash-devel/Makefile
@@ -36,7 +36,7 @@ USE_XPM= yes
USE_PERL5= yes
USE_GNOME= gnomeprefix gnomehack gnomeprint libglade gtkhtml libghttp intltool intlhack
GNU_CONFIGURE= yes
-INSTALLS_SHLIB= yes
+USE_LDCONFIG= yes
CONFIGURE_ARGS= --with-glib-config=${GLIB_CONFIG} \
--enable-ofx \
--disable-error-on-warning
diff --git a/finance/gnucash/Makefile b/finance/gnucash/Makefile
index 51fa485376a2..04a7a1b369ff 100644
--- a/finance/gnucash/Makefile
+++ b/finance/gnucash/Makefile
@@ -37,7 +37,7 @@ USE_XPM= yes
USE_PERL5= yes
USE_GNOME= gnomeprefix gnomehack gnomeprint libglade gtkhtml libghttp intltool intlhack
GNU_CONFIGURE= yes
-INSTALLS_SHLIB= yes
+USE_LDCONFIG= yes
CONFIGURE_ARGS= --with-glib-config=${GLIB_CONFIG} \
--enable-ofx \
--disable-error-on-warning
diff --git a/finance/ktoblzcheck/Makefile b/finance/ktoblzcheck/Makefile
index 2ee75ad042d3..dd64fa735ccd 100644
--- a/finance/ktoblzcheck/Makefile
+++ b/finance/ktoblzcheck/Makefile
@@ -18,7 +18,7 @@ USE_GNOME= gnomehack gnometarget pkgconfig
USE_PYTHON= 2.3+
USE_GMAKE= yes
USE_AUTOTOOLS= libtool:15
-INSTALLS_SHLIB= yes
+USE_LDCONFIG= yes
MAN1= ktoblzcheck.1
diff --git a/finance/libofx/Makefile b/finance/libofx/Makefile
index 69856475f2ea..4224451f03e4 100644
--- a/finance/libofx/Makefile
+++ b/finance/libofx/Makefile
@@ -25,7 +25,7 @@ GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
CONFIGURE_ARGS= --disable-doxygen --disable-dot --disable-gengetopt \
--with-opensp-includes=${LOCALBASE}/include/OpenSP
-INSTALLS_SHLIB= yes
+USE_LDCONFIG= yes
CPPFLAGS= -I${LOCALBASE}/include
LDFLAGS= -L${LOCALBASE}/lib
diff --git a/finance/openhbci/Makefile b/finance/openhbci/Makefile
index a8273b8d93ac..69ad57d81c3a 100644
--- a/finance/openhbci/Makefile
+++ b/finance/openhbci/Makefile
@@ -17,7 +17,7 @@ COMMENT= HBCI is a bank-independent homebanking standard
WRKSRC= ${WRKDIR}/${PORTNAME}-0.9.17
GNU_CONFIGURE= yes
CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
-INSTALLS_SHLIB= yes
+USE_LDCONFIG= yes
.include <bsd.port.pre.mk>
diff --git a/finance/qhacc/Makefile b/finance/qhacc/Makefile
index 97c6256d6941..b907a17423ed 100644
--- a/finance/qhacc/Makefile
+++ b/finance/qhacc/Makefile
@@ -25,7 +25,7 @@ CONFIGURE_ARGS= --with-qt-moc=${QT_PREFIX}/bin \
--with-qt-libs=${QT_PREFIX}/lib
MAKE_ARGS= ACLOCAL="${TRUE}" AUTOCONF="${TRUE}" AUTOMAKE="${TRUE}" \
AUTOHEADER="${TRUE}"
-INSTALLS_SHLIB= yes
+USE_LDCONFIG= yes
QTCPPFLAGS+= ${PTHREAD_CFLAGS}
QTCFGLIBS+= ${PTHREAD_LIBS}
diff --git a/finance/quantlib/Makefile b/finance/quantlib/Makefile
index 36af51929acb..1578e7641ef8 100644
--- a/finance/quantlib/Makefile
+++ b/finance/quantlib/Makefile
@@ -23,7 +23,7 @@ USE_GCC= 3.3
GNU_CONFIGURE= yes
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ENV= CPPFLAGS="${PTHREAD_CFLAGS}" LDFLAGS="${PTHREAD_LIBS}"
-INSTALLS_SHLIB= yes
+USE_LDCONFIG= yes
MAN1= quantlib-config.1 quantlib-test-suite.1