aboutsummaryrefslogtreecommitdiffstats
path: root/finance
diff options
context:
space:
mode:
authormakc <makc@FreeBSD.org>2014-02-01 20:17:42 +0800
committermakc <makc@FreeBSD.org>2014-02-01 20:17:42 +0800
commit0f5e1d428847cbc3e4fd726b997bf1d929a4a99c (patch)
tree270b8293a823ae8f2af62cb68b1058b435eb71ac /finance
parent7cb1d75f900f92c341f87d0c77f3bee7bea76c8f (diff)
downloadfreebsd-ports-gnome-0f5e1d428847cbc3e4fd726b997bf1d929a4a99c.tar.gz
freebsd-ports-gnome-0f5e1d428847cbc3e4fd726b997bf1d929a4a99c.tar.zst
freebsd-ports-gnome-0f5e1d428847cbc3e4fd726b997bf1d929a4a99c.zip
Replace KDE4 sharedmime with USES=shared-mime-info. KDE4 sharedmime is
deprecated and will be removed along with switching KDE4_PREFIX to ${LOCALBASE} soon.
Diffstat (limited to 'finance')
-rw-r--r--finance/kmymoney-kde4/Makefile4
-rw-r--r--finance/skrooge/Makefile4
2 files changed, 4 insertions, 4 deletions
diff --git a/finance/kmymoney-kde4/Makefile b/finance/kmymoney-kde4/Makefile
index ab7979d698c9..c3660f3c493c 100644
--- a/finance/kmymoney-kde4/Makefile
+++ b/finance/kmymoney-kde4/Makefile
@@ -15,10 +15,10 @@ LIB_DEPENDS= libboost_graph.so:${PORTSDIR}/devel/boost-libs \
libalkimia.so:${PORTSDIR}/finance/libalkimia
USE_XZ= yes
-USES= cmake pkgconfig
+USES= cmake pkgconfig shared-mime-info
USE_QT4= gui dbus network phonon sql svg xml \
qmake_build moc_build rcc_build uic_build
-USE_KDE4= kdehier kdeprefix automoc4 kdelibs pimlibs sharedmime
+USE_KDE4= kdehier kdeprefix automoc4 kdelibs pimlibs
USE_LDCONFIG= yes
NO_STAGE= yes
diff --git a/finance/skrooge/Makefile b/finance/skrooge/Makefile
index b9c51c2544cc..43afad3f4b54 100644
--- a/finance/skrooge/Makefile
+++ b/finance/skrooge/Makefile
@@ -17,11 +17,11 @@ LIB_DEPENDS= ofx:${PORTSDIR}/finance/libofx \
kactivities:${PORTSDIR}/x11/kactivities
USE_BZIP2= yes
-USES= cmake:outsource gettext
+USES= cmake:outsource gettext shared-mime-info
USE_SQLITE= yes
USE_QT4= qmake_build moc_build uic_build rcc_build designer_build \
corelib dbus gui script sql webkit xml sql-sqlite3_run
-USE_KDE4= automoc4 kdehier kdelibs kdeprefix pimlibs sharedmime
+USE_KDE4= automoc4 kdehier kdelibs kdeprefix pimlibs
USE_LDCONFIG= yes
PLIST_SUB= VERSION=${PORTVERSION}