aboutsummaryrefslogtreecommitdiffstats
path: root/finance
diff options
context:
space:
mode:
authoramdmi3 <amdmi3@FreeBSD.org>2015-07-29 05:38:03 +0800
committeramdmi3 <amdmi3@FreeBSD.org>2015-07-29 05:38:03 +0800
commit38b06296c2423f46203435eda0fbfcf0623d1faa (patch)
tree544738e067586f2e18c44658eea7fab6b715e224 /finance
parentc83a3fa47cbce665270887813ab7b24eed2c2d5e (diff)
downloadfreebsd-ports-gnome-38b06296c2423f46203435eda0fbfcf0623d1faa.tar.gz
freebsd-ports-gnome-38b06296c2423f46203435eda0fbfcf0623d1faa.tar.zst
freebsd-ports-gnome-38b06296c2423f46203435eda0fbfcf0623d1faa.zip
- Fix shebangs
Approved by: portmgr blanket MFH: 2015Q3 (blanket)
Diffstat (limited to 'finance')
-rw-r--r--finance/bitcoin-armory/Makefile6
1 files changed, 5 insertions, 1 deletions
diff --git a/finance/bitcoin-armory/Makefile b/finance/bitcoin-armory/Makefile
index 829c5cee6c3a..5cc3a56e57f8 100644
--- a/finance/bitcoin-armory/Makefile
+++ b/finance/bitcoin-armory/Makefile
@@ -3,6 +3,7 @@
PORTNAME= BitcoinArmory
PORTVERSION= 0.92.3
+PORTREVISION= 1
DISTVERSIONPREFIX= v
CATEGORIES= finance
@@ -23,7 +24,8 @@ RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}qt4-core>=${PYQT4_VERSION}:${PORTSDIR}/devel
USE_GITHUB= yes
GH_ACCOUNT= etotheipi
-USES= gmake python
+USES= gmake python shebangfix
+SHEBANG_FILES= extras/extractKeysFromWallet.py
USE_GCC= yes
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
@@ -34,9 +36,11 @@ ONLY_FOR_ARCHS_REASON= low-level code available only for i386 and amd64
post-patch:
@${REINPLACE_CMD} 's/python-config/$${PYTHON_CONFIG}/' ${WRKSRC}/cppForSwig/Makefile
+
post-stage:
@${SED} -i.bak -e 's|%%LOCALBASE%%|${LOCALBASE}|g' ${STAGEDIR}/${LOCALBASE}/bin/armory && \
${RM} -f ${STAGEDIR}/${LOCALBASE}/bin/armory.bak
+
post-install:
@${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/armory/_CppBlockUtils.so