aboutsummaryrefslogtreecommitdiffstats
path: root/finance
diff options
context:
space:
mode:
authormezz <mezz@FreeBSD.org>2012-12-30 07:00:38 +0800
committermezz <mezz@FreeBSD.org>2012-12-30 07:00:38 +0800
commitaa1ccad6cea6fa548cc2549dc0c9cec22579ab77 (patch)
tree08afdd0b60e59b49778a54d259060a11c8c6b663 /finance
parent5861e36aa012ddc900cbf3fb09669fb4a6b8c88f (diff)
downloadfreebsd-ports-gnome-aa1ccad6cea6fa548cc2549dc0c9cec22579ab77.tar.gz
freebsd-ports-gnome-aa1ccad6cea6fa548cc2549dc0c9cec22579ab77.tar.zst
freebsd-ports-gnome-aa1ccad6cea6fa548cc2549dc0c9cec22579ab77.zip
Fix the generate of .pyc/pyo (Python bytecode), bump the PORTREVISION.
PR: ports/171381 Submitted by: "John W. O'Brien" <john@saltant.com>
Diffstat (limited to 'finance')
-rw-r--r--finance/gnucash/Makefile10
1 files changed, 8 insertions, 2 deletions
diff --git a/finance/gnucash/Makefile b/finance/gnucash/Makefile
index fa069c4291e2..560dd7ac533d 100644
--- a/finance/gnucash/Makefile
+++ b/finance/gnucash/Makefile
@@ -3,7 +3,7 @@
PORTNAME= gnucash
PORTVERSION= 2.4.11
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= finance gnome
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}%20%28stable%29/${PORTVERSION}
@@ -106,7 +106,7 @@ LIB_DEPENDS+= webkitgtk-1.0:${PORTSDIR}/www/webkit-gtk2
USE_GNOME+= gtkhtml3
.endif
-.if${PORT_OPTIONS:MPYTHON}
+.if ${PORT_OPTIONS:MPYTHON}
CONFIGURE_ARGS+=--enable-python-bindings
USE_PYTHON= yes
PLIST_SUB+= PYTHON=""
@@ -115,6 +115,12 @@ PLIST_SUB+= PYTHON="@comment "
.endif
post-install:
+.if ${PORT_OPTIONS:MPYTHON}
+ @${PYTHON_CMD} ${PYTHON_LIBDIR}/compileall.py \
+ ${PYTHON_SITELIBDIR:S|${LOCALBASE}|${PREFIX}|}/${PORTNAME}
+ @${PYTHON_CMD} -O ${PYTHON_LIBDIR}/compileall.py \
+ ${PYTHON_SITELIBDIR:S|${LOCALBASE}|${PREFIX}|}/${PORTNAME}
+.endif
@${CAT} ${PKGMESSAGE}
.include <bsd.port.mk>