aboutsummaryrefslogtreecommitdiffstats
path: root/finance
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2013-04-30 06:27:05 +0800
committerbapt <bapt@FreeBSD.org>2013-04-30 06:27:05 +0800
commit31426e557795495adeb04aa9e16edb4c93184379 (patch)
tree8583dfe71adaea6ce266633e1799cd602516b801 /finance
parentb36431c8212c7fe9fc83e2f7412d5935b6e10e6e (diff)
downloadfreebsd-ports-gnome-31426e557795495adeb04aa9e16edb4c93184379.tar.gz
freebsd-ports-gnome-31426e557795495adeb04aa9e16edb4c93184379.tar.zst
freebsd-ports-gnome-31426e557795495adeb04aa9e16edb4c93184379.zip
Convert a bunch of ports from WITHOUT_NLS -> ${PORT_OPTIONS:MNLS}
While here: - trim headers - convert to new options framework
Diffstat (limited to 'finance')
-rw-r--r--finance/gnofin/Makefile10
-rw-r--r--finance/grisbi/Makefile18
2 files changed, 12 insertions, 16 deletions
diff --git a/finance/gnofin/Makefile b/finance/gnofin/Makefile
index 74dabe8475bf..793b0ee4783e 100644
--- a/finance/gnofin/Makefile
+++ b/finance/gnofin/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: gnofin
-# Date created: Sun Jul 18 1999
-# Whom: domi@saargate.de
-#
+# Created by: domi@saargate.de
# $FreeBSD$
-#
PORTNAME= gnofin
PORTVERSION= 0.8.4
@@ -22,7 +18,9 @@ GNU_CONFIGURE= yes
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
-.if !defined(WITHOUT_NLS)
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MNLS}
USES+= gettext
PLIST_SUB= NLS=""
.else
diff --git a/finance/grisbi/Makefile b/finance/grisbi/Makefile
index 048e9045e372..1cb7336ce041 100644
--- a/finance/grisbi/Makefile
+++ b/finance/grisbi/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: grisbi
-# Date created: 19 November 2002
-# Whom: Thierry Thomas <thierry@pompo.net>
-#
+# Created by: Thierry Thomas <thierry@pompo.net>
# $FreeBSD$
-#
PORTNAME= grisbi
PORTVERSION= 0.8.9
@@ -32,18 +28,20 @@ MAN1= grisbi.1
CPPFLAGS+= -I${LOCALBASE}/include ${PTHREAD_CFLAGS}
LDFLAGS+= -L${LOCALBASE}/lib ${PTHREAD_LIBS}
-.if defined(WITHOUT_NLS)
-CONFIGURE_ARGS+=--disable-nls
-PLIST_SUB+= NLS="@comment "
-.else
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MNLS}
USES+= gettext
PLIST_SUB+= NLS=""
+.else
+CONFIGURE_ARGS+=--disable-nls
+PLIST_SUB+= NLS="@comment "
.endif
pre-configure:
${REINPLACE_CMD} -e "s|-lpthread|${PTHREAD_LIBS}|g" \
${WRKSRC}/${CONFIGURE_SCRIPT}
-.if defined(NOPORTDOCS)
+.if ! ${PORT_OPTIONS:MDOCS}
${REINPLACE_CMD} -e "s|pixmaps help|pixmaps|" ${WRKSRC}/Makefile.in
.endif