aboutsummaryrefslogtreecommitdiffstats
path: root/finance
diff options
context:
space:
mode:
authoroliver <oliver@FreeBSD.org>2003-07-06 18:14:34 +0800
committeroliver <oliver@FreeBSD.org>2003-07-06 18:14:34 +0800
commit4fd1c8e689a9d3cc2704d2554c776a145816cbe6 (patch)
tree89d178a7a7b70336fed9683257d9d0468c703f8f /finance
parent567625c791ff8e5b2f312d4caf8e561f1dc99f52 (diff)
downloadfreebsd-ports-gnome-4fd1c8e689a9d3cc2704d2554c776a145816cbe6.tar.gz
freebsd-ports-gnome-4fd1c8e689a9d3cc2704d2554c776a145816cbe6.tar.zst
freebsd-ports-gnome-4fd1c8e689a9d3cc2704d2554c776a145816cbe6.zip
replace ${PERL} with ${REINPLACE_CMD}
PR: 47406
Diffstat (limited to 'finance')
-rw-r--r--finance/gnofin/Makefile19
1 files changed, 10 insertions, 9 deletions
diff --git a/finance/gnofin/Makefile b/finance/gnofin/Makefile
index 968b8ebdf541..c30a337e2f81 100644
--- a/finance/gnofin/Makefile
+++ b/finance/gnofin/Makefile
@@ -14,6 +14,7 @@ MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= ports@FreeBSD.org
COMMENT= Light-weight GNOME based financial management program
+USE_REINPLACE= yes
USE_X_PREFIX= yes
USE_GMAKE= yes
USE_GNOME= yes
@@ -24,14 +25,14 @@ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
MAN1= gnofin.1
pre-patch:
- @${PERL} -pi -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
- s|DATADIRNAME=lib|DATADIRNAME=share|g ; \
- s|USE_INCLUDED_LIBINTL=yes|#USE_INCLUDED_LIBINTL=yes|g ; \
- s|\$$\(top_builddir\)/intl/libintl.a|-lintl|g' ${WRKSRC}/configure
- @find ${WRKSRC} -name "Makefile.in" | xargs ${PERL} -pi -e \
- 's|\$$\(datadir\)/gnome/|\$$\(datadir\)/|g ; \
- s|\$$\(datadir\)/locale|\$$\(prefix\)/share/locale|g'
- @find ${WRKSRC}/plugins -name "Makefile.in" | xargs ${PERL} -pi -e \
- 's|_la_LDFLAGS =|_la_LDFLAGS = -avoid-version|g'
+ @${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|g' \
+ -e 's|DATADIRNAME=lib|DATADIRNAME=share|g' \
+ -e 's|USE_INCLUDED_LIBINTL=yes|#USE_INCLUDED_LIBINTL=yes|' \
+ -e 's|$$(top_builddir)/intl/libintl.a|-lintl|g' ${WRKSRC}/configure
+ @${FIND} ${WRKSRC} -name "Makefile.in" | ${XARGS} ${REINPLACE_CMD} \
+ -e 's|$$(datadir)/gnome/|$$(datadir)/|g' \
+ -e ' s|$$(datadir)/locale|$$(prefix)/share/locale|g'
+ @{FIND} ${WRKSRC}/plugins -name "Makefile.in" | ${XARGS} ${REINPLACE_CMD} \
+ -e 's|_la_LDFLAGS =|_la_LDFLAGS = -avoid-version|g'
.include <bsd.port.mk>
n> * . Update to 7u71.glewis2014-10-312-3/+3 * . Update to 7u71.glewis2014-10-313-177/+178 * Merge Linux-specific changes to BSD patches. Most importantly, this changejkim2014-10-313-3/+25 * . Update to 2014i.glewis2014-10-293-23/+4 * Update to 5.1 release.ale2014-10-283-5/+4 * - Convert ports from german/, java/, japanese/ and ports-mgmt/ to newmva2014-10-201-2/+1 * The MAP_NORESERVE flag to mmap() has never been implemented in FreeBSD andjhb2014-10-183-6/+85 * - Update to b33.jkim2014-10-174-715/+1485 * java/java-checkstyle: Upgrade version 5.5 => 5.8marino2014-10-102-5/+8 * java/visualvm: update to 1.3.8swills2014-10-093-21/+26 * Fix build with gmake 4.1bapt2014-10-081-0/+11 * Doesn't build with java 6.ale2014-10-031-1/+1 * Upgrade from 3.2.76 to 6.1.5 (the latest at this time). Fix up the WWW-entrymi2014-09-304-9/+7 * - Update to 8.0.1gahr2014-09-263-532/+111 * java/java3d: Set to dual GPLv2 and MIT licensingmarino2014-09-261-3/+3 * Replace USE_AUTOTOOLS=libltdl with an ordinary LIB_DEPENDS in all ports.tijl2014-09-171-2/+2 * Allow staging as a regular userantoine2014-09-121-4/+1 * Fix build by forcing -lpopt.adamw2014-09-111-0/+2 * Update the default version of GCC in the Ports Collection from GCC 4.7.4gerald2014-09-1140-33/+40 * Add USES=libtool and INSTALL_TARGET=install-striptijl2014-09-092-13/+5 * Add USES=libtool and INSTALL_TARGET=install-striptijl2014-09-092-5/+5 * Remove non staged ports without pending PR from j*bapt2014-09-0223-715/+0 * . Update to 2014f.glewis2014-08-313-16/+5 * Stage java/eclipse-langpackmarino2014-08-314-24/+13 * java/eclipse: Set a default theme and external browserrobak2014-08-273-3/+61 * Update to 5.0 release.ale2014-08-272-3/+3 * . Update to 8u20.glewis2014-08-243-6/+3 * . Update to 8u20glewis2014-08-243-184/+232 * Canonicalize a few LICENSE_PERMSantoine2014-08-221-1/+1 * many ruby/rubygem ports: death of rubyforge.orgswills2014-08-191-1/+1 * - Add USES=libtooltijl2014-08-182-14/+9 * - Add USES=libtooltijl2014-08-183-9/+36 * Update to latest 1.8.10lev2014-08-121-1/+4 * Finish stage supportantoine2014-08-122-16/+6 * Finish stage conversionantoine2014-08-112-2/+1 * Fix stage violationantoine2014-08-101-1/+1 * . Update to 7u67.glewis2014-08-102-3/+3 * . Update to 7u67.glewis2014-08-102-5/+5 * - Update from 1.1b5 to 3.1a1danilo2014-08-033-9/+10 * Convert a bunch of USE_XZ to USES=tar:xz.adamw2014-07-301-2/+1 * Convert a bunch of EXTRACT_SUFX=... into USES=tar:...adamw2014-07-301-2/+1 * Convert a bunch of USE_BZIP2 to USES=tar:bzip2adamw2014-07-301-2/+1 * Reset maintainership for ports not staged with no pending PRbapt2014-07-241-1/+1 * . Don't hardcode /bin/bash. Fixes build trace output.glewis2014-07-211-0/+11 * . Introduce a DIST_BUILD_NUMBER variable and refer to that in both DISTNAMEglewis2014-07-211-2/+4 * . Update to 8u11. This requires moving the patch file for 8u5 to startglewis2014-07-214-17/+6011 * - Update to b32.jkim2014-07-175-141/+310 * . Update to 7u65.glewis2014-07-163-2239/+9703 * . Update to 8u11.glewis2014-07-162-3/+3 * . Update to 8u11.glewis2014-07-162-5/+5 * . Update to 7u65.glewis2014-07-162-3/+3 * . Update to 7u65.glewis2014-07-162-5/+5 * Add EXAMPLES to OPTIONS_DEFINE to ports that check for PORT_OPTIONS:MEXAMPLES.adamw2014-07-161-1/+1 * Add DOCS to OPTIONS_DEFINE to ports that check for PORT_OPTIONS:MDOCS.adamw2014-07-153-2/+4 * Modernize LIB_DEPENDSbapt2014-07-141-1/+1 * java/wildfly80: fix building as userpi2014-07-132-4/+3 * . Fix unpack200 on i386/amd64 by only swapping bytes when this is actuallyglewis2014-07-133-7/+30 * java/dbvis: Swap order-sensitive categories to unbreak PKGORIGINmarino2014-07-121-1/+1 * java/dbvis: Update version 7.1 => 9.1.6 and stagemarino2014-07-122-7/+13 * Update 8 plugins following upgrade to Eclipse 4.3.2marino2014-07-1212-36/+35 * java/eclipse: Fix dropins locationmarino2014-07-121-0/+3 * @owner not @userbapt2014-07-061-2/+2 * @owner not @userbapt2014-07-061-1/+1 * Support stagebapt2014-07-062-4/+6 * Support stagebapt2014-07-062-12/+6 * Allow packaging as a userbapt2014-07-061-0/+4 * Support stagebapt2014-07-061-6/+3 * Remove indefinite articles and trailing periods from COMMENT, plus minorolgeni2014-07-0614-14/+14 * Remove NOPORTDOCS and NOPORTEXAMPLES from unstaged ports. Stage a couple whileadamw2014-07-052-4/+10 * Remove NOPORTDOCS and NOPORTEXAMPLES.adamw2014-07-0410-109/+98 * Correct typo declaring ONLY_FOR_ARCHSsbruno2014-07-031-1/+1 * - Update to 3.9.2jhale2014-06-302-15/+9 * Remove java/eclipse-devel as java/eclipse is newermarino2014-06-2912-8805/+0 * Restore eclipse Makefile.plugins instead of breaking/expiring ports using itantoine2014-06-281-4/+12 * Ports attempting to use eclipse Makefile.plugins are BROKEN, not IGNOREantoine2014-06-281-1/+3 * Implement current and signal methods for sun.nio.ch.NativeThread. Note thisjkim2014-06-288-4/+158 * - Chase database/sqlite3 slib bumpmiwi2014-06-281-1/+1 * java/eclipse: Change include <pre>/<post> to <options>marino2014-06-261-2/+2 * java/eclipse: Put back Makefile.plugins to unbreak indexmarino2014-06-261-0/+4 * java/eclipse: Remove troublesome comment completelymarino2014-06-261-2/+0 * java/eclipse: Tweak comment to satisfy freshports sanity checkmarino2014-06-261-1/+1 * java/eclipse: Update version 3.7.1 => 4.3.2 and assign maintainermarino2014-06-2613-8809/+3551 * Convert GMAKE to MAKE_CMDbapt2014-06-252-3/+3 * Remove interractive this ports can be installed without the graphical installerbapt2014-06-234-15/+22 * Unbreakantoine2014-06-211-1/+1 * . Update to 2014e.glewis2014-06-192-3/+3 * Stagify.vanilla2014-06-171-8/+7 * Stagify.vanilla2014-06-171-6/+5 * Stagify.vanilla2014-06-171-6/+5 * Stagify.vanilla2014-06-171-7/+6 * Stagify.vanilla2014-06-171-8/+7 * Stagify.vanilla2014-06-171-9/+8 * Stagify.vanilla2014-06-171-4/+3 * Stagify.vanilla2014-06-171-9/+8 * Stagify.vanilla2014-06-171-8/+7 * Stagify.vanilla2014-06-171-4/+3 * Stagify.vanilla2014-06-171-4/+3 * Stagify.vanilla2014-06-171-4/+3 * Stagify.vanilla2014-06-171-8/+7 * Stagify.vanilla2014-06-171-6/+2 * Stagify.vanilla2014-06-171-7/+7 * Stagify.vanilla2014-06-171-3/+2 * Stagify.vanilla2014-06-171-8/+7 * Stagify.vanilla2014-06-171-3/+2 * Stagify.vanilla2014-06-171-7/+6 * subversion port has been overhauled. Some optional parts was extractedlev2014-06-162-11/+13 * Remove redundant uses of NO_CDROM with RESTRICTED.jkim2014-06-125-5/+0 * Support LIBS like LDFLAGS.tijl2014-06-111-1/+2 * USE_XZ --> USES=tar:xz.demon2014-06-101-2/+1 * - Update to 2.8.2nivit2014-06-103-53/+21 * . Add a pkg-message explaining that procfs and fdescfs may be required.glewis2014-06-101-0/+16 * Java Development Kit 8 Documentation. Contains release information,jkim2014-06-104-0/+47 * Chase distfile change and support staging.jkim2014-06-102-10/+7 * Use new LIB_DEPENDS format. Remove unnecessary NO_STAGE.jkim2014-06-101-3/+2 * Remove unnecessary NO_STAGE.jkim2014-06-101-1/+0 * Update to 7u60.jkim2014-06-102-11/+7 * Support staging.jkim2014-06-102-7/+10 * Support staging. While here, get rid of the two-line pkg-plist.mi2014-06-102-10/+2 * Remove all space characters from Makefile assignments.olgeni2014-06-092-12/+12 * Remove indefinite articles from COMMENT where I'm maintainer.olgeni2014-06-081-1/+1 * Stagify.vanilla2014-06-081-6/+5 * Stagify.vanilla2014-06-081-4/+3 * Update to 7u60.glewis2014-06-08