aboutsummaryrefslogtreecommitdiffstats
path: root/finance
diff options
context:
space:
mode:
authorleeym <leeym@FreeBSD.org>2009-10-07 13:00:55 +0800
committerleeym <leeym@FreeBSD.org>2009-10-07 13:00:55 +0800
commit8b497ccc50f94d90ede85c209e2c97f1e4693034 (patch)
treeac79b733d228ac7d265aaa656afb636949d437a0 /finance
parente18d803cd57ebf33d10ddef5365a63352f1d8505 (diff)
downloadfreebsd-ports-gnome-8b497ccc50f94d90ede85c209e2c97f1e4693034.tar.gz
freebsd-ports-gnome-8b497ccc50f94d90ede85c209e2c97f1e4693034.tar.zst
freebsd-ports-gnome-8b497ccc50f94d90ede85c209e2c97f1e4693034.zip
- add Finance::YahooQuote 0.22
This module gets stock quotes from Yahoo! Finance. The getonequote function will return a quote for a single stock symbol, while the getquote function will return a quote for each of the stock symbols passed to it. getcustomquote allows to specify a format other than the default to take advantage of the extended range of available information. WWW: http://search.cpan.org/dist/Finance-YahooQuote/
Diffstat (limited to 'finance')
-rw-r--r--finance/Makefile1
-rw-r--r--finance/p5-Finance-YahooQuote/Makefile26
-rw-r--r--finance/p5-Finance-YahooQuote/distinfo3
-rw-r--r--finance/p5-Finance-YahooQuote/pkg-descr8
-rw-r--r--finance/p5-Finance-YahooQuote/pkg-plist6
5 files changed, 44 insertions, 0 deletions
diff --git a/finance/Makefile b/finance/Makefile
index 590af6fe0c58..e3379c392234 100644
--- a/finance/Makefile
+++ b/finance/Makefile
@@ -68,6 +68,7 @@
SUBDIR += p5-Finance-QuoteTW
SUBDIR += p5-Finance-TW-EmergingQuote
SUBDIR += p5-Finance-TW-TSEQuote
+ SUBDIR += p5-Finance-YahooQuote
SUBDIR += p5-Locale-Currency-Format
SUBDIR += p5-Math-Financial
SUBDIR += p5-PFProAPI
diff --git a/finance/p5-Finance-YahooQuote/Makefile b/finance/p5-Finance-YahooQuote/Makefile
new file mode 100644
index 000000000000..0cde72d80077
--- /dev/null
+++ b/finance/p5-Finance-YahooQuote/Makefile
@@ -0,0 +1,26 @@
+# New ports collection makefile for: Finance::YahooQuote
+# Date created: 2009-10-06
+# Whom: Yen-Ming Lee <leeym@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Finance-YahooQuote
+PORTVERSION= 0.22
+CATEGORIES= finance perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= leeym@FreeBSD.org
+COMMENT= Get stock quotes from Yahoo! Finance
+
+RUN_DEPENDS= p5-HTML-Parser>=2.2:${PORTSDIR}/www/p5-HTML-Parser \
+ p5-libwww>=1.62:${PORTSDIR}/www/p5-libwww
+BUILD_DEPENDS= ${RUN_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN1= yahooquote.1
+MAN3= Finance::YahooQuote.3
+
+.include <bsd.port.mk>
diff --git a/finance/p5-Finance-YahooQuote/distinfo b/finance/p5-Finance-YahooQuote/distinfo
new file mode 100644
index 000000000000..80fd2e7cce31
--- /dev/null
+++ b/finance/p5-Finance-YahooQuote/distinfo
@@ -0,0 +1,3 @@
+MD5 (Finance-YahooQuote-0.22.tar.gz) = f38b620a7126be785442cda794d052ca
+SHA256 (Finance-YahooQuote-0.22.tar.gz) = a7f6008aaae7f03a92edaa09a0fe3738a88ef5d6182577fd5f0faf5e3d471fc1
+SIZE (Finance-YahooQuote-0.22.tar.gz) = 22390
diff --git a/finance/p5-Finance-YahooQuote/pkg-descr b/finance/p5-Finance-YahooQuote/pkg-descr
new file mode 100644
index 000000000000..c29701363b2f
--- /dev/null
+++ b/finance/p5-Finance-YahooQuote/pkg-descr
@@ -0,0 +1,8 @@
+This module gets stock quotes from Yahoo! Finance. The getonequote
+function will return a quote for a single stock symbol, while the
+getquote function will return a quote for each of the stock symbols
+passed to it. getcustomquote allows to specify a format other than
+the default to take advantage of the extended range of available
+information.
+
+WWW: http://search.cpan.org/dist/Finance-YahooQuote/
diff --git a/finance/p5-Finance-YahooQuote/pkg-plist b/finance/p5-Finance-YahooQuote/pkg-plist
new file mode 100644
index 000000000000..951e0c3c9456
--- /dev/null
+++ b/finance/p5-Finance-YahooQuote/pkg-plist
@@ -0,0 +1,6 @@
+bin/yahooquote
+%%SITE_PERL%%/Finance/YahooQuote.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Finance/YahooQuote/.packlist
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Finance/YahooQuote
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Finance
+@dirrmtry %%SITE_PERL%%/Finance