aboutsummaryrefslogtreecommitdiffstats
path: root/finance
diff options
context:
space:
mode:
authorwen <wen@FreeBSD.org>2012-09-18 16:09:30 +0800
committerwen <wen@FreeBSD.org>2012-09-18 16:09:30 +0800
commita94a96b6c795db46fc0ecfcbba54e79e14e55d55 (patch)
treed4e4c86f5ca69133277ce6b54ff61b2ec8fbe16b /finance
parent08a46fdca0c2493d76deff2699f2524e182784e2 (diff)
downloadfreebsd-ports-gnome-a94a96b6c795db46fc0ecfcbba54e79e14e55d55.tar.gz
freebsd-ports-gnome-a94a96b6c795db46fc0ecfcbba54e79e14e55d55.tar.zst
freebsd-ports-gnome-a94a96b6c795db46fc0ecfcbba54e79e14e55d55.zip
This port adds the Sale Shipment Cost Module to the Tryton Application Platform.
WWW: http://www.tryton.org/ PR: 171467 Submitted by: Matthias Petermann <matthias@d2ux.net>
Diffstat (limited to 'finance')
-rw-r--r--finance/Makefile1
-rw-r--r--finance/trytond_sale_shipment_cost/Makefile27
-rw-r--r--finance/trytond_sale_shipment_cost/distinfo2
-rw-r--r--finance/trytond_sale_shipment_cost/pkg-descr3
-rw-r--r--finance/trytond_sale_shipment_cost/pkg-plist44
5 files changed, 77 insertions, 0 deletions
diff --git a/finance/Makefile b/finance/Makefile
index 9088a976d44e..5cb7ea61064d 100644
--- a/finance/Makefile
+++ b/finance/Makefile
@@ -124,6 +124,7 @@
SUBDIR += trytond_sale
SUBDIR += trytond_sale_opportunity
SUBDIR += trytond_sale_price_list
+ SUBDIR += trytond_sale_shipment_cost
SUBDIR += trytond_stock
SUBDIR += trytond_timesheet
SUBDIR += venice
diff --git a/finance/trytond_sale_shipment_cost/Makefile b/finance/trytond_sale_shipment_cost/Makefile
new file mode 100644
index 000000000000..3a20245889b5
--- /dev/null
+++ b/finance/trytond_sale_shipment_cost/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: trytond_sale_shipment_cost
+# Date created: 08 September, 2012
+# Whom: Matthias Petermann<matthias@petermann.it>
+#
+# $FreeBSD$
+#
+
+PORTNAME= trytond_sale_shipment_cost
+PORTVERSION= 2.4.0
+CATEGORIES= finance python
+MASTER_SITES= http://downloads2.tryton.org/${PORTVERSION:R}/
+
+MAINTAINER= matthias@petermann.it
+COMMENT= Tryton Application Platform (Sale Shipment Cost Module)
+
+LICENSE= GPLv3
+
+RUN_DEPENDS= trytond>=2.4.0:${PORTSDIR}/finance/trytond \
+ trytond_carrier>=2.4.1:${PORTSDIR}/finance/trytond_carrier \
+ trytond_sale>=2.4.0:${PORTSDIR}/finance/trytond_sale \
+ trytond_account_invoice>=2.4.1:${PORTSDIR}/finance/trytond_account_invoice \
+ trytond_stock>=2.4.0:${PORTSDIR}/finance/trytond_stock
+
+USE_PYTHON= yes
+USE_PYDISTUTILS=easy_install
+
+.include <bsd.port.mk>
diff --git a/finance/trytond_sale_shipment_cost/distinfo b/finance/trytond_sale_shipment_cost/distinfo
new file mode 100644
index 000000000000..1335f5089332
--- /dev/null
+++ b/finance/trytond_sale_shipment_cost/distinfo
@@ -0,0 +1,2 @@
+SHA256 (trytond_sale_shipment_cost-2.4.0.tar.gz) = 61822f0b9b9a767f6ffa874ff46b921df0f6418f2e41a19165a182b9d73040bd
+SIZE (trytond_sale_shipment_cost-2.4.0.tar.gz) = 23115
diff --git a/finance/trytond_sale_shipment_cost/pkg-descr b/finance/trytond_sale_shipment_cost/pkg-descr
new file mode 100644
index 000000000000..bd42b46f37d1
--- /dev/null
+++ b/finance/trytond_sale_shipment_cost/pkg-descr
@@ -0,0 +1,3 @@
+This port adds the Sale Shipment Cost Module to the Tryton Application Platform.
+
+WWW: http://www.tryton.org/
diff --git a/finance/trytond_sale_shipment_cost/pkg-plist b/finance/trytond_sale_shipment_cost/pkg-plist
new file mode 100644
index 000000000000..96c9716d0585
--- /dev/null
+++ b/finance/trytond_sale_shipment_cost/pkg-plist
@@ -0,0 +1,44 @@
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/EGG-INFO/PKG-INFO
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/EGG-INFO/SOURCES.txt
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/EGG-INFO/dependency_links.txt
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/EGG-INFO/entry_points.txt
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/EGG-INFO/not-zip-safe
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/EGG-INFO/requires.txt
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/EGG-INFO/top_level.txt
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/trytond/modules/sale_shipment_cost/__init__.py
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/trytond/modules/sale_shipment_cost/__init__.pyc
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/trytond/modules/sale_shipment_cost/__init__.pyo
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/trytond/modules/sale_shipment_cost/__tryton__.py
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/trytond/modules/sale_shipment_cost/__tryton__.pyc
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/trytond/modules/sale_shipment_cost/__tryton__.pyo
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/trytond/modules/sale_shipment_cost/locale/bg_BG.po
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/trytond/modules/sale_shipment_cost/locale/ca_ES.po
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/trytond/modules/sale_shipment_cost/locale/cs_CZ.po
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/trytond/modules/sale_shipment_cost/locale/de_DE.po
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/trytond/modules/sale_shipment_cost/locale/es_AR.po
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/trytond/modules/sale_shipment_cost/locale/es_CO.po
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/trytond/modules/sale_shipment_cost/locale/es_ES.po
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/trytond/modules/sale_shipment_cost/locale/fr_FR.po
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/trytond/modules/sale_shipment_cost/locale/nl_NL.po
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/trytond/modules/sale_shipment_cost/locale/ru_RU.po
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/trytond/modules/sale_shipment_cost/sale.py
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/trytond/modules/sale_shipment_cost/sale.pyc
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/trytond/modules/sale_shipment_cost/sale.pyo
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/trytond/modules/sale_shipment_cost/sale.xml
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/trytond/modules/sale_shipment_cost/stock.py
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/trytond/modules/sale_shipment_cost/stock.pyc
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/trytond/modules/sale_shipment_cost/stock.pyo
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/trytond/modules/sale_shipment_cost/stock.xml
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/trytond/modules/sale_shipment_cost/tests/__init__.py
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/trytond/modules/sale_shipment_cost/tests/__init__.pyc
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/trytond/modules/sale_shipment_cost/tests/__init__.pyo
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/trytond/modules/sale_shipment_cost/tests/test_sale_shipment_cost.py
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/trytond/modules/sale_shipment_cost/tests/test_sale_shipment_cost.pyc
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/trytond/modules/sale_shipment_cost/tests/test_sale_shipment_cost.pyo
+@dirrm %%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/trytond/modules/sale_shipment_cost/tests
+@dirrm %%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/trytond/modules/sale_shipment_cost/locale
+@dirrm %%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/trytond/modules/sale_shipment_cost
+@dirrm %%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/trytond/modules
+@dirrm %%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/trytond
+@dirrm %%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/EGG-INFO
+@dirrm %%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%