aboutsummaryrefslogtreecommitdiffstats
path: root/finance
diff options
context:
space:
mode:
authorjhale <jhale@FreeBSD.org>2018-04-24 08:12:50 +0800
committerjhale <jhale@FreeBSD.org>2018-04-24 08:12:50 +0800
commit754680b33168d24f4ab268ce05473b3286e02c71 (patch)
tree21296f3448c5fe147b3079acb948e6225c23df10 /finance
parenteb6c618cebe04ff53cb54b1e92b5b8e49799aa1b (diff)
downloadfreebsd-ports-gnome-754680b33168d24f4ab268ce05473b3286e02c71.tar.gz
freebsd-ports-gnome-754680b33168d24f4ab268ce05473b3286e02c71.tar.zst
freebsd-ports-gnome-754680b33168d24f4ab268ce05473b3286e02c71.zip
Paypal backend was re-added in this release and was missed due to the
arguments passed by EBIC_CONFIGURE_OFF. Consequently, the pkg-plist was broken when the EBICS option was enabled. Adjust the check for security/xmlsec1 so that aqbanking can be built in poudriere with the EBICS option enabled. MFH: 2018Q2 (blanket)
Diffstat (limited to 'finance')
-rw-r--r--finance/aqbanking/Makefile15
-rw-r--r--finance/aqbanking/pkg-plist13
2 files changed, 22 insertions, 6 deletions
diff --git a/finance/aqbanking/Makefile b/finance/aqbanking/Makefile
index e2b9d0f82b4b..c258f16e5464 100644
--- a/finance/aqbanking/Makefile
+++ b/finance/aqbanking/Makefile
@@ -2,6 +2,7 @@
PORTNAME= aqbanking
PORTVERSION= 5.7.8
+PORTREVISION= 1
CATEGORIES= finance
MASTER_SITES= http://www.aquamaniac.de/sites/download/download.php?package=03&release=217&file=02&dummy=/
@@ -38,18 +39,14 @@ DOXYGEN_BUILD_DEPENDS= doxygen:devel/doxygen \
DOXYGEN_CONFIGURE_ENABLE= full-doc
EBICS_DESC= Enable EBICS backend
-EBICS_LIB_DEPENDS= libxmlsec1-gnutls.so:security/xmlsec1
+EBICS_LIB_DEPENDS= libxmlsec1.so:security/xmlsec1
EBICS_USE= GNOME=libxml2,libxslt
-EBICS_CONFIGURE_OFF= --with-backends="aqhbci aqnone aqofxconnect"
+EBICS_CONFIGURE_OFF= --with-backends="aqhbci aqnone aqofxconnect aqpaypal"
KTOBLZCHECK_DESC= Enable KtoBlzCheck support
.include <bsd.port.options.mk>
-.if ${PORT_OPTIONS:MEBICS} && !exists(${LOCALBASE}/libdata/pkgconfig/xmlsec1-gnutls.pc)
-IGNORE= (Re)Install security/xmlsec1 with the GNUTLS option ON
-.endif
-
.if ${PORT_OPTIONS:MKTOBLZCHECK} || exists(${LOCALBASE}/lib/libktoblzcheck.so)
LIB_DEPENDS+= libktoblzcheck.so:finance/ktoblzcheck
.endif
@@ -58,6 +55,12 @@ LIB_DEPENDS+= libktoblzcheck.so:finance/ktoblzcheck
PORTDOCS= *
.endif
+pre-configure-EBICS-on:
+ @(if [ ! -e ${LOCALBASE}/libdata/pkgconfig/xmlsec1-gnutls.pc ] ; then \
+ ${ECHO_MSG} "(Re)Install security/xmlsec1 with the GNUTLS option ON" ; \
+ exit 1; \
+ fi)
+
post-build-DOXYGEN-on:
@cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} ${MAKE_CMD} srcdoc
diff --git a/finance/aqbanking/pkg-plist b/finance/aqbanking/pkg-plist
index 0b80d278ba85..aa6af0991e3d 100644
--- a/finance/aqbanking/pkg-plist
+++ b/finance/aqbanking/pkg-plist
@@ -2,6 +2,7 @@ bin/aqbanking-cli
bin/aqbanking-config
%%EBICS%%bin/aqebics-tool
bin/aqhbci-tool4
+bin/aqpaypal-tool
bin/hbcixml3
include/aqbanking5/aqbanking/ab_accountqueue.h
include/aqbanking5/aqbanking/ab_accountqueuefns.h
@@ -124,6 +125,9 @@ include/aqbanking5/aqofxconnect/version.h
%%EBICS%%include/aqebics/client/account.h
%%EBICS%%include/aqebics/client/provider.h
%%EBICS%%include/aqebics/client/user.h
+include/aqpaypal/aqpaypal.h
+include/aqpaypal/provider.h
+include/aqpaypal/user.h
lib/aqbanking/plugins/%%AQB_SHLIB_VER%%/bankinfo/at.so
lib/aqbanking/plugins/%%AQB_SHLIB_VER%%/bankinfo/at.xml
lib/aqbanking/plugins/%%AQB_SHLIB_VER%%/bankinfo/ca.so
@@ -168,6 +172,8 @@ lib/aqbanking/plugins/%%AQB_SHLIB_VER%%/providers/aqnone.so
lib/aqbanking/plugins/%%AQB_SHLIB_VER%%/providers/aqnone.xml
lib/aqbanking/plugins/%%AQB_SHLIB_VER%%/providers/aqofxconnect.so
lib/aqbanking/plugins/%%AQB_SHLIB_VER%%/providers/aqofxconnect.xml
+lib/aqbanking/plugins/%%AQB_SHLIB_VER%%/providers/aqpaypal.so
+lib/aqbanking/plugins/%%AQB_SHLIB_VER%%/providers/aqpaypal.xml
lib/cmake/aqbanking-%%AQB_MAJ_MIN_VER%%/aqbanking-config-version.cmake
lib/cmake/aqbanking-%%AQB_MAJ_MIN_VER%%/aqbanking-config.cmake
lib/libaqbanking.so
@@ -188,6 +194,9 @@ lib/libaqnone.so.%%AQB_SHLIB_VER%%.6.8
lib/libaqofxconnect.so
lib/libaqofxconnect.so.7
lib/libaqofxconnect.so.7.0.2
+lib/libaqpaypal.so
+lib/libaqpaypal.so.0
+lib/libaqpaypal.so.0.0.0
libdata/pkgconfig/aqbanking.pc
share/aclocal/aqbanking.m4
%%DATADIR%%/aqbanking/typemaker2/c/ab_account.tm2
@@ -220,6 +229,9 @@ share/aclocal/aqbanking.m4
%%DATADIR%%/backends/aqofxconnect/dialogs/dlg_getinst.dlg
%%DATADIR%%/backends/aqofxconnect/dialogs/dlg_newuser.dlg
%%DATADIR%%/backends/aqofxconnect/dialogs/dlg_ofx_special.dlg
+%%DATADIR%%/backends/aqpaypal/dialogs/dlg_editsecret.dlg
+%%DATADIR%%/backends/aqpaypal/dialogs/dlg_edituser.dlg
+%%DATADIR%%/backends/aqpaypal/dialogs/dlg_newuser.dlg
%%DATADIR%%/bankinfo/at/banks.data
%%DATADIR%%/bankinfo/at/bic.idx
%%DATADIR%%/bankinfo/at/blz.idx
@@ -308,4 +320,5 @@ share/aclocal/aqbanking.m4
%%DATADIR%%/typemaker2/c/ab_userqueue_list.tm2
%%EBICS%%share/doc/aqebics/aqebics-tool/README
share/doc/aqhbci/aqhbci-tool/README
+share/doc/aqpaypal/aqpaypal-tool/README
share/locale/de/LC_MESSAGES/aqbanking.mo