aboutsummaryrefslogtreecommitdiffstats
path: root/finance
diff options
context:
space:
mode:
authormezz <mezz@FreeBSD.org>2006-06-25 10:25:58 +0800
committermezz <mezz@FreeBSD.org>2006-06-25 10:25:58 +0800
commit98369e1612df1d477436803c63b91437ec420137 (patch)
tree54f6d2cfdb9a58996620aa9df786f3d9f1d5646e /finance
parentad82e27e554ae5ae525682b37d7c45ee60f316fb (diff)
downloadfreebsd-ports-gnome-98369e1612df1d477436803c63b91437ec420137.tar.gz
freebsd-ports-gnome-98369e1612df1d477436803c63b91437ec420137.tar.zst
freebsd-ports-gnome-98369e1612df1d477436803c63b91437ec420137.zip
HomeBank is the free software you have always wanted to manage your
personal accounts at home. The main concept is to be light, simple and very easy to use. It brings you many features that allows you to analyze your finances in adetailed way instantly and dynamically with powerfull report tools based on filtering and graphical charts. Furthermore HomeBank benefits now for more than 10 years of users experiences and feedbacks as its development started in 1995 on Amiga computers. It is now available on Amiga, GNU/Linux, and will probably be soon available for Microsoft Windows and MacOS X systems, as GTK+ exists on it. WWW: http://homebank.free.fr/ -- Keep in mind, this is an alpha quality apps. (Homebank 3.2 alpha). I only test it a little so far.
Diffstat (limited to 'finance')
-rw-r--r--finance/Makefile1
-rw-r--r--finance/homebank/Makefile36
-rw-r--r--finance/homebank/distinfo3
-rw-r--r--finance/homebank/files/patch-configure28
-rw-r--r--finance/homebank/files/patch-src_Makefile.in11
-rw-r--r--finance/homebank/files/patch-src_dsp_wallet.c13
-rw-r--r--finance/homebank/files/patch-src_homebank.h10
-rw-r--r--finance/homebank/files/patch-src_rep_budget.c10
-rw-r--r--finance/homebank/pkg-descr13
-rw-r--r--finance/homebank/pkg-plist53
10 files changed, 178 insertions, 0 deletions
diff --git a/finance/Makefile b/finance/Makefile
index ac3176ca7e5a..2f214f9af358 100644
--- a/finance/Makefile
+++ b/finance/Makefile
@@ -12,6 +12,7 @@
SUBDIR += gnucash
SUBDIR += gnucash-docs
SUBDIR += grisbi
+ SUBDIR += homebank
SUBDIR += kexchange
SUBDIR += khacc
SUBDIR += kmymoney2
diff --git a/finance/homebank/Makefile b/finance/homebank/Makefile
new file mode 100644
index 000000000000..5f299d77f7a1
--- /dev/null
+++ b/finance/homebank/Makefile
@@ -0,0 +1,36 @@
+# New ports collection makefile for: homebank
+# Date created: 24 June 2006
+# Whom: Mezz <mezz@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= homebank
+DISTVERSION= 3.2alpha1
+CATEGORIES= finance
+MASTER_SITES= http://homebank.free.fr/public/
+
+MAINTAINER= mezz@FreeBSD.org
+COMMENT= Manage your personal accounts at home
+
+WRKSRC= ${WRKDIR}/${PORTNAME}
+USE_GMAKE= yes
+USE_GNOME= gtk20
+USE_GETTEXT= yes
+USE_DOS2UNIX= src/*
+USE_X_PREFIX= yes
+GNU_CONFIGURE= yes
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib ${PTHREAD_LIBS}"
+
+DOCS= AUTHORS COPYING ChangeLog LICENSE NEWS README
+
+.ifndef (NOPORTDOCS)
+post-install:
+ @${MKDIR} ${DOCSDIR}
+.for i in ${DOCS}
+ @${INSTALL_DATA} ${WRKSRC}/${i} ${DOCSDIR}
+.endfor
+.endif
+
+.include <bsd.port.mk>
diff --git a/finance/homebank/distinfo b/finance/homebank/distinfo
new file mode 100644
index 000000000000..eab09a1a5f3a
--- /dev/null
+++ b/finance/homebank/distinfo
@@ -0,0 +1,3 @@
+MD5 (homebank-3.2alpha1.tar.gz) = ad511db5f935a0979161bb1043d5cd65
+SHA256 (homebank-3.2alpha1.tar.gz) = af1b5b43e804cd3ddfc69ab9af723f5187e2b54af9ef53feb2cdd70d0e008f82
+SIZE (homebank-3.2alpha1.tar.gz) = 536648
diff --git a/finance/homebank/files/patch-configure b/finance/homebank/files/patch-configure
new file mode 100644
index 000000000000..2624c1f7ca8d
--- /dev/null
+++ b/finance/homebank/files/patch-configure
@@ -0,0 +1,28 @@
+--- configure.orig Sat Jun 10 08:43:43 2006
++++ configure Sat Jun 24 18:41:41 2006
+@@ -1311,7 +1311,7 @@
+
+
+ PACKAGE=homebank
+-VERSION=3.2 alpha
++VERSION=3.2.a1
+
+ am__api_version="1.4"
+ ac_aux_dir=
+@@ -4878,7 +4878,7 @@
+ _ACEOF
+
+
+- ac_config_files="$ac_config_files Makefile data/Makefile src/Makefile images/Makefile po/Makefile.in"
++ ac_config_files="$ac_config_files Makefile src/Makefile images/Makefile po/Makefile.in"
+ cat >confcache <<\_ACEOF
+ # This file is a shell script that caches the results of configure
+ # tests run on this system so they can be shared between configure
+@@ -5416,7 +5416,6 @@
+ case "$ac_config_target" in
+ # Handling of arguments.
+ "Makefile" ) CONFIG_FILES="$CONFIG_FILES Makefile" ;;
+- "data/Makefile" ) CONFIG_FILES="$CONFIG_FILES data/Makefile" ;;
+ "src/Makefile" ) CONFIG_FILES="$CONFIG_FILES src/Makefile" ;;
+ "images/Makefile" ) CONFIG_FILES="$CONFIG_FILES images/Makefile" ;;
+ "po/Makefile.in" ) CONFIG_FILES="$CONFIG_FILES po/Makefile.in" ;;
diff --git a/finance/homebank/files/patch-src_Makefile.in b/finance/homebank/files/patch-src_Makefile.in
new file mode 100644
index 000000000000..553c82e842de
--- /dev/null
+++ b/finance/homebank/files/patch-src_Makefile.in
@@ -0,0 +1,11 @@
+--- src/Makefile.in.orig Sat Jun 24 20:51:02 2006
++++ src/Makefile.in Sat Jun 24 20:51:12 2006
+@@ -91,8 +91,6 @@
+
+ homebank_LDADD = $(DEPS_LIBS)
+
+-homebank_LDFLAGS = "-lpng12"
+-
+ AM_CPPFLAGS = $(DEPS_CFLAGS) -DLOCALE_DIR=\""$(datadir)/locale"\" -DPIXMAPS_DIR=\""$(datadir)/images/homebank"\"
+
+ mkinstalldirs = $(SHELL) $(top_srcdir)/mkinstalldirs
diff --git a/finance/homebank/files/patch-src_dsp_wallet.c b/finance/homebank/files/patch-src_dsp_wallet.c
new file mode 100644
index 000000000000..f4f91d509fff
--- /dev/null
+++ b/finance/homebank/files/patch-src_dsp_wallet.c
@@ -0,0 +1,13 @@
+--- src/dsp_wallet.c.orig Sat Jun 24 20:41:27 2006
++++ src/dsp_wallet.c Sat Jun 24 20:41:55 2006
+@@ -82,8 +82,8 @@
+ void wallet_update(GtkWidget *widget, gpointer user_data);
+ void wallet_check_automated(GtkWidget *widget, gpointer user_data);
+ void wallet_addoperations(GtkWidget *widget, gpointer user_data);
+-void wallet_importamiga(GtkWidget *widget, gpointer user_data);
+-void wallet_importgrisbi(GtkWidget *widget, gpointer user_data);
++void wallet_import_amiga(GtkWidget *widget, gpointer user_data);
++void wallet_import_grisbi(GtkWidget *widget, gpointer user_data);
+
+
+ enum
diff --git a/finance/homebank/files/patch-src_homebank.h b/finance/homebank/files/patch-src_homebank.h
new file mode 100644
index 000000000000..69f51b27a3f8
--- /dev/null
+++ b/finance/homebank/files/patch-src_homebank.h
@@ -0,0 +1,10 @@
+--- src/homebank.h.orig Sat Jun 24 20:53:39 2006
++++ src/homebank.h Sat Jun 24 20:54:12 2006
+@@ -37,6 +37,7 @@
+ #include "data_access.h"
+ #include "widgets.h"
+ #include "misc.h"
++#include "prototypes.h"
+
+ #include "gtkdateentry.h"
+ #include "gtkchart.h"
diff --git a/finance/homebank/files/patch-src_rep_budget.c b/finance/homebank/files/patch-src_rep_budget.c
new file mode 100644
index 000000000000..66672bff58f0
--- /dev/null
+++ b/finance/homebank/files/patch-src_rep_budget.c
@@ -0,0 +1,10 @@
+--- src/rep_budget.c.orig Sat Jun 24 20:49:04 2006
++++ src/rep_budget.c Sat Jun 24 20:49:20 2006
+@@ -135,6 +135,7 @@
+ void repbudget_toggle_detail(GtkWidget *widget, gpointer user_data);
+ void repbudget_detail(GtkWidget *widget, gpointer user_data);
+ void repbudget_compute(GtkWidget *widget, gpointer user_data);
++void repbudget_update_detail(GtkWidget *widget, gpointer user_data);
+ void repbudget_update_total(GtkWidget *widget, gpointer user_data);
+ void repbudget_action(GtkWidget *widget, gpointer user_data);
+ void repbudget_sensitive(GtkWidget *widget, gpointer user_data);
diff --git a/finance/homebank/pkg-descr b/finance/homebank/pkg-descr
new file mode 100644
index 000000000000..ba8d3d72b943
--- /dev/null
+++ b/finance/homebank/pkg-descr
@@ -0,0 +1,13 @@
+HomeBank is the free software you have always wanted to manage your
+personal accounts at home. The main concept is to be light, simple and
+very easy to use. It brings you many features that allows you to analyze
+your finances in adetailed way instantly and dynamically with powerfull
+report tools based on filtering and graphical charts.
+
+Furthermore HomeBank benefits now for more than 10 years of users
+experiences and feedbacks as its development started in 1995 on Amiga
+computers. It is now available on Amiga, GNU/Linux, and will probably be
+soon available for Microsoft Windows and MacOS X systems, as GTK+ exists
+on it.
+
+WWW: http://homebank.free.fr/
diff --git a/finance/homebank/pkg-plist b/finance/homebank/pkg-plist
new file mode 100644
index 000000000000..2273e2bfb4f6
--- /dev/null
+++ b/finance/homebank/pkg-plist
@@ -0,0 +1,53 @@
+bin/homebank
+%%PORTDOCS%%%%DOCSDIR%%/AUTHORS
+%%PORTDOCS%%%%DOCSDIR%%/COPYING
+%%PORTDOCS%%%%DOCSDIR%%/ChangeLog
+%%PORTDOCS%%%%DOCSDIR%%/LICENSE
+%%PORTDOCS%%%%DOCSDIR%%/NEWS
+%%PORTDOCS%%%%DOCSDIR%%/README
+share/images/homebank/account.svg
+share/images/homebank/archive.svg
+share/images/homebank/banktransfert.svg
+share/images/homebank/budget.svg
+share/images/homebank/cash.svg
+share/images/homebank/category.svg
+share/images/homebank/cheque.svg
+share/images/homebank/creditcard.svg
+share/images/homebank/document-new.svg
+share/images/homebank/document-open.svg
+share/images/homebank/document-save.svg
+share/images/homebank/filter.svg
+share/images/homebank/homebank.svg
+share/images/homebank/legend.svg
+share/images/homebank/lst_auto.svg
+share/images/homebank/lst_edit.svg
+share/images/homebank/lst_new.svg
+share/images/homebank/lst_remind.svg
+share/images/homebank/lst_vali.svg
+share/images/homebank/ope_add.svg
+share/images/homebank/ope_delete.svg
+share/images/homebank/ope_edit.svg
+share/images/homebank/ope_herit.svg
+share/images/homebank/ope_show.svg
+share/images/homebank/ope_valid.svg
+share/images/homebank/payee.svg
+share/images/homebank/personaltransfert.svg
+share/images/homebank/prf_display.svg
+share/images/homebank/prf_euro.svg
+share/images/homebank/prf_general.svg
+share/images/homebank/prf_help.svg
+share/images/homebank/prf_interface.svg
+share/images/homebank/prf_report.svg
+share/images/homebank/refresh.svg
+share/images/homebank/report_budget.svg
+share/images/homebank/report_car.svg
+share/images/homebank/report_overdrawn.svg
+share/images/homebank/report_stats.svg
+share/images/homebank/view_bar.svg
+share/images/homebank/view_line.svg
+share/images/homebank/view_list.svg
+share/images/homebank/view_pie.svg
+share/locale/fr/LC_MESSAGES/homebank.mo
+@dirrm share/images/homebank
+@dirrm share/images
+%%PORTDOCS%%@dirrm %%DOCSDIR%%