aboutsummaryrefslogtreecommitdiffstats
path: root/finance
diff options
context:
space:
mode:
authoredwin <edwin@FreeBSD.org>2005-12-01 05:48:29 +0800
committeredwin <edwin@FreeBSD.org>2005-12-01 05:48:29 +0800
commit88e5ef4def8cd8339e08356ba7b5a4e6acef6dee (patch)
treea7579479ab4c61a089d41ff404133090bf90b121 /finance
parent9aa14433bdc2a6fb32b667678085a13542794da0 (diff)
downloadfreebsd-ports-gnome-88e5ef4def8cd8339e08356ba7b5a4e6acef6dee.tar.gz
freebsd-ports-gnome-88e5ef4def8cd8339e08356ba7b5a4e6acef6dee.tar.zst
freebsd-ports-gnome-88e5ef4def8cd8339e08356ba7b5a4e6acef6dee.zip
Run pkg-message through SUB_FILES.
Display pkg-message when installing the port (vs the package)
Diffstat (limited to 'finance')
-rw-r--r--finance/pfpro/Makefile8
-rw-r--r--finance/pfpro/files/pkg-message.in (renamed from finance/pfpro/pkg-message)0
2 files changed, 4 insertions, 4 deletions
diff --git a/finance/pfpro/Makefile b/finance/pfpro/Makefile
index 79a5ccc5d230..511650049ab4 100644
--- a/finance/pfpro/Makefile
+++ b/finance/pfpro/Makefile
@@ -19,6 +19,7 @@ RESTRICTED= "Only for VeriSign PayFlow Pro customers"
NO_BUILD= yes
INSTALLS_SHLIB= yes
NO_WRKSUBDIR= yes
+SUB_FILES= pkg-message
PKGMESSAGE= ${WRKDIR}/pkg-message
@@ -43,10 +44,6 @@ some terms and conditions. After downing the SDK, place ${PFP_BUNDLE}\n\
in ${DISTDIR}.\n
.endif
-post-patch:
- @${SED} -e "s,%%PREFIX%%,${PREFIX},g" ${.CURDIR}/pkg-message \
- > ${PKGMESSAGE}
-
do-install:
${INSTALL_PROGRAM} ${FBSDDIR}/bin/pfpro ${PREFIX}/bin
${INSTALL_PROGRAM} ${FBSDDIR}/bin/pfpro-file ${PREFIX}/bin
@@ -55,4 +52,7 @@ do-install:
${MKDIR} ${CERTDIR}
${INSTALL_DATA} ${FBSDDIR}/certs/f73e89fd.0 ${CERTDIR}
+post-install:
+ ${CAT} ${PKGMESSAGE}
+
.include <bsd.port.post.mk>
diff --git a/finance/pfpro/pkg-message b/finance/pfpro/files/pkg-message.in
index 38b6b1fb18dd..38b6b1fb18dd 100644
--- a/finance/pfpro/pkg-message
+++ b/finance/pfpro/files/pkg-message.in