aboutsummaryrefslogtreecommitdiffstats
path: root/finance
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2017-04-02 17:42:48 +0800
committerbapt <bapt@FreeBSD.org>2017-04-02 17:42:48 +0800
commit876d37194c8bd7d1720953195c9fdb2016ca8ed1 (patch)
tree78e5e49a7f8d762e5078b44b18009481a7c461f5 /finance
parent4d7183f89c40b569f9f227a990add74f6c31bfe5 (diff)
downloadfreebsd-ports-gnome-876d37194c8bd7d1720953195c9fdb2016ca8ed1.tar.gz
freebsd-ports-gnome-876d37194c8bd7d1720953195c9fdb2016ca8ed1.tar.zst
freebsd-ports-gnome-876d37194c8bd7d1720953195c9fdb2016ca8ed1.zip
Chase a bunch of failures after libsigc++20 update
New libsigc++20 requires c++11 (it exposes c++11) so explicitly use -std=c++11 where needed. Mark as broken a bunch of ports which are not c++11 compatible
Diffstat (limited to 'finance')
-rw-r--r--finance/libofx/Makefile4
1 files changed, 3 insertions, 1 deletions
diff --git a/finance/libofx/Makefile b/finance/libofx/Makefile
index 78c7c83609b2..57055cfd9f64 100644
--- a/finance/libofx/Makefile
+++ b/finance/libofx/Makefile
@@ -16,7 +16,9 @@ LIB_DEPENDS= libcurl.so:ftp/curl \
libxml++-2.6.so:textproc/libxml++26 \
libosp.so:textproc/opensp
-USES= gettext-runtime gmake iconv libtool localbase pathfix pkgconfig
+USES= gettext-runtime gmake iconv libtool localbase pathfix pkgconfig \
+ compiler:c++11-lang
+USE_CXXSTD= c++11
USE_GNOME= glib20 glibmm libsigc++20 libxml2
CONFIGURE_ARGS= --disable-doxygen --disable-dot --disable-gengetopt \
--with-opensp-includes=${LOCALBASE}/include/OpenSP \