aboutsummaryrefslogtreecommitdiffstats
path: root/finance
diff options
context:
space:
mode:
authormezz <mezz@FreeBSD.org>2010-10-04 01:04:08 +0800
committermezz <mezz@FreeBSD.org>2010-10-04 01:04:08 +0800
commitc40eb11bfcb69a1f67022919c1ff3e57557fccf3 (patch)
treedc3ae78e11891377ca5ee060d8ff95f3a9c5fc50 /finance
parent5e31f2f303675256832fa2cb3f15dc351084e961 (diff)
downloadfreebsd-ports-gnome-c40eb11bfcb69a1f67022919c1ff3e57557fccf3.tar.gz
freebsd-ports-gnome-c40eb11bfcb69a1f67022919c1ff3e57557fccf3.tar.zst
freebsd-ports-gnome-c40eb11bfcb69a1f67022919c1ff3e57557fccf3.zip
Fix the quote price editor adds price data as wrong date. Bump the
PORTREVISION. More details by the submitter: "gnucash quote price editor consume date string and convert the string by strptime(3) then get time_t by mktime(3). And struct tm, a mktime argument is not initialized and mktime detects insane structure and returns -1. So the entry is always added as epoch -1 date." PR: ports/138410 Submitted by: Takanori Watanabe <takawata@init-main.com>
Diffstat (limited to 'finance')
-rw-r--r--finance/gnucash/Makefile2
-rw-r--r--finance/gnucash/files/patch-src_app-utils_guile-util.c11
2 files changed, 12 insertions, 1 deletions
diff --git a/finance/gnucash/Makefile b/finance/gnucash/Makefile
index d146f83305ca..1ccc1afac8b2 100644
--- a/finance/gnucash/Makefile
+++ b/finance/gnucash/Makefile
@@ -8,7 +8,7 @@
PORTNAME= gnucash
PORTVERSION= 2.2.9
-PORTREVISION= 9
+PORTREVISION= 10
CATEGORIES= finance gnome
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}%20%28stable%29/${PORTVERSION} \
http://www.gnucash.org/pub/gnucash/sources/stable/
diff --git a/finance/gnucash/files/patch-src_app-utils_guile-util.c b/finance/gnucash/files/patch-src_app-utils_guile-util.c
new file mode 100644
index 000000000000..de8f77cdf17d
--- /dev/null
+++ b/finance/gnucash/files/patch-src_app-utils_guile-util.c
@@ -0,0 +1,11 @@
+--- src/app-utils/guile-util.c.orig 2008-01-08 10:06:47.000000000 +0900
++++ src/app-utils/guile-util.c 2009-09-01 03:04:30.000000000 +0900
+@@ -1304,6 +1304,8 @@
+
+ g_return_val_if_fail(s && format, -1);
+
++ bzero(&tm, sizeof(tm));
++
+ if (!strptime(s, format, &tm))
+ return -1;
+