aboutsummaryrefslogtreecommitdiffstats
path: root/finance
diff options
context:
space:
mode:
authormarino <marino@FreeBSD.org>2015-05-21 18:08:46 +0800
committermarino <marino@FreeBSD.org>2015-05-21 18:08:46 +0800
commit56cd4e459727038db6e42ef6aa6e429ca36df7e8 (patch)
tree97af54f1a4e8b9c8340cd5904b3c32c640d02236 /finance
parent96f15e76a48515c7a0c25034c628402e8f39ec88 (diff)
downloadfreebsd-ports-gnome-56cd4e459727038db6e42ef6aa6e429ca36df7e8.tar.gz
freebsd-ports-gnome-56cd4e459727038db6e42ef6aa6e429ca36df7e8.tar.zst
freebsd-ports-gnome-56cd4e459727038db6e42ef6aa6e429ca36df7e8.zip
finance/frontaccounting: Upgrade version 2.3.22 => 2.3.24
The version update was done because the port had to address missing PHP modules anyway. Why here: * Add the missing hash, ctype, zlib modules * leverage new options framework to simply options handling * implement NLS option (was listed, but not implemented) * explicitly list DOCS option (implemented but unselectable) * Rename MYSQL option to MYSQL_SERVER because MySQL client is installed unconditionally so the option name was misleading * Unsuppress install commands * Wrap compound commands in parentheses for multijob support * Wrap to 80 columns * Remove bogus post-install cat pkgmessage target * Remove 120 bogus @dir lines introduced in [2] PR: 200265 PR: 194255 [2] Reported by: marino Initial fix: maintainer (ek - purplehat.org) rest of fixes: marino
Diffstat (limited to 'finance')
-rw-r--r--finance/frontaccounting/Makefile40
-rw-r--r--finance/frontaccounting/distinfo4
-rw-r--r--finance/frontaccounting/pkg-plist120
3 files changed, 21 insertions, 143 deletions
diff --git a/finance/frontaccounting/Makefile b/finance/frontaccounting/Makefile
index b64df285fd6f..7c65fd67f8fc 100644
--- a/finance/frontaccounting/Makefile
+++ b/finance/frontaccounting/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= frontaccounting
-DISTVERSION= 2.3.22
+DISTVERSION= 2.3.24
CATEGORIES= finance www
MASTER_SITES= SF/${PORTNAME}/FrontAccounting-2.3/${PORTVERSION}
@@ -12,45 +12,41 @@ COMMENT= Simple, powerful system for the entire ERP chain
LICENSE= GPLv3
LICENSE_FILE= ${WRKSRC}/doc/license.txt
-USES= cpe gettext
-USE_MYSQL= yes
-USE_PHP+= mysql mysqli openssl session
+USES= cpe
+USE_PHP+= mysql mysqli openssl session hash ctype zlib
WRKSRC= ${WRKDIR}/${PORTNAME}
NO_BUILD= yes
-
SUB_FILES= pkg-deinstall pkg-message
+PORTDOCSARGS=
+
+OPTIONS_DEFINE= APACHE LIGHTTPD MYSQL_SERVER NLS DOCS
+OPTIONS_DEFAULT= APACHE MYSQL_SERVER
-OPTIONS_DEFINE= APACHE LIGHTTPD MYSQL NLS
-OPTIONS_DEFAULT= APACHE MYSQL
+MYSQL_SERVER_DESC= MySQL server support
+LIGHTTPD_RUN_DEPENDS= lighttpd:${PORTSDIR}/www/lighttpd
+MYSQL_SERVER_USE= MYSQL=server
+APACHE_USE= APACHE_RUN=22+
+NLS_USES= gettext
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MAPACHE}
-USE_APACHE_RUN= 22+
WANT_PHP_WEB=yes
.endif
-.if ${PORT_OPTIONS:MLIGHTTPD}
-RUN_DEPENDS+= lighttpd:${PORTSDIR}/www/lighttpd
-.endif
-
-.if ${PORT_OPTIONS:MMYSQL}
-USE_MYSQL= server
+.if !${PORT_OPTIONS:MDOCS}
+PORTDOCSARGS= '-not -path "./doc*"'
.endif
-.if ${PORT_OPTIONS:MDOCS}
-PORTDOCSARGS=
-.else
-PORTDOCSARGS= '-not -path "./doc*"'
+.if !${PORT_OPTIONS:MMYSQL_SERVER}
+USE_MYSQL= client
.endif
do-install:
@${MKDIR} ${STAGEDIR}${WWWDIR}
- @cd ${WRKSRC} && ${COPYTREE_SHARE} . ${STAGEDIR}${WWWDIR} ${PORTDOCSARGS}
-
-post-install:
- @${CAT} ${PKGMESSAGE}
+ (cd ${WRKSRC} && ${COPYTREE_SHARE} . \
+ ${STAGEDIR}${WWWDIR} ${PORTDOCSARGS})
.include <bsd.port.mk>
diff --git a/finance/frontaccounting/distinfo b/finance/frontaccounting/distinfo
index 51d50bb0d541..d50f1ed538d9 100644
--- a/finance/frontaccounting/distinfo
+++ b/finance/frontaccounting/distinfo
@@ -1,2 +1,2 @@
-SHA256 (frontaccounting-2.3.22.tar.gz) = aa54b3745f70c84ec458a0fc4ce858f8edc46899a51b25aa0b661caff944e481
-SIZE (frontaccounting-2.3.22.tar.gz) = 1294124
+SHA256 (frontaccounting-2.3.24.tar.gz) = a88a460deee9216c23705cfe95c4e5a37adfd9ecfb31f0c5341b18d66959094a
+SIZE (frontaccounting-2.3.24.tar.gz) = 1277783
diff --git a/finance/frontaccounting/pkg-plist b/finance/frontaccounting/pkg-plist
index 70c65d8b3389..37791e13d486 100644
--- a/finance/frontaccounting/pkg-plist
+++ b/finance/frontaccounting/pkg-plist
@@ -3,6 +3,7 @@
%%WWWDIR%%/.htaccess
%%WWWDIR%%/CHANGELOG.txt
%%WWWDIR%%/FA.pem
+%%WWWDIR%%/README.md
%%WWWDIR%%/access/index.php
%%WWWDIR%%/access/login.php
%%WWWDIR%%/access/logout.php
@@ -641,122 +642,3 @@
%%WWWDIR%%/tmp/index.php
%%WWWDIR%%/update.html
%%WWWDIR%%/version.php
-@dir %%WWWDIR%%/access
-@dir %%WWWDIR%%/admin/db
-@dir %%WWWDIR%%/admin
-@dir %%WWWDIR%%/applications
-@dir %%WWWDIR%%/company/0/backup
-@dir %%WWWDIR%%/company/0/images
-@dir %%WWWDIR%%/company/0/js_cache
-@dir %%WWWDIR%%/company/0/pdf_files
-@dir %%WWWDIR%%/company/0/reporting
-@dir %%WWWDIR%%/company/0
-@dir %%WWWDIR%%/company
-@dir %%WWWDIR%%/dimensions/includes
-@dir %%WWWDIR%%/dimensions/inquiry
-@dir %%WWWDIR%%/dimensions/view
-@dir %%WWWDIR%%/dimensions
-@dir %%WWWDIR%%/doc
-@dir %%WWWDIR%%/gl/includes/db
-@dir %%WWWDIR%%/gl/includes/ui
-@dir %%WWWDIR%%/gl/includes
-@dir %%WWWDIR%%/gl/inquiry
-@dir %%WWWDIR%%/gl/manage
-@dir %%WWWDIR%%/gl/view
-@dir %%WWWDIR%%/gl
-@dir %%WWWDIR%%/includes/db
-@dir %%WWWDIR%%/includes/lang
-@dir %%WWWDIR%%/includes/page
-@dir %%WWWDIR%%/includes/prefs
-@dir %%WWWDIR%%/includes/ui
-@dir %%WWWDIR%%/includes
-@dir %%WWWDIR%%/install/lang/ar_EG/LC_MESSAGES
-@dir %%WWWDIR%%/install/lang/ar_EG
-@dir %%WWWDIR%%/install/lang/da_DK/LC_MESSAGES
-@dir %%WWWDIR%%/install/lang/da_DK
-@dir %%WWWDIR%%/install/lang/de_DE/LC_MESSAGES
-@dir %%WWWDIR%%/install/lang/de_DE
-@dir %%WWWDIR%%/install/lang/el_GR/LC_MESSAGES
-@dir %%WWWDIR%%/install/lang/el_GR
-@dir %%WWWDIR%%/install/lang/es_MX/LC_MESSAGES
-@dir %%WWWDIR%%/install/lang/es_MX
-@dir %%WWWDIR%%/install/lang/fr_FR/LC_MESSAGES
-@dir %%WWWDIR%%/install/lang/fr_FR
-@dir %%WWWDIR%%/install/lang/id_ID/LC_MESSAGES
-@dir %%WWWDIR%%/install/lang/id_ID
-@dir %%WWWDIR%%/install/lang/it_IT/LC_MESSAGES
-@dir %%WWWDIR%%/install/lang/it_IT
-@dir %%WWWDIR%%/install/lang/ka_GE/LC_MESSAGES
-@dir %%WWWDIR%%/install/lang/ka_GE
-@dir %%WWWDIR%%/install/lang/new_language_template/LC_MESSAGES
-@dir %%WWWDIR%%/install/lang/new_language_template
-@dir %%WWWDIR%%/install/lang/nl_BE/LC_MESSAGES
-@dir %%WWWDIR%%/install/lang/nl_BE
-@dir %%WWWDIR%%/install/lang/pl_PL/LC_MESSAGES
-@dir %%WWWDIR%%/install/lang/pl_PL
-@dir %%WWWDIR%%/install/lang/pt_BR/LC_MESSAGES
-@dir %%WWWDIR%%/install/lang/pt_BR
-@dir %%WWWDIR%%/install/lang/pt_PT/LC_MESSAGES
-@dir %%WWWDIR%%/install/lang/pt_PT
-@dir %%WWWDIR%%/install/lang/sv_SE/LC_MESSAGES
-@dir %%WWWDIR%%/install/lang/sv_SE
-@dir %%WWWDIR%%/install/lang/zh_CN/LC_MESSAGES
-@dir %%WWWDIR%%/install/lang/zh_CN
-@dir %%WWWDIR%%/install/lang
-@dir %%WWWDIR%%/install
-@dir %%WWWDIR%%/inventory/includes/db
-@dir %%WWWDIR%%/inventory/includes
-@dir %%WWWDIR%%/inventory/inquiry
-@dir %%WWWDIR%%/inventory/manage
-@dir %%WWWDIR%%/inventory/view
-@dir %%WWWDIR%%/inventory
-@dir %%WWWDIR%%/js
-@dir %%WWWDIR%%/lang/en_US/LC_MESSAGES
-@dir %%WWWDIR%%/lang/en_US
-@dir %%WWWDIR%%/lang/new_language_template/LC_MESSAGES
-@dir %%WWWDIR%%/lang/new_language_template
-@dir %%WWWDIR%%/lang
-@dir %%WWWDIR%%/manufacturing/includes/db
-@dir %%WWWDIR%%/manufacturing/includes
-@dir %%WWWDIR%%/manufacturing/inquiry
-@dir %%WWWDIR%%/manufacturing/manage
-@dir %%WWWDIR%%/manufacturing/view
-@dir %%WWWDIR%%/manufacturing
-@dir %%WWWDIR%%/modules/_cache
-@dir %%WWWDIR%%/modules
-@dir %%WWWDIR%%/purchasing/allocations
-@dir %%WWWDIR%%/purchasing/includes/db
-@dir %%WWWDIR%%/purchasing/includes/ui
-@dir %%WWWDIR%%/purchasing/includes
-@dir %%WWWDIR%%/purchasing/inquiry
-@dir %%WWWDIR%%/purchasing/manage
-@dir %%WWWDIR%%/purchasing/view
-@dir %%WWWDIR%%/purchasing
-@dir %%WWWDIR%%/reporting/fonts
-@dir %%WWWDIR%%/reporting/forms
-@dir %%WWWDIR%%/reporting/includes/fpdi/decoders
-@dir %%WWWDIR%%/reporting/includes/fpdi
-@dir %%WWWDIR%%/reporting/includes
-@dir %%WWWDIR%%/reporting
-@dir %%WWWDIR%%/sales/allocations
-@dir %%WWWDIR%%/sales/includes/db
-@dir %%WWWDIR%%/sales/includes/ui
-@dir %%WWWDIR%%/sales/includes
-@dir %%WWWDIR%%/sales/inquiry
-@dir %%WWWDIR%%/sales/manage
-@dir %%WWWDIR%%/sales/view
-@dir %%WWWDIR%%/sales
-@dir %%WWWDIR%%/sql
-@dir %%WWWDIR%%/taxes/db
-@dir %%WWWDIR%%/taxes
-@dir %%WWWDIR%%/themes/aqua/images
-@dir %%WWWDIR%%/themes/aqua
-@dir %%WWWDIR%%/themes/cool/images
-@dir %%WWWDIR%%/themes/cool
-@dir %%WWWDIR%%/themes/default/images
-@dir %%WWWDIR%%/themes/default
-@dir %%WWWDIR%%/themes
-@dir %%WWWDIR%%/tmp
-@dir %%WWWDIR%%
-@owner root
-@group wheel