aboutsummaryrefslogtreecommitdiffstats
path: root/finance
diff options
context:
space:
mode:
authorobrien <obrien@FreeBSD.org>2005-04-11 16:04:41 +0800
committerobrien <obrien@FreeBSD.org>2005-04-11 16:04:41 +0800
commit6b02d1b35c173832c085697cf76aa156d04ad843 (patch)
tree195cb55f1eda849521409154920849cf102b91fa /finance
parent93ea51bfc3219265c52c39374430d10201b8f436 (diff)
downloadfreebsd-ports-gnome-6b02d1b35c173832c085697cf76aa156d04ad843.tar.gz
freebsd-ports-gnome-6b02d1b35c173832c085697cf76aa156d04ad843.tar.zst
freebsd-ports-gnome-6b02d1b35c173832c085697cf76aa156d04ad843.zip
Assist getting more ports working on AMD64 by obeying the
Ports Collection documentation and use 'ARCH' rather than 'MACHINE_ARCH'.
Diffstat (limited to 'finance')
-rw-r--r--finance/khacc/Makefile2
-rw-r--r--finance/ktoblzcheck/Makefile2
-rw-r--r--finance/qhacc/Makefile2
-rw-r--r--finance/quantlib/Makefile2
4 files changed, 4 insertions, 4 deletions
diff --git a/finance/khacc/Makefile b/finance/khacc/Makefile
index 1e1d7d196c07..d0f3a5ffbfd9 100644
--- a/finance/khacc/Makefile
+++ b/finance/khacc/Makefile
@@ -23,7 +23,7 @@ USE_GMAKE= yes
WANT_AUTOMAKE_VER= 19
WANT_AUTOCONF_VER= 259
GNU_CONFIGURE= yes
-CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ARGS= --with-qhacc-config=${X11BASE}/bin
MAKE_ARGS= ACLOCAL="${TRUE}" AUTOCONF="${TRUE}" AUTOMAKE="${TRUE}" \
AUTOHEADER="${TRUE}"
diff --git a/finance/ktoblzcheck/Makefile b/finance/ktoblzcheck/Makefile
index cc6b660362a4..47035c7dd9ae 100644
--- a/finance/ktoblzcheck/Makefile
+++ b/finance/ktoblzcheck/Makefile
@@ -21,7 +21,7 @@ EXTRACT_DEPENDS=unzip:${PORTSDIR}/archivers/unzip
USE_GMAKE= yes
USE_LIBTOOL_VER= 15
-CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
INSTALLS_SHLIBS= yes
MAN1= ktoblzcheck.1
diff --git a/finance/qhacc/Makefile b/finance/qhacc/Makefile
index be361e31add7..adaff592d32b 100644
--- a/finance/qhacc/Makefile
+++ b/finance/qhacc/Makefile
@@ -21,7 +21,7 @@ USE_X_PREFIX= yes
USE_REINPLACE= yes
USE_GMAKE= yes
USE_LIBTOOL_VER= 15
-CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ARGS= --with-qt-moc=${QT_PREFIX}/bin \
--with-qt-libs=${QT_PREFIX}/lib
MAKE_ARGS= ACLOCAL="${TRUE}" AUTOCONF="${TRUE}" AUTOMAKE="${TRUE}" \
diff --git a/finance/quantlib/Makefile b/finance/quantlib/Makefile
index 4dfc4dbe336c..cd6170d22941 100644
--- a/finance/quantlib/Makefile
+++ b/finance/quantlib/Makefile
@@ -22,7 +22,7 @@ WRKSRC= ${WRKDIR}/QuantLib-${PORTVERSION}
USE_GCC= 3.3
USE_REINPLACE= yes
GNU_CONFIGURE= yes
-CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ENV= CPPFLAGS="${PTHREAD_CFLAGS}" LDFLAGS="${PTHREAD_LIBS}"
INSTALLS_SHLIB= yes