aboutsummaryrefslogtreecommitdiffstats
path: root/french/aster/files
diff options
context:
space:
mode:
authorthierry <thierry@FreeBSD.org>2012-07-07 23:15:57 +0800
committerthierry <thierry@FreeBSD.org>2012-07-07 23:15:57 +0800
commit726ffef471eca6d32679402fd3a5d14eb4f9104e (patch)
treeef4b4db281d1c7ee910e1f2045f2b3da1b1ac7e8 /french/aster/files
parent8d118c7017be387768cac6f95dde7a629dc3b07f (diff)
downloadfreebsd-ports-gnome-726ffef471eca6d32679402fd3a5d14eb4f9104e.tar.gz
freebsd-ports-gnome-726ffef471eca6d32679402fd3a5d14eb4f9104e.tar.zst
freebsd-ports-gnome-726ffef471eca6d32679402fd3a5d14eb4f9104e.zip
Upgrade Code_Aster to 10.6.0-3.
Diffstat (limited to 'french/aster/files')
-rw-r--r--french/aster/files/patch-check_compilers.py19
-rw-r--r--french/aster/files/patch-products.py31
-rw-r--r--french/aster/files/patch-setup.cfg21
-rw-r--r--french/aster/files/patch-setup.py39
4 files changed, 14 insertions, 96 deletions
diff --git a/french/aster/files/patch-check_compilers.py b/french/aster/files/patch-check_compilers.py
deleted file mode 100644
index 8c2f55d5de7a..000000000000
--- a/french/aster/files/patch-check_compilers.py
+++ /dev/null
@@ -1,19 +0,0 @@
---- check_compilers.py.orig 2010-12-22 17:42:47.000000000 +0100
-+++ check_compilers.py 2010-12-27 23:35:57.000000000 +0100
-@@ -602,6 +602,16 @@
- else: # x86_64
- intel_arch = 'intel64'
- mkl_src_name = 'mklvarsem64t.sh'
-+ elif self.platform == 'FREEBSD': # Not yet tested with icc!
-+ if self.arch == 'ia64': # ia64
-+ intel_arch = 'ia64'
-+ mkl_src_name = 'mklvars64.sh'
-+ elif self.arch == 'x86_64': # x86_64
-+ intel_arch = 'ia64'
-+ mkl_src_name = 'mklvars64.sh'
-+ else: # 32 bits
-+ intel_arch = 'ia32'
-+ mkl_src_name = 'mklvars32.sh'
- else:
- raise CheckCompilerError(_('Unsupported platform : %s') % self.platform)
-
diff --git a/french/aster/files/patch-products.py b/french/aster/files/patch-products.py
index 9b85ff2745c8..a6af22d05468 100644
--- a/french/aster/files/patch-products.py
+++ b/french/aster/files/patch-products.py
@@ -1,6 +1,6 @@
---- products.py.orig 2010-12-22 17:42:46.000000000 +0100
-+++ products.py 2010-12-27 23:44:22.000000000 +0100
-@@ -922,15 +922,16 @@
+--- products.py.orig 2012-01-11 16:29:00.000000000 +0100
++++ products.py 2012-04-30 18:10:46.000000000 +0200
+@@ -933,7 +933,8 @@
'HOME_PYTHON', 'PYTHON_EXE', 'PYTHONLIB',
'HOME_MUMPS', 'HOME_ZMAT', 'HOME_MPI', 'INCLUDE_MUMPS', 'HOME_METIS',
'HOME_MED', 'HOME_HDF', 'HOME_CRPCRS', 'HOME_NUMPY', 'USE_NUMPY',
@@ -10,20 +10,9 @@
reqobj=['file:?ASTER_ROOT?/bin/as_run',
'file:?ASTER_ROOT?/etc/codeaster/profile.sh'],
set=['MEDLIB', 'HDFLIB', 'MATHLIB',
- 'MUMPSLIB', 'ZMATLIB', 'SCOTCHLIB',
- 'LDFLAGS',
-- 'CFLAGS', 'CFLAGS_DBG', 'CINCLUDE',
-- 'FFLAGS', 'FFLAGS_DBG', 'FINCLUDE',
-- 'F90FLAGS', 'F90FLAGS_DBG', 'F90INCLUDE',
-+ 'CINCLUDE',
-+ 'FINCLUDE',
-+ 'F90INCLUDE',
- 'NOBUILD', ],
- )
- cfg['ENV_SH'] = cfg.get('ENV_SH', '')
-@@ -968,6 +969,19 @@
+@@ -976,6 +977,19 @@
if cfg['IFDEF'] in ('LINUX', 'P_LINUX'):
- zmat_platform='Linux'
+ zmat_platform = 'Linux'
mpilibs.extend(['mpich'])
+ elif cfg['IFDEF']=='FREEBSD':
+ # Don't check gfortran, already part of SYSLIB
@@ -41,10 +30,10 @@
elif cfg['IFDEF'] == 'LINUX64':
mpilibs.extend(['mpich'])
# others have not been tested !
-@@ -1010,11 +1024,12 @@
- cfg['MEDLIB']=''
+@@ -1031,11 +1045,12 @@
# ----- libs c++ (for MED and ZMAT)
+ #XXX probably to remove (done by check_compiler)
- if cfg['HOME_MED'] != '' or cfg['HOME_ZMAT'] != '':
- for lib in cxxlibs:
- ftools.findlib_and_set(cfg, 'CXXLIB', lib,
@@ -58,8 +47,8 @@
+ # err=False, append=True, maxdepth=max(ftools.maxdepth,10))
# ----- MUMPS
- if cfg['HOME_MUMPS'] != '':
-@@ -1023,12 +1038,15 @@
+ if cfg.get('MUMPSLIB'):
+@@ -1046,12 +1061,15 @@
if not less_than_version(dict_prod['mumps'], '4.8.0'):
mumps_lib.extend(['smumps', 'cmumps', 'mumps_common'])
mumps_lib.extend(['pord', 'mpiseq'])
@@ -80,4 +69,4 @@
+ ftools.CheckFromLastFound(cfg, 'HOME_MUMPS', 'lib')
if cfg['HOME_METIS'] != '':
cfg['MUMPSLIB'] += " -L%s/lib -lmetis" % cfg['HOME_METIS']
- opt['F90INCLUDE'] += ' -I%s' % os.path.join(cfg['ASTER_ROOT'],cfg['ASTER_VERSION'],'bibf90',cfg['INCLUDE_MUMPS'])
+ opt['F90INCLUDE'] += ' -I%s' % osp.join(cfg['ASTER_ROOT'],cfg['ASTER_VERSION'],'bibf90',cfg['INCLUDE_MUMPS'])
diff --git a/french/aster/files/patch-setup.cfg b/french/aster/files/patch-setup.cfg
index c7d2b91e8eca..848c8e2c22d4 100644
--- a/french/aster/files/patch-setup.cfg
+++ b/french/aster/files/patch-setup.cfg
@@ -1,6 +1,6 @@
---- setup.cfg.orig 2010-02-09 10:04:59.000000000 +0100
-+++ setup.cfg 2010-02-17 21:24:28.000000000 +0100
-@@ -56,7 +56,7 @@
+--- setup.cfg.orig 2012-01-11 16:29:00.000000000 +0100
++++ setup.cfg 2012-04-30 18:11:37.000000000 +0200
+@@ -66,7 +66,7 @@
# If a file or library is not found in these directories, you may try
# using 'locate' command. Default is not to use locate because it usually
# causes failure with inconsistent versions.
@@ -9,7 +9,7 @@
USE_LOCATE = False
#-------------------------------------------------------------------------------
-@@ -100,7 +100,7 @@
+@@ -111,7 +111,7 @@
#INCLUDEDIR=['/myprefix/include', ]
# To search for shared libraries first
@@ -18,16 +18,3 @@
#-------------------------------------------------------------------------------
-@@ -140,9 +140,9 @@
-
- #-------------------------------------------------------------------------------
- # Interface between Code_Aster and Salome
--_install_omniORB = True
--_install_omniORBpy = True
--_install_pylotage = True
-+#_install_omniORB = True
-+#_install_omniORBpy = True
-+#_install_pylotage = True
- # Salome version supported by pylotage
- SALOME_VERSION = 'DEFAULT' # DEFAULT means the last one supported by pylotage
-
diff --git a/french/aster/files/patch-setup.py b/french/aster/files/patch-setup.py
deleted file mode 100644
index 5c86f10a8eb2..000000000000
--- a/french/aster/files/patch-setup.py
+++ /dev/null
@@ -1,39 +0,0 @@
---- ./setup.py.orig 2010-02-09 10:04:59.000000000 +0100
-+++ ./setup.py 2010-02-11 23:32:34.000000000 +0100
-@@ -318,6 +318,14 @@
- cfg['ARCH'] = 'x86_64'
- else:
- cfg['IFDEF'] = 'LINUX'
-+ elif sys.platform[:7] == 'freebsd':
-+ cfg['IFDEF']='FREEBSD'
-+ cfg['ARCH'] = 'x86'
-+ if machine.endswith('64'):
-+ if machine in ('x86_64', 'ia64'):
-+ cfg['ARCH'] = machine
-+ else: # force to x86_64
-+ cfg['ARCH'] = 'x86_64'
- elif sys.platform[:4] == 'osf1':
- cfg['IFDEF']='TRU64'
- elif sys.platform == 'sunos5':
-@@ -442,13 +450,6 @@
- if not type(math_lib) in (list, tuple):
- math_lib = [math_lib,]
- sys_lib = []
-- for glob_lib in ('pthread', 'z',):
-- cfg['__tmp__'] = ''
-- del cfg['__tmp__']
-- ftools.findlib_and_set(cfg, '__tmp__', glob_lib, prefshared=True, err=False, silent=False)
-- if cfg.get('__tmp__'):
-- ftools.AddToCache('lib', glob_lib, cfg['__tmp__'])
-- sys_lib.append(glob_lib)
-
- # 1.4.2. ----- check for compilers
- cfg_ini = cfg.copy()
-@@ -541,6 +542,7 @@
- # and modify command line of those which don't have a --display= option
- ListEdit=[
- ['nedit' , 'nedit',],
-+ ['gvim' , 'gvim --display=@D',],
- ['gedit' , 'gedit --display=@D',],
- ['kwrite', 'kwrite --display @D',],
- ['xemacs', 'xemacs -display @D',],