aboutsummaryrefslogtreecommitdiffstats
path: root/french/aster/files
diff options
context:
space:
mode:
authorthierry <thierry@FreeBSD.org>2006-09-24 20:36:11 +0800
committerthierry <thierry@FreeBSD.org>2006-09-24 20:36:11 +0800
commitb246b561b751684d2f8461efe05248847ec25ea6 (patch)
treedf788250958cb307e1b1a5d3f26a5645603cf78a /french/aster/files
parent28c88dd1bc50757b4e4a38478fe3b4ee13847a15 (diff)
downloadfreebsd-ports-gnome-b246b561b751684d2f8461efe05248847ec25ea6.tar.gz
freebsd-ports-gnome-b246b561b751684d2f8461efe05248847ec25ea6.tar.zst
freebsd-ports-gnome-b246b561b751684d2f8461efe05248847ec25ea6.zip
- Catch the exception risen by gethostbyaddr and set a "to be configured"
hostname to fix the build on pointyhat and unbreak; - Take maintainership.
Diffstat (limited to 'french/aster/files')
-rw-r--r--french/aster/files/patch-as_setup.py14
1 files changed, 14 insertions, 0 deletions
diff --git a/french/aster/files/patch-as_setup.py b/french/aster/files/patch-as_setup.py
new file mode 100644
index 000000000000..43e3a50eace2
--- /dev/null
+++ b/french/aster/files/patch-as_setup.py
@@ -0,0 +1,14 @@
+--- as_setup.py.orig Wed Jun 28 18:04:25 2006
++++ as_setup.py Sun Sep 24 12:23:18 2006
+@@ -1170,7 +1170,10 @@
+ from socket import gethostname, gethostbyaddr
+ if host==None:
+ host = gethostname()
+- fqn, alias, ip = gethostbyaddr(host)
++ try:
++ fqn, alias, ip = gethostbyaddr(host)
++ except:
++ fqn='put-your-host-name.here'
+ if fqn.find('localhost')>-1:
+ alias=[a for a in alias if a.find('localhost')<0]
+ if len(alias)>0: