aboutsummaryrefslogtreecommitdiffstats
path: root/french/belote/Makefile
diff options
context:
space:
mode:
authorjylefort <jylefort@FreeBSD.org>2006-11-09 23:27:59 +0800
committerjylefort <jylefort@FreeBSD.org>2006-11-09 23:27:59 +0800
commit8693d0f77c2567bb7f483811d2b7472fe4e7645a (patch)
treed9e4e9f2dde161a3ccf50e95789a1990828a3bcc /french/belote/Makefile
parent5ad6eb568142f1be1ea0355174ce8b813bac5d7e (diff)
downloadfreebsd-ports-gnome-8693d0f77c2567bb7f483811d2b7472fe4e7645a.tar.gz
freebsd-ports-gnome-8693d0f77c2567bb7f483811d2b7472fe4e7645a.tar.zst
freebsd-ports-gnome-8693d0f77c2567bb7f483811d2b7472fe4e7645a.zip
Add belote.
Jouez à la belote coinchée seul contre l'ordinateur ou en réseau. WWW: http://coincher.free.fr/
Diffstat (limited to 'french/belote/Makefile')
-rw-r--r--french/belote/Makefile45
1 files changed, 45 insertions, 0 deletions
diff --git a/french/belote/Makefile b/french/belote/Makefile
new file mode 100644
index 000000000000..6552893c96aa
--- /dev/null
+++ b/french/belote/Makefile
@@ -0,0 +1,45 @@
+# New ports collection makefile for: belote
+# Date created: 09 Nov 2006
+# Whom: Jean-Yves Lefort <jylefort@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= belote
+PORTVERSION= 20061109
+CATEGORIES= french games java
+MASTER_SITES= http://coincher.free.fr/
+DISTNAME= belote
+
+MAINTAINER= jylefort@FreeBSD.org
+COMMENT= Un jeu de belote coinchée contre l'ordinateur ou en réseau
+
+USE_ZIP= yes
+USE_JAVA= yes
+JAVA_VERSION= 1.5+
+NO_WRKSUBDIR= yes
+NO_BUILD= yes
+
+SUB_FILES= belote
+SUB_LIST= JAVA="${JAVA}"
+
+DESKTOP_ENTRIES="Belote" \
+ "Jouer à la belote" \
+ "${PREFIX}/share/pixmaps/belote.gif" \
+ "belote" \
+ "" \
+ false
+
+post-extract:
+ @${UNZIP_CMD} -qo ${WRKSRC}/data.bin rsc/vp.gif -d ${WRKSRC}
+
+do-install:
+ ${INSTALL_SCRIPT} ${WRKDIR}/belote ${PREFIX}/bin
+ ${MKDIR} ${DATADIR}
+.for f in belote.jar data.bin
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${DATADIR}
+.endfor
+ ${MKDIR} ${PREFIX}/share/pixmaps
+ ${INSTALL_DATA} ${WRKSRC}/rsc/vp.gif ${PREFIX}/share/pixmaps/belote.gif
+
+.include <bsd.port.mk>