aboutsummaryrefslogtreecommitdiffstats
path: root/french/gibi
diff options
context:
space:
mode:
authornetchild <netchild@FreeBSD.org>2005-06-18 06:59:29 +0800
committernetchild <netchild@FreeBSD.org>2005-06-18 06:59:29 +0800
commit8d63fa8ce3e1cb7a464d405732fcf971c5848297 (patch)
treebef012ab5e448ce5c144b7bb40139ba1dfd902a6 /french/gibi
parent5f5845bb3ad1db90d601456aaaea7343c4dabfc6 (diff)
downloadfreebsd-ports-gnome-8d63fa8ce3e1cb7a464d405732fcf971c5848297.tar.gz
freebsd-ports-gnome-8d63fa8ce3e1cb7a464d405732fcf971c5848297.tar.zst
freebsd-ports-gnome-8d63fa8ce3e1cb7a464d405732fcf971c5848297.zip
Mega-patch to cleanup the ports infrastructure regarding our linux bits:
- USE_LINUX now implies NO_FILTER_SHLIBS=yes. It also doesn't use FreeBSD tools to strip binaries anymore, so it's not neccesary anymore to override STRIP and STRIP_CMD. - USE_LINUX_PREFIX implies NO_MTREE now. - In the USE_LINUX case, USE_XLIB now depends upon the linux X11 libraries instead upon the native FreeBSD libraries. - The variable LINUX_BASE_PORT contains a string which is suitable as an item in *_DEPENDS, so if a port BATCH_DEPENDS or FETCH_DEPENDS upon the default (or overriden) linux base, ${LINUX_BASE_PORT} should be used instead of a hardcoded reference. - Change all ports to comply to the "new world order". - The Ports Collection now allows to override the default linux_base port. Specify e.g. OVERRIDE_LINUX_BASE_PORT=rh-9 in /etc/make.conf to use ${PORTSDIR}/emulators/linux_base-rh-9 (the logic is to use ${PORTSDIR}/emulators/linux_base-${OVERRIDE_LINUX_BASE_PORT}). - If USE_LINUX or OVERRIDE_LINUX_BASE doesn't point to an existing linux_base port and if USE_LINUX isn't set to "yes" (case insensitive), the port will be marked as IGNORE. [1] - Readd USE_LINUX knobs into several ports and make several uses of a conditional dependency ("USE_LINUX?=") into an unconditional one ("USE_LINUX=") which where removed/changed by Trevor to allow the use of alternative linux_base ports. While this is a nice goal, the implementation resulted in missing dependencies. The OVERRIDE_LINUX_BASE_PORT knob in this commit is supposed to fix the problem while keeping the feature. Basicaly this includes a backout of Trevor's commit, to prevent confusion I mention it here explicitely. - Use the correct prefix (X11- instead of LOCAL- or LINUX-) for some ports. Chase dependencies for this. - Changes to make linux_devtools installable on amd64, remove some stray device nodes (they don't work on recent OS versions and aren't really needed). - Make linux_base-8 PREFIX clean and remove some stray device nodes. Additionally tell a little bit more about how to setup NIS/YP [2]. - Update the PGSQL dependency in the linux-opengroupware port to a recent version (the old one isn't available anymore), I don't know if this works (at least it isn't more broken than before). - Use PREFIX/usr/share/doc instead of PREFIX/usr/doc in the divx4linux ports, the former path exists already and gets populated by other packages too (PREFIX=LINUXPREFIX!). - Fix some obvious (non-linuxolator) bugs in some linux ports while being there. - Bump PORTREVISION where neccesary. Requested by: portmgr (linimon) [1] Submittted by: Gerrit Kuehn <gerrit_huehn@gruft.fido.de [2] Approved by: portmgr (kris, linimon), maintainers (or maintainer timeout) Tested on: ports cluster (kris) Reviewed by: silence on emulation@ Superseedes PR: 69997 Maintainer approval from: chris@chrisburkert.de cracauer@cons.org des girgen jamie@bishopston.net mezz mi nivit@users.sf.net pat simond@irrelevant.org riggs@rrr.de Udo.Schweigert@Siemens.com
Diffstat (limited to 'french/gibi')
-rw-r--r--french/gibi/Makefile7
1 files changed, 4 insertions, 3 deletions
diff --git a/french/gibi/Makefile b/french/gibi/Makefile
index 9cf2ac894f20..2e3e76c69d4d 100644
--- a/french/gibi/Makefile
+++ b/french/gibi/Makefile
@@ -7,7 +7,7 @@
PORTNAME= gibi
PORTVERSION= 2000
-PORTREVISION= 5
+PORTREVISION= 6
CATEGORIES= french cad linux
MASTER_SITES= http://www.code-aster.org/FICHIERS/
DISTNAME= ${PORTNAME}-${PORTVERSION}-1.${ARCH}
@@ -25,7 +25,6 @@ COMMENT= GIBI est la partie mailleur et post de CASTEM
BUILD_DEPENDS+= ${LOCALBASE}/aster/${vaster}/asteru:${PORTSDIR}/french/aster
RUN_DEPENDS+= ${LOCALBASE}/aster/${vaster}/asteru:${PORTSDIR}/french/aster \
- ${LINUXBASE}/usr/X11R6/lib/libXrender.so.1:${PORTSDIR}/x11/linux-XFree86-libs \
${SHELL_RUN_GIBI}:${PORTSDIR}/shells/${SHRGDEP}
RESTRICTED= "Toute personne chargeant le logiciel GIBI s'engage à ne\
@@ -35,6 +34,8 @@ RESTRICTED= "Toute personne chargeant le logiciel GIBI s'engage à ne\
ONLY_FOR_ARCHS= i386
USE_REINPLACE= yes
+USE_LINUX= yes
+USE_X_PREFIX= yes
REINPLACE_ARGS= -i ""
NO_BUILD= yes
@@ -93,7 +94,7 @@ do-install:
${INSTALL_PROGRAM} ${WRKDIR}/bin/${PORTNAME}${ARCHIVER} \
${GIBIDIR}/bin
@${BRANDELF} -t Linux ${GIBIDIR}/bin/${PORTNAME}${ARCHIVER}
- @${BRANDELF} ${GIBIDIR}/DATA/kinstall_${ARCHIVER}
+ @${BRANDELF} -t Linux ${GIBIDIR}/DATA/kinstall_${ARCHIVER}
@(cd ${GIBIDIR}/DATA \
&& ./kinstall_${ARCHIVER} < ${FILESDIR}/clef >/dev/null 2>&1 \
&& ${CHMOD} 666 USRDAT)