aboutsummaryrefslogtreecommitdiffstats
path: root/french/mozilla-flp/Makefile
diff options
context:
space:
mode:
authorthierry <thierry@FreeBSD.org>2004-07-03 14:38:16 +0800
committerthierry <thierry@FreeBSD.org>2004-07-03 14:38:16 +0800
commit08ce9b7a344e0b19b6910a91b5658a93da1fbbc3 (patch)
tree9b663db430cdbfa880c447e2ef8ffa230bee8584 /french/mozilla-flp/Makefile
parent2442a7249f5d677c527daf05c45e66da976450d4 (diff)
downloadfreebsd-ports-gnome-08ce9b7a344e0b19b6910a91b5658a93da1fbbc3.tar.gz
freebsd-ports-gnome-08ce9b7a344e0b19b6910a91b5658a93da1fbbc3.tar.zst
freebsd-ports-gnome-08ce9b7a344e0b19b6910a91b5658a93da1fbbc3.zip
Adding french/mozilla-flp, Mozilla French Language Pack.
Note: the language pack for firefox 0.9.1 is not yet available. PR: ports/63238
Diffstat (limited to 'french/mozilla-flp/Makefile')
-rw-r--r--french/mozilla-flp/Makefile44
1 files changed, 44 insertions, 0 deletions
diff --git a/french/mozilla-flp/Makefile b/french/mozilla-flp/Makefile
new file mode 100644
index 000000000000..91558488b94b
--- /dev/null
+++ b/french/mozilla-flp/Makefile
@@ -0,0 +1,44 @@
+# Ports collection Makefile for: mozilla-flp
+# Date created: Sat Nov 01, 2003
+# Whom: Thierry Thomas (<thierry@pompo.net>)
+#
+# $FreeBSD$
+#
+
+PORTNAME= mozilla-flp
+PORTVERSION= 1.7
+CATEGORIES= french www
+MASTER_SITES= http://frenchmozilla.sourceforge.net/FTP/${PORTVERSION}/
+DISTNAME= mozilla-l10n-fr-FR-${PORTVERSION}
+
+MAINTAINER= thierry@FreeBSD.org
+COMMENT= Mozilla French Language Pack (FLP)
+
+USE_X_PREFIX= yes # Cannot be included after <bsd.port.pre.mk>.
+WRKSRC= ${WRKDIR}/bin
+
+.include <bsd.port.pre.mk>
+.include "${PORTSDIR}/www/mozex/Makefile.xpi"
+
+REPS= defaults/profile/FR/chrome defaults/messenger/FR defaults/isp/FR
+FICHIERS= chrome/FR.jar chrome/fr-FR.jar chrome/fr-unix.jar \
+ components/myspell/fr-FR.aff components/myspell/fr-FR.dic \
+ defaults/isp/FR/movemail.rdf defaults/messenger/FR/mailViews.dat \
+ defaults/profile/FR/bookmarks.html \
+ defaults/profile/FR/chrome/userChrome-example.css \
+ defaults/profile/FR/chrome/userContent-example.css \
+ defaults/profile/FR/localstore.rdf defaults/profile/FR/mimeTypes.rdf \
+ defaults/profile/FR/panels.rdf defaults/profile/FR/search.rdf \
+ searchplugins/jeeves.gif searchplugins/jeeves.src searchplugins/dmoz.gif\
+ searchplugins/dmoz.src searchplugins/google.gif searchplugins/google.src\
+ searchplugins/googlefr.gif searchplugins/googlefr.src
+
+do-install:
+.for rep in ${REPS}
+ @${MKDIR} ${MOZDIR}/${rep}
+.endfor
+.for fichier in ${FICHIERS}
+ @${INSTALL_DATA} ${WRKSRC}/${fichier} ${MOZDIR}/`dirname ${fichier}`
+.endfor
+
+.include <bsd.port.post.mk>