aboutsummaryrefslogtreecommitdiffstats
path: root/french
diff options
context:
space:
mode:
authorthierry <thierry@FreeBSD.org>2015-01-06 04:44:46 +0800
committerthierry <thierry@FreeBSD.org>2015-01-06 04:44:46 +0800
commit64e144e631271fe9056c4be23be4a9f270c8c45d (patch)
tree0a594c3d34494c78827450ee8552a90312ed774a /french
parentc74157985d15bec83df834ee51811db8829e629e (diff)
downloadfreebsd-ports-gnome-64e144e631271fe9056c4be23be4a9f270c8c45d.tar.gz
freebsd-ports-gnome-64e144e631271fe9056c4be23be4a9f270c8c45d.tar.zst
freebsd-ports-gnome-64e144e631271fe9056c4be23be4a9f270c8c45d.zip
Uses the new blaslapack.mk.
Diffstat (limited to 'french')
-rw-r--r--french/aster/Makefile34
1 files changed, 10 insertions, 24 deletions
diff --git a/french/aster/Makefile b/french/aster/Makefile
index 78f927e9c7ce..457cba8f2bcd 100644
--- a/french/aster/Makefile
+++ b/french/aster/Makefile
@@ -45,6 +45,13 @@ RUN_DEPENDS+= ${PYTHON_SITELIBDIR}/Gnuplot:${PORTSDIR}/math/py-gnuplot \
${LOCALBASE}/aster/ASTK/ASTK_SERV:${PORTSDIR}/cad/astk-serveur
USES= bison fortran tk python:2
+
+.if defined(WITH_ATLAS)
+USES+= blaslapack:atlas
+.else
+USES+= blaslapack:netlib
+.endif
+
HAS_CONFIGURE= yes
MAKE_ENV= INCLUDES="${LOCALBASE}/include ${LOCALBASE}/include/metis"
REINPLACE_ARGS= -i ""
@@ -72,19 +79,6 @@ FLAGARCH= -DP_LINUX -DLINUX
FLAGARCH= -DLINUX64
.endif
-# Avoid renaming .f into .F
-#F90FLAGS= -x f77-cpp-input ${FFLAGS}
-
-.if exists(${LOCALBASE}/lib/libatlas.so) && !defined(WITH_BLAS)
-WITH_ATLAS= yes
-.endif
-.if defined(WITH_ATLAS)
-LIB_DEPENDS+= libatlas.so:${PORTSDIR}/math/atlas
-.else
-LIB_DEPENDS+= libblas.so:${PORTSDIR}/math/blas
-LIB_DEPENDS+= liblapack.so:${PORTSDIR}/math/lapack
-.endif
-
.if !defined(WITHOUT_ASTK_CLI)
RUN_DEPENDS+= ${ASTKDIR}:${PORTSDIR}/cad/astk-client
PLIST_SUB+= ASTK_CLIENT="" ASTKDIR=${ASTKDIR}
@@ -187,15 +181,7 @@ v_ifdef= ${OPSYS:tu}
SHELL_INSTALL_ASTER= ${LOCALBASE}/bin/${SHIA}
tcl_dir= ${LOCALBASE}
hdf_dir= ${LOCALBASE}
-.if defined(WITH_ATLAS)
-lib_blas= ptf77blas
-lib_atlas= atlas
-lib_math= "-L${LOCALBASE}/lib -lptf77blas -latlas"
-.else
-lib_blas= blas
-lib_atlas= # empty
-lib_math= "-L${LOCALBASE}/lib -lblas -llapack"
-.endif
+lib_math= "-L${LOCALBASE}/lib ${BLASLIB} ${LAPACKLIB} ${ATLASLIB}"
LASTKDIR?= ${PORTNAME}/ASTK/ASTK_CLIENT
ASTKDIR= ${LOCALBASE}/${LASTKDIR}
@@ -278,9 +264,9 @@ pre-configure:
${ECHO_CMD} "HOME_MED='${LOCALBASE}'" >> ${WRKSRC}/setup.cfg
${ECHO_CMD} "HOME_TCL_TK='${tcl_dir}'" >> ${WRKSRC}/setup.cfg
.if defined(WITH_ATLAS)
- ${ECHO_CMD} "ATLASLIB='${lib_atlas}'" >> ${WRKSRC}/setup.cfg
+ ${ECHO_CMD} "ATLASLIB='${_ATLASLIB}'" >> ${WRKSRC}/setup.cfg
.endif
- ${ECHO_CMD} "BLASLIB='${lib_blas}'" >> ${WRKSRC}/setup.cfg
+ ${ECHO_CMD} "BLASLIB='${_BLASLIB}'" >> ${WRKSRC}/setup.cfg
${ECHO_CMD} "LAPACKLIB='lapack'" >> ${WRKSRC}/setup.cfg
${ECHO_CMD} "GZIP='/usr/bin/gzip'" >> ${WRKSRC}/setup.cfg
${ECHO_CMD} "SHELL_EXECUTION='${SHELL_INSTALL_ASTER}'" >> ${WRKSRC}/setup.cfg