aboutsummaryrefslogtreecommitdiffstats
path: root/french
diff options
context:
space:
mode:
authoredwin <edwin@FreeBSD.org>2003-12-29 14:24:17 +0800
committeredwin <edwin@FreeBSD.org>2003-12-29 14:24:17 +0800
commitc206cc0ead1c70aa0bfa0e8cad72042a3fb96156 (patch)
tree570fa534493ffac4d0cf50f9b5221f75d122f218 /french
parent6dfa17c611a44ff6b2627d971492633b7918ecb8 (diff)
downloadfreebsd-ports-gnome-c206cc0ead1c70aa0bfa0e8cad72042a3fb96156.tar.gz
freebsd-ports-gnome-c206cc0ead1c70aa0bfa0e8cad72042a3fb96156.tar.zst
freebsd-ports-gnome-c206cc0ead1c70aa0bfa0e8cad72042a3fb96156.zip
french/facturier: fixing ${APACHE_PORT} usage.
Problem reported by Matthew Seaman: The french/facturier port uses the ${APACHE_PORT} variable in a manner inconsistent with most other ports that depend on apache, and with the usage in bsd.ports.mk. (also added WWWOWN/WWWGRP) PR: ports/60665 Submitted by: Thierry Thomas <thierry@pompo.net>
Diffstat (limited to 'french')
-rw-r--r--french/facturier/Makefile8
1 files changed, 4 insertions, 4 deletions
diff --git a/french/facturier/Makefile b/french/facturier/Makefile
index 1bfd3784c8ab..113df07f5403 100644
--- a/french/facturier/Makefile
+++ b/french/facturier/Makefile
@@ -14,8 +14,8 @@ EXTRACT_SUFX= .tgz
MAINTAINER= thierry@pompo.net
COMMENT= Logiciel de facturation pour P.M.I. & P.M.E.
-BUILD_DEPENDS= ${LOCALBASE}/sbin/apxs:${APACHE_PORT}
-RUN_DEPENDS= ${LOCALBASE}/sbin/apxs:${APACHE_PORT} \
+BUILD_DEPENDS= ${LOCALBASE}/sbin/apxs:${PORTSDIR}/${APACHE_PORT}
+RUN_DEPENDS= ${LOCALBASE}/sbin/apxs:${PORTSDIR}/${APACHE_PORT} \
${LOCALBASE}/bin/htmldoc:${PORTSDIR}/textproc/htmldoc \
${PBASE}/${PERL_ARCH}/Mysql.pm:${PORTSDIR}/databases/p5-Mysql \
${PBASE}/Tie/IxHash.pm:${PORTSDIR}/devel/p5-Tie-IxHash
@@ -27,7 +27,7 @@ USE_PERL5_RUN= yes
USE_MYSQL= yes
USE_REINPLACE= yes
-APACHE_PORT?= ${PORTSDIR}/www/apache13
+APACHE_PORT?= www/apache13
APACHE_CNFDIR?= ${LOCALBASE}/etc/apache
APACHE_CONF= ${APACHE_CNFDIR}/httpd.conf
PBASE= ${SITE_PERL}
@@ -80,7 +80,7 @@ do-install:
@${RM} ${FACT_CNF}.beforeFacturier
@${CP} -p ${FACT_CNF} ${FACT_CNF}.dist
# Set perms
- @${CHOWN} -R www:www ${FACT_REP}
+ @${CHOWN} -R ${WWWOWN}:${WWWGRP} ${FACT_REP}
@${CHMOD} -R 644 ${FACT_REP}
@${FIND} ${FACT_REP} -type d -exec ${CHMOD} a+x {} \;
@${CHMOD} -R u+x ${FACT_REP}/cgi-bin