aboutsummaryrefslogtreecommitdiffstats
path: root/ftp/IglooFTP/Makefile
diff options
context:
space:
mode:
authorflathill <flathill@FreeBSD.org>1999-05-08 01:43:08 +0800
committerflathill <flathill@FreeBSD.org>1999-05-08 01:43:08 +0800
commitcabbe6b2b55e3d616a8f112bbaf9f9d944527b94 (patch)
treebed3211cf0df8592990a9d0971e33a9d93afb8a1 /ftp/IglooFTP/Makefile
parent1bcf7947891487ad75b0b1cfd84f7c150ec22850 (diff)
downloadfreebsd-ports-gnome-cabbe6b2b55e3d616a8f112bbaf9f9d944527b94.tar.gz
freebsd-ports-gnome-cabbe6b2b55e3d616a8f112bbaf9f9d944527b94.tar.zst
freebsd-ports-gnome-cabbe6b2b55e3d616a8f112bbaf9f9d944527b94.zip
PR: ports/11463
Submitted by: andy@icc.surw.chel.su Easy to use FTP client for X Window System.
Diffstat (limited to 'ftp/IglooFTP/Makefile')
-rw-r--r--ftp/IglooFTP/Makefile43
1 files changed, 43 insertions, 0 deletions
diff --git a/ftp/IglooFTP/Makefile b/ftp/IglooFTP/Makefile
new file mode 100644
index 000000000000..917e999f4422
--- /dev/null
+++ b/ftp/IglooFTP/Makefile
@@ -0,0 +1,43 @@
+# New ports collection makefile for: IglooFTP
+# Version required: 0.6.1
+# Date created: 3 May 1999
+# Whom: Andrey Zakhvatov
+#
+# $Id$
+#
+
+DISTNAME= IglooFTP-0.6.1.src
+PKGNAME= IglooFTP-0.6.1
+CATEGORIES= net
+MASTER_SITES= ${MASTER_SITE_SUNSITE} \
+ ftp://littleigloo.org/pub/iglooftp/
+MASTER_SITE_SUBDIR= system/network/file-transfer
+
+MAINTAINER= andy@icc.surw.chel.su
+
+LIB_DEPENDS= gdk12.1:${PORTSDIR}/x11-toolkits/gtk12 \
+ glib12:${PORTSDIR}/devel/glib12 \
+ gmodule12:${PORTSDIR}/devel/glib12 \
+ gtk12.1:${PORTSDIR}/x11-toolkits/gtk12 \
+ intl:${PORTSDIR}/devel/gettext
+
+USE_X_PREFIX= yes
+
+WRKSRC= ${WRKDIR}/IglooFTP-0.6.1
+
+do-build:
+ @ cd ${WRKSRC}/src; ${MAKE}
+
+do-install:
+ @ cd ${WRKSRC}/src; ${MAKE} install
+ @ ${RM} ${PREFIX}/share/IglooFTP/docs/LICENSE~
+
+post-install:
+.if !defined(NOPORTDOCS)
+ @ ${MKDIR} ${PREFIX}/share/doc/IglooFTP
+.for file in AUTHORS BUGS COPYRIGHT THANKS TODO
+ @ ${INSTALL_DATA} ${WRKSRC}/${file} ${PREFIX}/share/doc/IglooFTP
+.endfor
+.endif
+
+.include <bsd.port.mk>