aboutsummaryrefslogtreecommitdiffstats
path: root/ftp/axyftp/Makefile
diff options
context:
space:
mode:
authorbillf <billf@FreeBSD.org>1998-12-02 06:11:59 +0800
committerbillf <billf@FreeBSD.org>1998-12-02 06:11:59 +0800
commit8c54733f7779c4600d9f8a683b05c9cd39453523 (patch)
tree3ac5b2455c01d04f50b6e1c0c6b23addd8e08215 /ftp/axyftp/Makefile
parent49dff2d7742f47dc0f593758e34bca738f3ef7cc (diff)
downloadfreebsd-ports-gnome-8c54733f7779c4600d9f8a683b05c9cd39453523.tar.gz
freebsd-ports-gnome-8c54733f7779c4600d9f8a683b05c9cd39453523.tar.zst
freebsd-ports-gnome-8c54733f7779c4600d9f8a683b05c9cd39453523.zip
Initial Import.
WXftp is an X Window System FTP client Major features available in current (0.4.0) release: o User-friendly, intuitive interface (both GTK+ and Motif). o Passive data transfers o Convenient session manager window o On-line help system o Recursive downloads with resume option o Recursive uploads o Multiple delete with option to recurse o Auto-redial option WXftp is copyright (c) 1998 by Alexander Yukhimets <alexy@edgarmail.com>. All right under the copyright reserved. This committer thinks this program is really neat as well. :> PR: ports/8413 Submitted by: Dirk Froemberg <ibex@physik.TU-Berlin.de>
Diffstat (limited to 'ftp/axyftp/Makefile')
-rw-r--r--ftp/axyftp/Makefile36
1 files changed, 36 insertions, 0 deletions
diff --git a/ftp/axyftp/Makefile b/ftp/axyftp/Makefile
new file mode 100644
index 000000000000..4d197b91fce2
--- /dev/null
+++ b/ftp/axyftp/Makefile
@@ -0,0 +1,36 @@
+# New ports collection makefile for: wxftp
+# Version required: 0.4.0
+# Date created: 22 October 1998
+# Whom: Antti Kaipila <anttik@iki.fi>
+#
+# $Id$
+#
+
+DISTNAME= wxftp-0.4.0.src
+PKGNAME= wxftp-0.4.0
+CATEGORIES= net
+MASTER_SITES= ${MASTER_SITE_SUNSITE}
+MASTER_SITE_SUBDIR= system/network/file-transfer
+
+MAINTAINER= anttik@iki.fi
+
+LIB_DEPENDS= gtk.1:${PORTSDIR}/x11-toolkits/gtk
+
+WRKSRC= ${WRKDIR}/${PKGNAME}/src
+USE_GMAKE= yes
+USE_X_PREFIX= yes
+
+MAN1= wxftp.1
+
+post-build:
+
+ @${CP} ${WRKSRC}/wf ${WRKDIR}/${PKGNAME}/wxftp
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKDIR}/${PKGNAME}/wxftp ${PREFIX}/bin
+ @${CP} ${WRKDIR}/${PKGNAME}/wxftp.1X ${WRKDIR}/${PKGNAME}/wxftp.1
+ ${INSTALL_MAN} ${WRKDIR}/${PKGNAME}/wxftp.1 ${PREFIX}/man/man1
+ @${MKDIR} ${PREFIX}/share/wxftp/help
+ ${INSTALL_DATA} ${WRKDIR}/${PKGNAME}/help/* ${PREFIX}/share/wxftp/help
+
+.include <bsd.port.mk>