aboutsummaryrefslogtreecommitdiffstats
path: root/ftp/bsdftpd-ssl
diff options
context:
space:
mode:
authorkrion <krion@FreeBSD.org>2004-01-12 07:03:43 +0800
committerkrion <krion@FreeBSD.org>2004-01-12 07:03:43 +0800
commit168278c38942b32f0583bcb13fd3f33060a106f8 (patch)
treefe5dec228c40b836843c29a170e7a7a7ac0b130b /ftp/bsdftpd-ssl
parent3cfe0bd625c67963f9e5e676bd587cc961b5d32d (diff)
downloadfreebsd-ports-gnome-168278c38942b32f0583bcb13fd3f33060a106f8.tar.gz
freebsd-ports-gnome-168278c38942b32f0583bcb13fd3f33060a106f8.tar.zst
freebsd-ports-gnome-168278c38942b32f0583bcb13fd3f33060a106f8.zip
- Data transfere may be aborted now with the next message,
because the EINTR error isn't handled: "426 Data connection: Interrupted system call". PR: 61221 Submitted by: maintainer
Diffstat (limited to 'ftp/bsdftpd-ssl')
-rw-r--r--ftp/bsdftpd-ssl/Makefile1
-rw-r--r--ftp/bsdftpd-ssl/files/patch-aa40
2 files changed, 41 insertions, 0 deletions
diff --git a/ftp/bsdftpd-ssl/Makefile b/ftp/bsdftpd-ssl/Makefile
index 2f1584de5667..a536d108fba0 100644
--- a/ftp/bsdftpd-ssl/Makefile
+++ b/ftp/bsdftpd-ssl/Makefile
@@ -7,6 +7,7 @@
PORTNAME= bsdftpd-ssl
PORTVERSION= 1.0.0
+PORTREVISION= 1
CATEGORIES= ftp
MASTER_SITES= http://bsdftpd-ssl.sc.ru/files/bsdftpd-ssl/archive/1.0/src/
DISTNAME= bsdftpd-ssl-${PORTVERSION}
diff --git a/ftp/bsdftpd-ssl/files/patch-aa b/ftp/bsdftpd-ssl/files/patch-aa
new file mode 100644
index 000000000000..533d6dab3b3c
--- /dev/null
+++ b/ftp/bsdftpd-ssl/files/patch-aa
@@ -0,0 +1,40 @@
+--- ftpd/Makefile.FreeBSD.ORI Wed Oct 8 00:59:49 2003
++++ ftpd/Makefile.FreeBSD Mon Jan 12 00:33:53 2004
+@@ -44,7 +44,7 @@
+ CFLAGS+=-Wall
+ ## Feature flags
+ CFLAGS+=-DSETPROCTITLE -DLOGIN_CAP -DVIRTUAL_HOSTING
+-CFLAGS+=-DUSE_SENDFILE
++#CFLAGS+=-DUSE_SENDFILE
+ #CFLAGS+=-DINET6
+
+ YFLAGS=
+--- ftpd/ftpd.c.ORI Mon Nov 10 11:42:45 2003
++++ ftpd/ftpd.c Mon Jan 12 00:36:04 2004
+@@ -2810,6 +2810,17 @@
+ goto oldway;
+ } else
+ #endif /* USE_SSL */
++/* workaround for the problem described in
++ * http://bsdftpd-ssl.sc.ru/news/bfa_20040112.txt */
++#if __FreeBSD__ >= 5
++# if __FreeBSD_version >= 502000
++# define USE_SENDFILE = 1
++# endif
++#else
++# if __FreeBSD_version > 490000
++# define USE_SENDFILE = 1
++# endif
++#endif /* __FreeBSD__ */
+ #ifdef USE_SENDFILE
+ while (err != -1 && filesize > 0) {
+ #ifdef LINUX /* Linux port */
+@@ -2834,7 +2845,7 @@
+
+ if (err == -1) {
+ #ifndef LINUX /* BSD source */
+- if (errno == EAGAIN) {
++ if (errno == EAGAIN || errno == EINTR) {
+ err = 0;
+ continue;
+ }