aboutsummaryrefslogtreecommitdiffstats
path: root/ftp/curl/Makefile
diff options
context:
space:
mode:
authorroam <roam@FreeBSD.org>2007-08-27 23:44:22 +0800
committerroam <roam@FreeBSD.org>2007-08-27 23:44:22 +0800
commit98fd9a8b4d1ebbb43477c45e8c09dd4c275ae011 (patch)
tree11fa888fe6caee8414da588165749d5eee99dd2b /ftp/curl/Makefile
parent3c8469998a546e79f13d955827a41d502b1c95c6 (diff)
downloadfreebsd-ports-gnome-98fd9a8b4d1ebbb43477c45e8c09dd4c275ae011.tar.gz
freebsd-ports-gnome-98fd9a8b4d1ebbb43477c45e8c09dd4c275ae011.tar.zst
freebsd-ports-gnome-98fd9a8b4d1ebbb43477c45e8c09dd4c275ae011.zip
Update to curl-7.16.3.
Fix the (still present in 7.16.3) libssh2 problems, at least so that cURL works with the libssh2 0.17 in our ports tree. PR: 114215 (the basic update) Submitted by: pesho.petrov@gmail.com
Diffstat (limited to 'ftp/curl/Makefile')
-rw-r--r--ftp/curl/Makefile7
1 files changed, 3 insertions, 4 deletions
diff --git a/ftp/curl/Makefile b/ftp/curl/Makefile
index d4d61f453847..1e2ad56cc326 100644
--- a/ftp/curl/Makefile
+++ b/ftp/curl/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= curl
-PORTVERSION= 7.16.1
-PORTREVISION= 1
+PORTVERSION= 7.16.3
CATEGORIES= ftp ipv6 www
MASTER_SITES= http://curl.haxx.se/download/ \
${MASTER_SITE_SOURCEFORGE} \
@@ -124,7 +123,6 @@ CONFIGURE_ARGS+= --without-libidn
.endif
.if defined(WITH_LIBSSH2)
-BROKEN= does not work with libssh2-0.15
LIB_DEPENDS+= ssh2.1:${PORTSDIR}/security/libssh2
CONFIGURE_ARGS+= --with-libssh2=${LOCALBASE}
.else
@@ -148,7 +146,8 @@ post-patch:
post-install:
.if !defined(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}
- ${CP} -r ${WRKSRC}/docs/* ${DOCSDIR}/
+ (cd ${WRKSRC}/docs && exec ${COPYTREE_SHARE} \* ${DOCSDIR} \
+ "! -name Makefile ! -name Makefile.am ! -name Makefile.in ! -name curl.1 ! -name curl-config.1 ! -name *.3")
.endif
# Setting LC_ALL=C is a kludge; maybe curl/libcurl shouldn't actually use