aboutsummaryrefslogtreecommitdiffstats
path: root/ftp/curl/files
diff options
context:
space:
mode:
authorsunpoet <sunpoet@FreeBSD.org>2013-07-12 00:26:26 +0800
committersunpoet <sunpoet@FreeBSD.org>2013-07-12 00:26:26 +0800
commitda258ad9a4ded9a27a8c070a61c3a78fa151c483 (patch)
treed6c77b7a4c1035ef2fe37dd09eb4885e2b07cae0 /ftp/curl/files
parent801115b3a04ad0dcc5b3555121188f6f84953884 (diff)
downloadfreebsd-ports-gnome-da258ad9a4ded9a27a8c070a61c3a78fa151c483.tar.gz
freebsd-ports-gnome-da258ad9a4ded9a27a8c070a61c3a78fa151c483.tar.zst
freebsd-ports-gnome-da258ad9a4ded9a27a8c070a61c3a78fa151c483.zip
- Update to 7.31.0
- Bump PORTREVISION for ftp/curl shlib change - Add TEST_DEPENDS - Convert to new options framework - Adjust options: - Add COOKIES - Add CYASSL, NSS, POLARSSL, THREADED_RESOLVER, TLS_SRP [1] - Add GSSAPI and SPNEGO [2] - Remove KERBEROS4 - Rename LIBIDN to IDN - Remove TRACKMEMORY [1] - Sort option handler - Add SLAVEDIRS: ftp/curl-hiphop - Cosmetic change - Cleanup Makefile header - While I'm here, fix typo (PORTREVSION) in x11-wm/ede/Makefile Changes: http://curl.haxx.se/changes.html PR: ports/172325 (-exp run), ports/177369 (based on) [1] Submitted by: Hirohisa Yamaguchi <umq@ueo.co.jp> [1], hrs (via email) [2] Exp run by: miwi
Diffstat (limited to 'ftp/curl/files')
-rw-r--r--ftp/curl/files/patch-CVE-2013-217438
-rw-r--r--ftp/curl/files/patch-configure41
-rw-r--r--ftp/curl/files/patch-src-tool_operate.c8
3 files changed, 18 insertions, 69 deletions
diff --git a/ftp/curl/files/patch-CVE-2013-2174 b/ftp/curl/files/patch-CVE-2013-2174
deleted file mode 100644
index e0386e951b79..000000000000
--- a/ftp/curl/files/patch-CVE-2013-2174
+++ /dev/null
@@ -1,38 +0,0 @@
-From 6032f0ff672f09babf69d9d42bcde6eb9eeb5bea Mon Sep 17 00:00:00 2001
-From: Daniel Stenberg <daniel@haxx.se>
-Date: Sun, 19 May 2013 23:24:29 +0200
-Subject: [PATCH] Curl_urldecode: no peeking beyond end of input buffer
-
-Security problem: CVE-2013-2174
-
-If a program would give a string like "%" to curl_easy_unescape(), it
-would still consider the % as start of an encoded character. The
-function then not only read beyond the buffer but it would also deduct
-the *unsigned* counter variable for how many more bytes there's left to
-read in the buffer by two, making the counter wrap. Continuing this, the
-function would go on reading beyond the buffer and soon writing beyond
-the allocated target buffer...
-
-Bug: http://curl.haxx.se/docs/adv_20130622.html
-Reported-by: Timo Sirainen
----
- lib/escape.c | 5 +++--
- 1 file changed, 3 insertions(+), 2 deletions(-)
-
-diff --git lib/escape.c lib/escape.c
-index 6a26cf8..aa7db2c 100644
---- lib/escape.c
-+++ lib/escape.c
-@@ -159,7 +159,8 @@ CURLcode Curl_urldecode(struct SessionHandle *data,
-
- while(--alloc > 0) {
- in = *string;
-- if(('%' == in) && ISXDIGIT(string[1]) && ISXDIGIT(string[2])) {
-+ if(('%' == in) && (alloc > 2) &&
-+ ISXDIGIT(string[1]) && ISXDIGIT(string[2])) {
- /* this is two hexadecimal digits following a '%' */
- char hexstr[3];
- char *ptr;
---
-1.7.10.4
-
diff --git a/ftp/curl/files/patch-configure b/ftp/curl/files/patch-configure
index 3510088a3f55..530e871c984a 100644
--- a/ftp/curl/files/patch-configure
+++ b/ftp/curl/files/patch-configure
@@ -6,22 +6,9 @@ Forwarded: not-needed
Author: Peter Pentchev <roam@FreeBSD.org>
Last-Update: 2010-12-19
---- configure.orig 2012-02-26 17:52:21.904908587 +0800
-+++ configure 2012-02-26 17:52:21.929909948 +0800
-@@ -15049,10 +15049,10 @@
- flags_dbg_all="$flags_dbg_all -gdwarf-2"
- flags_dbg_all="$flags_dbg_all -gvms"
- flags_dbg_yes="-g"
-- flags_dbg_off="-g0"
-+ flags_dbg_off=""
- flags_opt_all="-O -O0 -O1 -O2 -O3 -Os"
- flags_opt_yes="-O2"
-- flags_opt_off="-O0"
-+ flags_opt_off=""
- else
- { $as_echo "$as_me:${as_lineno-$LINENO}: result: no" >&5
- $as_echo "no" >&6; }
-@@ -15892,6 +15892,9 @@
+--- configure.orig 2013-02-06 17:47:26.000000000 +0800
++++ configure 2013-02-18 18:25:16.000000000 +0800
+@@ -16651,6 +16651,9 @@
tmp_CFLAGS="$CFLAGS"
tmp_CPPFLAGS="$CPPFLAGS"
@@ -31,7 +18,7 @@ Last-Update: 2010-12-19
ac_var_stripped=""
for word1 in $tmp_CFLAGS; do
ac_var_strip_word="no"
-@@ -15922,6 +15925,7 @@
+@@ -16681,6 +16684,7 @@
done
tmp_CPPFLAGS="$ac_var_stripped"
squeeze tmp_CPPFLAGS
@@ -39,7 +26,7 @@ Last-Update: 2010-12-19
#
if test "$want_debug" = "yes"; then
-@@ -16139,6 +16143,9 @@
+@@ -16898,6 +16902,9 @@
#
if test "$honor_optimize_option" = "yes"; then
@@ -49,7 +36,7 @@ Last-Update: 2010-12-19
ac_var_stripped=""
for word1 in $tmp_CFLAGS; do
ac_var_strip_word="no"
-@@ -16169,6 +16176,7 @@
+@@ -16928,6 +16935,7 @@
done
tmp_CPPFLAGS="$ac_var_stripped"
squeeze tmp_CPPFLAGS
@@ -57,17 +44,17 @@ Last-Update: 2010-12-19
if test "$want_optimize" = "yes"; then
{ $as_echo "$as_me:${as_lineno-$LINENO}: checking if compiler accepts optimizer enabling options" >&5
-@@ -20137,7 +20145,8 @@
+@@ -21379,7 +21387,8 @@
PKGTEST="no"
PREFIX_OPENSSL=$OPT_SSL
- OPENSSL_PCDIR="$OPT_SSL/lib/pkgconfig"
-+ # Use the FreeBSD location of the pkg-config libdir
++ # Use the FreeBSD location of the pkgconf libdir
+ OPENSSL_PCDIR="$LOCALBASE/libdata/pkgconfig"
{ $as_echo "$as_me:${as_lineno-$LINENO}: PKG_CONFIG_LIBDIR will be set to \"$OPENSSL_PCDIR\"" >&5
$as_echo "$as_me: PKG_CONFIG_LIBDIR will be set to \"$OPENSSL_PCDIR\"" >&6;}
if test -f "$OPENSSL_PCDIR/openssl.pc"; then
-@@ -23231,29 +23240,30 @@
+@@ -24725,29 +24734,30 @@
;;
off)
LIB_RTMP="-lrtmp"
@@ -78,9 +65,9 @@ Last-Update: 2010-12-19
*)
PREFIX_RTMP=$OPT_LIBRTMP
+ LIB_RTMP="-lrtmp"
-+ LD_RTMP=-L${PREFIX_RTMP}/lib$libsuff
-+ CPP_RTMP=-I${PREFIX_RTMP}/include
-+ DIR_RTMP=${PREFIX_RTMP}/lib$libsuff
++ LD_RTMP="-L${PREFIX_RTMP}/lib$libsuff"
++ CPP_RTMP="-I${PREFIX_RTMP}/include"
++ DIR_RTMP="${PREFIX_RTMP}/lib$libsuff"
;;
esac
@@ -92,13 +79,13 @@ Last-Update: 2010-12-19
-
LDFLAGS="$LDFLAGS $LD_RTMP"
CPPFLAGS="$CPPFLAGS $CPP_RTMP"
- LIBS="$LIBS $LIB_RTMP"
+ LIBS="$LIB_RTMP $LIBS"
- { $as_echo "$as_me:${as_lineno-$LINENO}: checking for RTMP_Init in -lrtmp" >&5
-$as_echo_n "checking for RTMP_Init in -lrtmp... " >&6; }
+ { $as_echo "$as_me:${as_lineno-$LINENO}: checking for RTMP_Init in $LIB_RTMP" >&5
+$as_echo_n "checking for RTMP_Init in $LIB_RTMP... " >&6; }
- if test "${ac_cv_lib_rtmp_RTMP_Init+set}" = set; then :
+ if ${ac_cv_lib_rtmp_RTMP_Init+:} false; then :
$as_echo_n "(cached) " >&6
else
ac_check_lib_save_LIBS=$LIBS
diff --git a/ftp/curl/files/patch-src-tool_operate.c b/ftp/curl/files/patch-src-tool_operate.c
index a168b8bcec40..01c92c9beeed 100644
--- a/ftp/curl/files/patch-src-tool_operate.c
+++ b/ftp/curl/files/patch-src-tool_operate.c
@@ -1,6 +1,6 @@
---- src/tool_operate.c.orig 2012-01-23 23:31:30.000000000 +0800
-+++ src/tool_operate.c 2012-02-26 17:40:00.117907281 +0800
-@@ -580,22 +580,10 @@
+--- src/tool_operate.c.orig 2012-07-24 01:59:20.000000000 +0800
++++ src/tool_operate.c 2012-09-22 20:54:44.439408357 +0800
+@@ -653,22 +653,10 @@
DEBUGASSERT(!outs.filename);
}
@@ -26,7 +26,7 @@
if(!file) {
helpf(config->errors, "Can't open '%s'!\n", outfile);
res = CURLE_WRITE_ERROR;
-@@ -603,6 +591,19 @@
+@@ -676,6 +664,19 @@
}
outs.fopened = TRUE;
outs.stream = file;