aboutsummaryrefslogtreecommitdiffstats
path: root/ftp/curl
diff options
context:
space:
mode:
authorsunpoet <sunpoet@FreeBSD.org>2014-03-28 00:22:01 +0800
committersunpoet <sunpoet@FreeBSD.org>2014-03-28 00:22:01 +0800
commit9a4714bd1ca59a843c7b62350fc8888e938d6301 (patch)
treebc1c9993eae6e116e13a72a08a7d4dab6fef27b3 /ftp/curl
parent175a3f2444f87b998b1645d3ecd4b5cf41800b41 (diff)
downloadfreebsd-ports-gnome-9a4714bd1ca59a843c7b62350fc8888e938d6301.tar.gz
freebsd-ports-gnome-9a4714bd1ca59a843c7b62350fc8888e938d6301.tar.zst
freebsd-ports-gnome-9a4714bd1ca59a843c7b62350fc8888e938d6301.zip
- Add HTTP2 option
Diffstat (limited to 'ftp/curl')
-rw-r--r--ftp/curl/Makefile6
1 files changed, 4 insertions, 2 deletions
diff --git a/ftp/curl/Makefile b/ftp/curl/Makefile
index 218dbefa5b2e..6129fb017185 100644
--- a/ftp/curl/Makefile
+++ b/ftp/curl/Makefile
@@ -12,7 +12,7 @@ COMMENT?= Non-interactive tool to get files from FTP, GOPHER, HTTP(S) servers
LICENSE= MIT
-OPTIONS_DEFINE= CA_BUNDLE COOKIES CURL_DEBUG DEBUG DOCS EXAMPLES IDN IPV6 LDAP LDAPS LIBSSH2 PROXY RTMP SPNEGO TLS_SRP
+OPTIONS_DEFINE= CA_BUNDLE COOKIES CURL_DEBUG DEBUG DOCS EXAMPLES HTTP2 IDN IPV6 LDAP LDAPS LIBSSH2 PROXY RTMP SPNEGO TLS_SRP
OPTIONS_RADIO= GSSAPI RESOLV SSL
OPTIONS_RADIO_GSSAPI= GSSAPI_BASE HEIMDAL_PORT KRB5_PORT
OPTIONS_RADIO_RESOLV= CARES THREADED_RESOLVER
@@ -81,6 +81,8 @@ HEIMDAL_PORT_CONFIGURE_ON= --with-gssapi=${HEIMDAL_HOME}
HEIMDAL_PORT_CPPFLAGS= -I${HEIMDAL_HOME}/include
HEIMDAL_PORT_LDFLAGS= -L${HEIMDAL_HOME}/lib
HEIMDAL_PORT_LIB_DEPENDS= libgssapi.so:${PORTSDIR}/security/heimdal
+HTTP2_CONFIGURE_OFF= --without-nghttp2
+HTTP2_CONFIGURE_ON= --with-nghttp2=${LOCALBASE}
IDN_CONFIGURE_OFF= --without-libidn
IDN_CONFIGURE_ON= --with-libidn=${LOCALBASE}
IDN_LIB_DEPENDS= libidn.so:${PORTSDIR}/dns/libidn
@@ -153,7 +155,7 @@ CONFIGURE_ARGS+=--without-gssapi
.endif
post-patch:
- @${REINPLACE_CMD} -e 's|\(flags_dbg_off=\)".*"|\1""|; s|\(flags_opt_off=\)".*"|\1""|' ${WRKSRC}/configure
+ @${REINPLACE_CMD} -e 's|\(flags_dbg_off=\)".*"|\1""|; s|\(flags_opt_off=\)".*"|\1""|; s|lib/pkgconfig|libdata/pkgconfig|g' ${WRKSRC}/configure
@${REINPLACE_CMD} -e '/^SUBDIRS = / s|$$| docs|; /^DIST_SUBDIRS = / s| docs||; /cd docs &&/d' ${WRKSRC}/Makefile.in
post-install: