aboutsummaryrefslogtreecommitdiffstats
path: root/ftp/curl
diff options
context:
space:
mode:
authorroam <roam@FreeBSD.org>2009-08-15 21:41:32 +0800
committerroam <roam@FreeBSD.org>2009-08-15 21:41:32 +0800
commitbb85bfcd8dc6c1607079e1158cb304248c7ac422 (patch)
treed6d8cac47384e098d142207f2b4bed1dbb99df2f /ftp/curl
parentde84dc83f8d476755d3b236fa178924a271c2c95 (diff)
downloadfreebsd-ports-gnome-bb85bfcd8dc6c1607079e1158cb304248c7ac422.tar.gz
freebsd-ports-gnome-bb85bfcd8dc6c1607079e1158cb304248c7ac422.tar.zst
freebsd-ports-gnome-bb85bfcd8dc6c1607079e1158cb304248c7ac422.zip
Update the cURL port to 7.19.6.
Diffstat (limited to 'ftp/curl')
-rw-r--r--ftp/curl/Makefile10
-rw-r--r--ftp/curl/distinfo6
-rw-r--r--ftp/curl/files/patch-Makefile.in6
-rw-r--r--ftp/curl/files/patch-docs::libcurl::libcurl-tutorial.313
-rw-r--r--ftp/curl/files/patch-docs::libcurl::libcurl-tutorial.html13
-rw-r--r--ftp/curl/files/patch-include::curl::curl.h22
-rw-r--r--ftp/curl/files/patch-lib::nss.c13
-rw-r--r--ftp/curl/files/patch-lib::url.c6
-rw-r--r--ftp/curl/files/patch-src::main.c10
9 files changed, 22 insertions, 77 deletions
diff --git a/ftp/curl/Makefile b/ftp/curl/Makefile
index f4d7ef86d1e6..b2994bda42fc 100644
--- a/ftp/curl/Makefile
+++ b/ftp/curl/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= curl
-PORTVERSION= 7.19.5
-PORTREVISION= 1
+PORTVERSION= 7.19.6
CATEGORIES= ftp ipv6 www
MASTER_SITES= http://curl.haxx.se/download/ \
${MASTER_SITE_SOURCEFORGE} \
@@ -68,7 +67,8 @@ OPTIONS= CARES "Asynchronous DNS resolution via c-ares" off \
LIBSSH2 "SCP/SFTP support via libssh2" off \
NTLM "NTLM authentication" off \
OPENSSL "OpenSSL support" on \
- PROXY "Proxy support" on
+ PROXY "Proxy support" on \
+ TRACKMEMORY "Enable curl memory diagnostic output" off
.include <bsd.port.pre.mk>
@@ -171,6 +171,10 @@ CONFIGURE_ARGS+= --without-libssh2
CONFIGURE_ARGS+= --enable-debug
.endif
+.if defined(WITH_TRACKMEMORY)
+CONFIGURE_ARGS+= --enable-curldebug
+.endif
+
.if defined(WITH_NTLM)
CONFIGURE_ARGS+= --enable-ntlm
.else
diff --git a/ftp/curl/distinfo b/ftp/curl/distinfo
index f01ccf23cb2b..9a2fb98ff243 100644
--- a/ftp/curl/distinfo
+++ b/ftp/curl/distinfo
@@ -1,3 +1,3 @@
-MD5 (curl-7.19.5.tar.bz2) = 426d161661dce70c8ea9ad8f553363a3
-SHA256 (curl-7.19.5.tar.bz2) = 05ad84a9c8d340917370f357ad9fdce5ea595deb11f4cb70f946fa48c7b02cd0
-SIZE (curl-7.19.5.tar.bz2) = 2298238
+MD5 (curl-7.19.6.tar.bz2) = 8402c1f654c51ad7287aad57c3aa79be
+SHA256 (curl-7.19.6.tar.bz2) = ea88f48c8415f7d3af482e4d241277b2bdbfaffaf285e8001c88c1376cbc1021
+SIZE (curl-7.19.6.tar.bz2) = 2347791
diff --git a/ftp/curl/files/patch-Makefile.in b/ftp/curl/files/patch-Makefile.in
index a71a35c6fb7f..76ab06ec1583 100644
--- a/ftp/curl/files/patch-Makefile.in
+++ b/ftp/curl/files/patch-Makefile.in
@@ -2,8 +2,8 @@ Build and install the documentation as usual, no special handling.
--- a/Makefile.in
+++ b/Makefile.in
-@@ -273,9 +273,9 @@
- libcurl.pc.in vc6curl.dsw
+@@ -297,9 +297,9 @@
+ libcurl.pc.in vc6curl.dsw MacOSX-Framework Android.mk $(CMAKE_DIST)
bin_SCRIPTS = curl-config
-SUBDIRS = lib src
@@ -15,7 +15,7 @@ Build and install the documentation as usual, no special handling.
pkgconfig_DATA = libcurl.pc
all: all-recursive
-@@ -835,12 +835,10 @@
+@@ -859,12 +859,10 @@
# We extend the standard install with a custom hook:
install-data-hook:
cd include && $(MAKE) install
diff --git a/ftp/curl/files/patch-docs::libcurl::libcurl-tutorial.3 b/ftp/curl/files/patch-docs::libcurl::libcurl-tutorial.3
deleted file mode 100644
index f33c20ea172e..000000000000
--- a/ftp/curl/files/patch-docs::libcurl::libcurl-tutorial.3
+++ /dev/null
@@ -1,13 +0,0 @@
-Fix a typo.
-
---- a/docs/libcurl/libcurl-tutorial.3
-+++ b/docs/libcurl/libcurl-tutorial.3
-@@ -754,7 +754,7 @@
-
- - Read the Javascript code and rewrite the same logic in another language.
-
--- Implement a Javascript interpreted, people have successfully used the
-+- Implement a Javascript interpreter, people have successfully used the
- Mozilla Javascript engine in the past.
-
- - Ask your admins to stop this, for a static proxy setup or similar.
diff --git a/ftp/curl/files/patch-docs::libcurl::libcurl-tutorial.html b/ftp/curl/files/patch-docs::libcurl::libcurl-tutorial.html
deleted file mode 100644
index 47d7c7bb4b6b..000000000000
--- a/ftp/curl/files/patch-docs::libcurl::libcurl-tutorial.html
+++ /dev/null
@@ -1,13 +0,0 @@
-Fix a typo.
-
---- a/docs/libcurl/libcurl-tutorial.html
-+++ b/docs/libcurl/libcurl-tutorial.html
-@@ -329,7 +329,7 @@
- <p class="level1">libcurl has no means to interpret or evaluate Javascript and thus it doesn't support this. If you get yourself in a position where you face this nasty invention, the following advice have been mentioned and used in the past:
- <p class="level1">- Depending on the Javascript complexity, write up a script that translates it to another language and execute that.
- <p class="level1">- Read the Javascript code and rewrite the same logic in another language.
--<p class="level1">- Implement a Javascript interpreted, people have successfully used the Mozilla Javascript engine in the past.
-+<p class="level1">- Implement a Javascript interpreter, people have successfully used the Mozilla Javascript engine in the past.
- <p class="level1">- Ask your admins to stop this, for a static proxy setup or similar.
- <p class="level1"><a name="Persistence"></a><h2 class="nroffsh">Persistence Is The Way to Happiness</h2>
- <p class="level0">
diff --git a/ftp/curl/files/patch-include::curl::curl.h b/ftp/curl/files/patch-include::curl::curl.h
deleted file mode 100644
index 5d13f2ecdfef..000000000000
--- a/ftp/curl/files/patch-include::curl::curl.h
+++ /dev/null
@@ -1,22 +0,0 @@
-Fix two minor grammatical errors in comments.
-
---- a/include/curl/curl.h
-+++ b/include/curl/curl.h
-@@ -186,7 +186,7 @@
- size_t nitems,
- void *outstream);
-
--/* this is the return codes for the seek callbacks */
-+/* those are the return codes for the seek callbacks */
- #define CURL_SEEKFUNC_OK 0
- #define CURL_SEEKFUNC_FAIL 1 /* fail the entire transfer */
- #define CURL_SEEKFUNC_CANTSEEK 2 /* tell libcurl seeking can't be done, so
-@@ -1516,7 +1516,7 @@
- * DESCRIPTION
- *
- * curl_global_init() should be invoked exactly once for each application that
-- * uses libcurl and before any call of other libcurl function.
-+ * uses libcurl and before any call of other libcurl functions.
- *
- * This function is not thread-safe!
- */
diff --git a/ftp/curl/files/patch-lib::nss.c b/ftp/curl/files/patch-lib::nss.c
deleted file mode 100644
index c8d57ead0e16..000000000000
--- a/ftp/curl/files/patch-lib::nss.c
+++ /dev/null
@@ -1,13 +0,0 @@
-Fix a typo in a comment.
-
---- a/lib/nss.c
-+++ b/lib/nss.c
-@@ -157,7 +157,7 @@
- #endif
- };
-
--/* following ciphers are new in NSS 3.4 and not enabled by default, therefor
-+/* following ciphers are new in NSS 3.4 and not enabled by default, therefore
- they are enabled explicitly */
- static const int enable_ciphers_by_default[] = {
- TLS_DHE_DSS_WITH_AES_128_CBC_SHA,
diff --git a/ftp/curl/files/patch-lib::url.c b/ftp/curl/files/patch-lib::url.c
index a8baee9d1dcb..510409e91fc2 100644
--- a/ftp/curl/files/patch-lib::url.c
+++ b/ftp/curl/files/patch-lib::url.c
@@ -2,9 +2,9 @@ Different handling of signals and threads.
--- a/lib/url.c
+++ b/lib/url.c
-@@ -719,6 +719,10 @@
- data->set.httpauth = CURLAUTH_BASIC; /* defaults to basic */
- data->set.proxyauth = CURLAUTH_BASIC; /* defaults to basic */
+@@ -792,6 +792,10 @@
+ data->progress.flags |= PGRS_HIDE;
+ data->state.current_speed = -1; /* init to negative == impossible */
+#if defined(__FreeBSD_version)
+ data->set.no_signal = TRUE; /* different handling of signals and threads */
diff --git a/ftp/curl/files/patch-src::main.c b/ftp/curl/files/patch-src::main.c
index 28193e8ea82b..4ef4937d0211 100644
--- a/ftp/curl/files/patch-src::main.c
+++ b/ftp/curl/files/patch-src::main.c
@@ -2,9 +2,9 @@ Use fstat() instead of stat() to avoid a race condition.
--- a/src/main.c
+++ b/src/main.c
-@@ -4355,31 +4355,32 @@
- (-1 == create_dir_hierarchy(outfile, config->errors)))
- return CURLE_WRITE_ERROR;
+@@ -4384,33 +4384,34 @@
+ break;
+ }
- if(config->resume_from_current) {
- /* We're told to continue from where we are now. Get the
@@ -32,7 +32,9 @@ Use fstat() instead of stat() to avoid a race condition.
+ outs.stream=(FILE *) fopen(outfile, "ab");
if (!outs.stream) {
helpf(config->errors, "Can't open '%s'!\n", outfile);
- return CURLE_WRITE_ERROR;
+ free(url);
+ res = CURLE_WRITE_ERROR;
+ break;
}
+
+ if(config->resume_from_current) {