aboutsummaryrefslogtreecommitdiffstats
path: root/ftp/curlpp
diff options
context:
space:
mode:
authorsunpoet <sunpoet@FreeBSD.org>2013-09-20 14:34:15 +0800
committersunpoet <sunpoet@FreeBSD.org>2013-09-20 14:34:15 +0800
commit5ec810ff8d555eccece6fe429ae526a7bbad6c19 (patch)
treec7e45a94b2d95f52c92644c40d7db6a66e10be6d /ftp/curlpp
parent9c2d63e66510748fe377fd985ef392423d1fcea1 (diff)
downloadfreebsd-ports-gnome-5ec810ff8d555eccece6fe429ae526a7bbad6c19.tar.gz
freebsd-ports-gnome-5ec810ff8d555eccece6fe429ae526a7bbad6c19.tar.zst
freebsd-ports-gnome-5ec810ff8d555eccece6fe429ae526a7bbad6c19.zip
- Fix build without libstdc++ by removing hardcoded libstdc++ linkage [1]
- Convert to new LIB_DEPENDS format - Convert to new OPTIONS simplifier Reported by: pkg-fallout [1]
Diffstat (limited to 'ftp/curlpp')
-rw-r--r--ftp/curlpp/Makefile16
1 files changed, 8 insertions, 8 deletions
diff --git a/ftp/curlpp/Makefile b/ftp/curlpp/Makefile
index b8ea2d626c99..fa4b109dcd52 100644
--- a/ftp/curlpp/Makefile
+++ b/ftp/curlpp/Makefile
@@ -10,7 +10,7 @@ MASTER_SITES= GOOGLE_CODE
MAINTAINER= sunpoet@FreeBSD.org
COMMENT= C++ wrapper for libcurl
-LIB_DEPENDS= curl:${PORTSDIR}/ftp/curl
+LIB_DEPENDS= libcurl.so:${PORTSDIR}/ftp/curl
OPTIONS_DEFINE= BOOST DOCS EXAMPELS
@@ -21,15 +21,15 @@ LDFLAGS+= -L${LOCALBASE}/lib
USE_LDCONFIG= yes
USES= pathfix
+BOOST_BUILD_DEPENDS= boost-libs>=1.20.0:${PORTSDIR}/devel/boost-libs
+BOOST_RUN_DEPENDS= ${BOOST_BUILD_DEPENDS}
+BOOST_CONFIGURE_ON= --with-boost=${LOCALBASE}
+BOOST_CONFIGURE_OFF= --without-boost
+
.include <bsd.port.options.mk>
-.if ${PORT_OPTIONS:MBOOST}
-BUILD_DEPENDS+= boost-libs>=1.20.0:${PORTSDIR}/devel/boost-libs
-RUN_DEPENDS+= boost-libs>=1.20.0:${PORTSDIR}/devel/boost-libs
-CONFIGURE_ARGS+=--with-boost=${LOCALBASE}
-.else
-CONFIGURE_ARGS+=--without-boost
-.endif
+post-patch:
+ @${REINPLACE_CMD} -e 's| -lstdc++||' ${WRKSRC}/configure
post-install:
.if ${PORT_OPTIONS:MDOCS}