aboutsummaryrefslogtreecommitdiffstats
path: root/ftp/downloader/Makefile
diff options
context:
space:
mode:
authorbland <bland@FreeBSD.org>2005-03-13 14:38:11 +0800
committerbland <bland@FreeBSD.org>2005-03-13 14:38:11 +0800
commit0aef4a01657463990f3f38b12241302161ee1098 (patch)
treeac8c11e6a6261ab6069fc98600f38c3abde927b1 /ftp/downloader/Makefile
parentd1de33991f846d49dbdead18245bdb7948f46d52 (diff)
downloadfreebsd-ports-gnome-0aef4a01657463990f3f38b12241302161ee1098.tar.gz
freebsd-ports-gnome-0aef4a01657463990f3f38b12241302161ee1098.tar.zst
freebsd-ports-gnome-0aef4a01657463990f3f38b12241302161ee1098.zip
- Fix build broken by GTK+ 2.6 import.
- Remove obsolete REINPLACE patch pattern.
Diffstat (limited to 'ftp/downloader/Makefile')
-rw-r--r--ftp/downloader/Makefile9
1 files changed, 5 insertions, 4 deletions
diff --git a/ftp/downloader/Makefile b/ftp/downloader/Makefile
index 5d00b68c3040..779dc5e59691 100644
--- a/ftp/downloader/Makefile
+++ b/ftp/downloader/Makefile
@@ -38,11 +38,12 @@ BROKEN= "Does not compile on sparc64"
post-patch:
@${REINPLACE_CMD} -e 's| $$OPTFLAGS||g ; \
- s| $$OS_CXXFLAGS||g ; \
- s|-lpthread||g ; \
- s|#define GTK_DISABLE_DEPRECATED||' ${WRKSRC}/configure
+ s| $$OS_CXXFLAGS||g ; \
+ s|-lpthread||g' ${WRKSRC}/configure
@${REINPLACE_CMD} -e 's| DOC||g ; \
- s| share||g' ${WRKSRC}/Makefile.in
+ s| share||g' ${WRKSRC}/Makefile.in
+ @${REINPLACE_CMD} -e 's|GtkCellRendererProgress|tCellRendererProgress|g' \
+ ${WRKSRC}/main/face/lod.cc
post-install:
${INSTALL_MAN} ${WRKSRC}/DOC/nt.1 ${MANPREFIX}/man/man1