aboutsummaryrefslogtreecommitdiffstats
path: root/ftp/frox
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2004-02-04 03:32:37 +0800
committerpav <pav@FreeBSD.org>2004-02-04 03:32:37 +0800
commite8bbea7691b3ba26c40e1a8e17f17f8f357e822a (patch)
tree7ab116f2e646a47c548456b8f93ceb102a207e18 /ftp/frox
parent1364906b95a3bef88474dfa0279650bc2b75fd35 (diff)
downloadfreebsd-ports-gnome-e8bbea7691b3ba26c40e1a8e17f17f8f357e822a.tar.gz
freebsd-ports-gnome-e8bbea7691b3ba26c40e1a8e17f17f8f357e822a.tar.zst
freebsd-ports-gnome-e8bbea7691b3ba26c40e1a8e17f17f8f357e822a.zip
- Fix OPTIONS (they must be before bsd.port.pre.mk)
PR: ports/62296 Submitted by: Sergey Matveychuk <sem@ciam.ru> (maintainer)
Diffstat (limited to 'ftp/frox')
-rw-r--r--ftp/frox/Makefile18
1 files changed, 9 insertions, 9 deletions
diff --git a/ftp/frox/Makefile b/ftp/frox/Makefile
index 79bdf138e596..dda97e2f07ce 100644
--- a/ftp/frox/Makefile
+++ b/ftp/frox/Makefile
@@ -41,6 +41,15 @@ PKGMESSAGE= ${WRKDIR}/pkg-message
CONFIGURE_ARGS= --enable-configfile=${PREFIX}/etc/frox.conf
+OPTIONS= IPFILTER "Use ipfilter instead of ipfw" off \
+ VIRUS_SCAN "Run external virus scaner on each download" off \
+ HTTP_CACHE "Enable use of external cache" on \
+ LOCAL_CACHE "Enable use of local cache" off \
+ CCP "Ftp-proxy style command control programs" on \
+ ROOT_RUN "Allow frox running as root (not recomended)" off
+
+.include <bsd.port.pre.mk>
+
.if defined(WITH_IPFILTER)
CONFIGURE_ARGS+= --enable-ipfilter
.endif
@@ -60,15 +69,6 @@ CONFIGURE_ARGS+= --enable-ccp
CONFIGURE_ARGS+= --enable-run-as-root
.endif
-.include <bsd.port.pre.mk>
-
-OPTIONS= IPFILTER "Use ipfilter instead of ipfw" off \
- VIRUS_SCAN "Run external virus scaner on each download" off \
- HTTP_CACHE "Enable use of external cache" on \
- LOCAL_CACHE "Enable use of local cache" off \
- CCP "Ftp-proxy style command control programs" on \
- ROOT_RUN "Allow frox running as root (not recomended)" off
-
pre-patch:
@${SED} ${SED_SCRIPT} ${PKGDIR}/pkg-message >${PKGMESSAGE}
@${SED} ${SED_SCRIPT} ${FILESDIR}/frox.sh > ${WRKDIR}/frox.sh